Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS Home Button Problems

  1. #1
    Default iPhone 3GS Home Button Problems
    So I have scored the internet searching for anwers and I have found some but not all.

    To start... On day my Jailbroken iPhone 3GS (4.2.1) Home Button Stopped working. Tried everything from soft/hard resets to restoring 4.2.1 with no fix. I opened up the iphone and noticed that both connectors were still there and in the "V" form.

    Where I went wrong: I decided to upgrade thinking it would be fix the issue... so I upgraded to 4.3. Unfortunately I did not realize that iTunes would not let me activate 4.3 without a developers account ($99). So I decided to downgrade... or at least tried. iTunes refused to downgrade giving me a 1015 error. I googled the fix which requires the device to be in DFU mode, which happens to need a Home Button.

    after repeatedly opening and trying to adjust the home button prongs one broke of making the damage permanent... SO! I have ordered a replacement piece but must wait til Monday to get it.

    SO! I eventually was able to get the device into some kind of DFU mode by changing the LLB file with in the 4.2.1 ipws. The device will fail to restore but when it rebooted it was in DFU mode and I was then able to put it in to pwned DFU with Redsn0w. From there I was able to successfully install a CUSTOM 4.2.1 I found from a torrent and able to use the phone.

    So I was kinda back where I started, without a home button. I was able to install cydia with RedSn0w but not Greenpois0n (Greenpois0n would complete but nothing went past "Greenpois0n initiating"). I was able to install "activator" which worked for about 10 mins and then then iPhone went haywire! So, I tried "QuickMe" which worked for about a day and then went haywire again

    iPhone going haywire = The phone acts as though the home button is being touched repetitively or held down. As a result I am continuously being kicked out of apps, entering the multitask mode, search or entering voice control...

    SO! I would be fine if could use "activator" or "QuickMe" but this cause the iPhone to go Haywire (as stated above). How can I fix this little problem while I await my much needed package??

  2. #2
    My guess you bent the prongs and now they're making continuous contact

    Break the other one since it's of no use

  3. #3
    One step ahead of you, I actually broke off the other one right after I broke the first. I even lifted the home button connector and wedged a small piece of foam to try and make contact with the other contact (if that makes sense). All in all, it didn't work. Originally I though that maybe the problem but after many tried the problem seems to be in the software cause it only freaks out after installing activator and/or QuickMe.

  4. #4
    Quote Originally Posted by cpedroson View Post
    One step ahead of you, I actually broke off the other one right after I broke the first. I even lifted the home button connector and wedged a small piece of foam to try and make contact with the other contact (if that makes sense). All in all, it didn't work. Originally I though that maybe the problem but after many tried the problem seems to be in the software cause it only freaks out after installing activator and/or QuickMe.
    Well then restore

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •