+ Reply
Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G 8gb "No-Wifi" issue

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
hi, i have an iPhone 3G 8gb with wifi issues. When i go into SETTINGS, the Wifi tab is greyes out and says "no wifi"..it was so when the phone
...
  1. #1
    What's Jailbreak?
    Join Date
    Feb 2009
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default iPhone 3G 8gb "No-Wifi" issue
    hi,

    i have an iPhone 3G 8gb with wifi issues. When i go into SETTINGS,
    the Wifi tab is greyes out and says "no wifi"..it was so when the phone was on 3.1.3, persisted as i downgraded to 3.1.2 and remained the same as i took it upto the latest 4.2.1 iOS. i recently bought it off a friend for real cheap and do not know the history behind it..any hope?? please help,

    Thank YOu

  2. #2
    Green Apple
    Join Date
    Nov 2010
    Posts
    57
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Exact same problem.

    It was 3.1.2. Restored it to 3.1.2 then JB.
    Restored it to 4.1 Jailbreak and unlock.

    NO luck. Hardware issue

  3. #3
    iPhone? More like MyPhone
    Join Date
    Sep 2010
    Posts
    133
    Thanks
    3
    Thanked 4 Times in 4 Posts

    try settings>general>reset>reset network settings

    mine wouldn't connect and this fixed mine

  4. #4
    iPhoneaholic
    Join Date
    Feb 2008
    Location
    Miami, FL
    Posts
    403
    Thanks
    2
    Thanked 47 Times in 29 Posts

    if it is greyed out after restore, then it not software related... hardware for sure

  5. #5
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,244
    Thanks
    6,599
    Thanked 14,785 Times in 6,878 Posts

    Sounds like hardware issue to me too.

  6. #6
    iPhone Underground A3gOwner's Avatar
    Join Date
    Jun 2009
    Location
    Underground
    Posts
    1,172
    Thanks
    2
    Thanked 117 Times in 110 Posts

    If it is hardware atleast it's probably just the wifi chip which if u got the skills is easy to replace. It's a delicate process tho just a heads up.


    Sent from my iPhone using ModMyi

  7. #7
    What's Jailbreak?
    Join Date
    Feb 2009
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Thank you everyone. With wifi Chips going for 60-80+ bucks i don't think i am going to bother with. However, i am thinking in order to install anything through shsh (ultrasn0w), i will need the mobile terminal installed. Would any of you be able to point me towards that??

  8. #8
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,244
    Thanks
    6,599
    Thanked 14,785 Times in 6,878 Posts

    You can try this to install ultrasnow without wifi:
    
1) download SetupiPhoneBrowser.1.93.exe – Downloads - iphonebrowser - Project Hosting on Google Code
    
2) download ultrasn0w 1.2 .deb – MEGAUPLOAD - The leading online storage and file delivery service
    3) Open iPhoneBrowser – (Create folders Cydia and AutoInstall right after Media) in var/root/Media/Cydia/AutoInstall

    4) Drag & drop ultrasn0w and mobile subrate insiide AutoInstall folder
5) Restart iPhone twice, carrier will come up and enjoy

    (not my instructions, just googled for it)

  9. The Following User Says Thank You to Simon For This Useful Post:

    chirayustha (12-20-2010)

  10. #9
    What's Jailbreak?
    Join Date
    Feb 2009
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Thanks a million, x98car. will try that

  11. #10
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,244
    Thanks
    6,599
    Thanked 14,785 Times in 6,878 Posts

    No prob, hope it works for you.

  12. #11
    What's Jailbreak?
    Join Date
    Feb 2009
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Ok..Interesting new development..i had pretty much given up on the wifi. But yesterday for a brief moment, the wifi was kinda working. I hadn't done anything to it to cause this, i was simply browsing around the phone and when i went into settings, the Wifi was not greyed out, so immediately tried to connect, it did. However when i opened up safari, and tried getting the jailbreakme website to open, it stopped working. It was still detecting the networks but after a while it greyed out again.

    Is this behavior in any way relevant towards a probable issue to any of you guys??
    Thank YOu

  13. #12
    iPhoneaholic
    Join Date
    Feb 2008
    Location
    Miami, FL
    Posts
    403
    Thanks
    2
    Thanked 47 Times in 29 Posts

    sounds like hardware for sure... there is a way to restore to a custom firmware that already has been unlocked. I need to browse thru my stuff because this happened to me once and I installed that firmware and did not need wifi, it was already unlocked as soon as I restored it

    EDIT : it is done with Creamsn0w, just google it, download it, install, enjoy..
    here is the link to the video of "How To" and download links

    [ame]http://vimeo.com/5778145[/ame]
    Last edited by dq13; 12-21-2010 at 08:23 PM.

  14. #13
    What's Jailbreak?
    Join Date
    Dec 2010
    Posts
    13
    Thanks
    1
    Thanked 1 Time in 1 Post
    Do you feel capable in taking your phone apart? Maybe the connection from the wifi antennae is lose.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts