+ Reply
Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Replaced back cover on 3GS. Now GPS reception is bad.

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
I've replaced the back cover on my 3GS with one from eBay because the original cracked. I used the original metal bezel but now my GPS reception is really bad.
...
  1. #1
    Green Apple
    Join Date
    Aug 2008
    Posts
    80
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default Replaced back cover on 3GS. Now GPS reception is bad.
    I've replaced the back cover on my 3GS with one from eBay because the original cracked. I used the original metal bezel but now my GPS reception is really bad. I can't even drive and use google maps.

    I suspect a bad contact between the motherboard and the metal bezel gps antenna. Does anyone have a picture of what it should look like?

    Is there a gps testing app that can show reception and satellite info?

  2. #2
    What's Jailbreak?
    Join Date
    Dec 2008
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Had the same problem mate
    I replaced my whole case with a chrome one and i could only get 2 bars on my phone signal and nothing on the gps
    I just lost the rag and scratched all the chrome off and whala full signal and gps working
    I was also looking for an app with a gps signal bar and the only one i could find was "Runmeter" Its a fitness/running app.

    Bee

  3. #3
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Same thing happened to me. Disassembled the iphone several times, and put it back together but always using the new red chrome back cover I bought on ecaseshop.com
    Turns out the chrome ink was blocking the signals, specially the GPS signal (the assisted gps was still working, but that doesn't give us an accurate position fix).

    When I assembled the iphone using the original back case everithing started working fine again.

    Regards,
    Vitor

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts