+ Reply
Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Home button does not 'press' after screen replacement

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
I am trying to fix an iPhone 3G. I got the broken glass off, and seperated it from the LCD from the bracket. Nothing too hard to this point. Before
...
  1. #1
    iPhone? More like MyPhone
    Join Date
    Jan 2008
    Posts
    143
    Thanks
    6
    Thanked 4 Times in 4 Posts

    Default Home button does not 'press' after screen replacement
    I am trying to fix an iPhone 3G. I got the broken glass off, and seperated it from the LCD from the bracket.

    Nothing too hard to this point.

    Before I put the glass back on, I wanted to make sure that everything was ready and I pushed the home button. I noticed that it would not press. I can push down on the home button but it does not depress. At this point I only have the mid frame in my hand.

    I can press the home button if I put it between my thumb and forefinger so I know the button works, it just will not depress when I push it back down into the midframe.

    I tried putting the midframe back into the case (without the glass) and still it will not 'press'. I didnt want to find this out after I put the new glass on it.

    I cannot figure out why the home button wont work.

    The silver metal circle is on the midframe where the home button makes contact with it (its flush with the midframe).

    I can put something between the midframe (on top of the metal circle) and the home button, and it works like it should. Remove the shim and the same result.

    Its almost as if the home button isnt sitting into the cut out for it and that wont allow the center of the button to contact the metal circle inthe midframe.

    Anyone have any idea what Im doing wrong??

    THANKS

    OK, I figured it out. I found that someone had done something similar and it gave me the clue I needed...

    When I heated up the glass to loosen the adhesive, the plastic of the frame got warm as well. I must have pushed from the button side on it. The frame moved microns.. but enough to make the contact between the button and the frame impossible.

    I warmed it up from the underside and pushed with minumal pressure. After cooling, it worked just like it did before I removed the glass.
    Last edited by billinaz; 07-17-2010 at 07:33 PM. Reason: Automerged Doublepost

  2. #2
    plain jane vanilla (post count restored to FULL AWESOMENESS) cpjr's Avatar
    Join Date
    Jul 2007
    Location
    ATL
    Posts
    11,686
    Thanks
    181
    Thanked 1,461 Times in 1,264 Posts

    Well, I was about to tell you what you did wrong, but sounds like you found it.

  3. #3
    iPhone? More like MyPhone
    Join Date
    Jan 2008
    Posts
    143
    Thanks
    6
    Thanked 4 Times in 4 Posts

    been there before , huh?

  4. #4
    plain jane vanilla (post count restored to FULL AWESOMENESS) cpjr's Avatar
    Join Date
    Jul 2007
    Location
    ATL
    Posts
    11,686
    Thanks
    181
    Thanked 1,461 Times in 1,264 Posts

    Ahhh, if you check out my sig links....Ive been modding/fixing and customizing them for awhile now Pretty much ran into everything.

  5. #5
    iPhone? More like MyPhone
    Join Date
    Jan 2008
    Posts
    143
    Thanks
    6
    Thanked 4 Times in 4 Posts

    Guess you have. How long did it take you to figure it out the first time???

    Took me about 4 hours! I was looking for something that was preventing the button from reaching the contact on the bottom. It didnt occur to me that the plastic had been slightly deformed...

  6. #6
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hi, I am having this issue. I replaced the digitizer and the home button is making perfect contact. Ive checked the little z looking bronze button and it works when I press it with a screw driver touching the outside part of the ipod, is the only way it works. Ive tried different flex cables and buttons and it doesnt work. What solutions do you guys have?

    This is an Itouch 2G btw.
    Last edited by MrStuky; 03-08-2011 at 07:40 PM. Reason: Automerged Doublepost

  7. #7
    Super Moderator Cowboy's Avatar
    Join Date
    Apr 2009
    Location
    Owasso,OK
    Posts
    30,679
    Thanks
    1,049
    Thanked 3,866 Times in 2,206 Posts

    Are they bent far enough to touch the connections on the dock?
    Follow me @LoganWesterman

    Need Your iPhone Unlock Click HERE or Here
    Needs Your iPhone Fixed Pm Me!
    Have a question about Jailbreaking Pm Simon, Annie, Or just about any other member on here

  8. #8
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Yea, I checked and they are touching.

  9. #9
    Super Moderator Cowboy's Avatar
    Join Date
    Apr 2009
    Location
    Owasso,OK
    Posts
    30,679
    Thanks
    1,049
    Thanked 3,866 Times in 2,206 Posts

    Sounds like you need a new one
    Follow me @LoganWesterman

    Need Your iPhone Unlock Click HERE or Here
    Needs Your iPhone Fixed Pm Me!
    Have a question about Jailbreaking Pm Simon, Annie, Or just about any other member on here

  10. #10
    What's Jailbreak?
    Join Date
    Mar 2011
    Location
    South Africa
    Posts
    24
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I had this when i replaced my rear housing, just bent the home button pins a bit and voila!
    Apple Emac G4 | Intel Core i5 | Apple iPhone3G 16GB (aspiring to be an iPhone 4 )

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts