Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Ambient Lightsensor not working (3G)

  1. #1
    Default Ambient Lightsensor not working (3G)
    Hi,

    A few months ago, I replace the digitizer, and both my sensors were not working.
    I found out that it was probably a problem with the midpanel where the sensors are, so I bought a new midpanel with the sensors and cables included.

    I replaced everything, and the iPhone is working good again, except for the ambient ligth sensor.
    The proximity sensor is working well, and the earpiece too.
    Can someone please give me a direction to think on for what the problem could be?
    Could it be that I got a new midpanel with a defective flexcable or sensor? Or could it be the connector on the logicboard? The strange thing is, that my proximitysensor is working like it should (and that uses the same flexcable...)

    Anyway, and help is appreciated. At first I left it this way, but it is starting to bother me that my phone doesn't change the brightness on itsself when I am either in the outdoor, or at night.

    Thanks

  2. #2
    I'm having this same problem on a phone which i replaced the digitizer. Has anyone ever fixed this problem?

  3. #3
    iPhone? More like MyPhone krazy's Avatar
    Join Date
    Sep 2007
    Location
    Orange County, CA
    Posts
    108
    Thanks
    27
    Thanked 20 Times in 19 Posts

    try swapping the screen with a friend's phone and see if it does the same thing. Could be the #3 ribbon that is faulty, or it it could even be a software item that is overridden by something. I know SBSettings have a brightness function that could override the ambient light sensor.
    How to fix #3 CONNECTORS:
    http://hectordtruong.blogspot.com/

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •