Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help Please - Phone Doesn't Charge After Disassembly!

  1. #1
    Default Help Please - Phone Doesn't Charge After Disassembly!
    Hi all,

    I'm new to the forums. Just registered because i was hoping i could get some help. I recently took apart my iphone to replace the back cover because it was so scratched it. Everything went smoothly until i had to remove the logic board. I guess when i was removing it, the ground pin broke off. I just continued to put everything back together. It turned on fine and worked, but after i tried to charge it, it would not hold a charge. Now it is completely out of batteries and i cant get it to charge still. Can anyone help me out at all? Thanks.

    Paul

  2. #2
    plain jane vanilla (post count restored to FULL AWESOMENESS) cpjr's Avatar
    Join Date
    Jul 2007
    Location
    ATL
    Posts
    11,685
    Thanks
    181
    Thanked 1,461 Times in 1,264 Posts

    Well, I hope you registered for more than just help....

    Anyways, there are several hardware issues that could cause that, unfortunately I wouldnt be able to diagnose it without having the phone, and I doubt you have the experience to trace it out.

  3. #3
    Do you think you can possibly list out some of the possible issues that i could look into?

  4. #4
    iPhoneaholic sursture's Avatar
    Join Date
    May 2008
    Location
    US - the land of the fat
    Posts
    366
    Thanks
    4
    Thanked 98 Times in 88 Posts

    An attempt:
    - You say "ground pin broke off" [not clear what you refer to] - there is NO unneeded connection in the phone. If it broke - you MUST fix the connection somehow.
    - [If you have a 2G version] One common failure after phone being disassembled causing battery charging failure is the "middle" battery cable not being attached. Check and reattach.
    Do hope that helps



    _________________________________________________

    **uoʇʇnq sʞuɐɥʇ ǝɥʇ ʇıɥ puɐ puıʞ ǝq noʎ pǝdןǝɥ sɐɥ ǝuoǝɯos ɟı**
    _________________________________________________




  5. The Following User Says Thank You to sursture For This Useful Post:

    pnguyen_3kgt (04-30-2010)

  6. #5
    I dont know if you'll be able to tell by the picture but its circled in red.



    Thats the part that broke off when i tried to take out the board. I have soldered it back on and it touches the metal part of the bezel, but it still doesnt charge.

    Oh, and its a 3G

  7. #6
    iPhoneaholic sursture's Avatar
    Join Date
    May 2008
    Location
    US - the land of the fat
    Posts
    366
    Thanks
    4
    Thanked 98 Times in 88 Posts

    Soldering in an iPhone is a dangerous gamble - it is super sensitive to static discharges [make sure both you AND the soldering iron are firmly grounded].

    I would suggest you try with:
    0) rechecking your repair
    1) a new battery some $4 delivered off eBay [battery contains some electronics], next step
    2) a working main board if you can find one - this as if the connections are all there you might have caused a static discharge damage when re-soldering.
    Do hope that helps



    _________________________________________________

    **uoʇʇnq sʞuɐɥʇ ǝɥʇ ʇıɥ puɐ puıʞ ǝq noʎ pǝdןǝɥ sɐɥ ǝuoǝɯos ɟı**
    _________________________________________________




  8. The Following User Says Thank You to sursture For This Useful Post:

    pnguyen_3kgt (04-30-2010)

  9. #7
    great, thanks a lot. i ordered a battery yesterday so i hope to get it by tomorrow. hopefully i wont need to get a new board

  10. #8
    From what I understand - Red is the part you broken?

    Sorry to say this, but this is what it is....
    1. Both Yellow Boxes are the battery connections
    2. Black is the vibrator motor connections
    3. Blue is the GSM antenna connection

    I'm not sure how bad you broke this area, but if you correctly attach things atleast you can get the battery going. But I'm not sure whether you will be able to fix the GSM antenna connection. Without this you wont get any cellphone connection.

    This also requires some inductor which is in place there. Wiring this part is a bit tough, since it has some 'pressure' in this area against the the dock connector. You may instead need a 'wired' connection to the dock port for getting it going. (Tough - though not impossible).

    If you cannot connect the GSM antenna, but if you manage hooking up the Battery connection atleast you can use it as a iTouch. If you unable to 'touch' the battery contacts you can even solder them through some thin wires. (also depends on whether you damaged something around there)

    I've already replied in another thread about the GSM antenna fixing. Here is the link again:

    www,mauron,net/iphonerepair/

    Good luck!
    Attached Thumbnails Attached Thumbnails -iphoneconnections.jpg  

  11. The Following User Says Thank You to dskum For This Useful Post:

    pnguyen_3kgt (05-01-2010)

  12. #9
    Oh, no, the whole part did not break off. Just the metal yellow thing that sticks out. I thought it was the ground, i guess not. But yea, only that yellow pointy pin thing that sticks out is broken. The rest is still in tact.

  13. #10
    Oh good, then you should be ok soldering it back. Make sure you dont mess up the 'gold' contacts of GSM / battery with solder lead. Also the inductor which is in close proximity with the one you broke.

    Also before putting it back if possible try to clean up the contacts with isopropyl alchohol with a piece of paper towel or cloth. (Available in most medial stores). This cleans up any oil from your fingers which are in contacts as this might interfere with contact quality.

  14. The Following User Says Thank You to dskum For This Useful Post:

    pnguyen_3kgt (05-01-2010)

  15. #11
    hey everyone, thanks for all the replies. i really appreciate the help.

    so i got that pin thing i broke off soldered back on. i bought a new battery as well. now it turns on and everything's fine except that it doesnt charge.

    what does that mean? do i need a new dock port thing?

    also, i just put my phone on my speaker dock. it detects it and plays music and everything, still doesnt charge my phone either though.
    Last edited by pnguyen_3kgt; 05-01-2010 at 03:02 PM.

  16. #12
    any ideas anyone?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •