Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G charge port

  1. #1
    Default iPhone 3G charge port
    Randomly my phone turned off, now it turns on if I plug it into the computer but will not charge from USB or wall....what gives? The phone is basically draining right now and it doesn't seem to be pulling any current...but if I plug it into something initially it turns on...

    Also doesn't get recognized in DFU mode...
    Last edited by Dloc2; 02-12-2010 at 12:59 AM.

  2. #2
    Maybe there is something wrong with the dock assembly. That may be the reason why the port and home button doesn't work.

  3. #3
    Oh those buttons work now. The phone was in my pocket a few hours ago and was off all of the sudden. Now when I plug a usb cable in it will turn on but will not charge, will not be recognized at all.

  4. #4
    Quote Originally Posted by Dloc2 View Post
    Oh those buttons work now. The phone was in my pocket a few hours ago and was off all of the sudden. Now when I plug a usb cable in it will turn on but will not charge, will not be recognized at all.
    I would suggest a new dock assembly since it doesn't charge.

  5. #5
    Gotdamn this phone, beginning to think I'll just get a new one. What's odd is that I had it working perfectly, I actually unplugged it and walked out. Now it's doing this.

    Also, no way this could be the battery? And do I need a whole new dock or just the ribbon?
    Last edited by Dloc2; 02-12-2010 at 03:59 AM.

  6. #6
    Sounds like it could be the battery. Your dock connector seems to be functioning fine, as the phone turns on when plugged into the computer. We see this issue a lot with bad batteries.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  7. The Following User Says Thank You to Melech518 For This Useful Post:

    Dloc2 (02-12-2010)

  8. #7
    Quote Originally Posted by Melech518 View Post
    Sounds like it could be the battery. Your dock connector seems to be functioning fine, as the phone turns on when plugged into the computer. We see this issue a lot with bad batteries.
    Cool, luckily I have a battery lying around here. Before I go yanking this one out, the battery was showing 100% for about 15 minutes while I was using it before it screwed up and I thought that was really odd, now pc or wall doesn't recognize it but it turns on...ALSO, I noticed that the battery doesn't completely drain...sometimes I'd plug it on and it wont show the charge sign but the batt would jump from 38-40-45-51% or so in about 15 seconds...

    Just to be sure, a faulty battery is your guess?

  9. #8
    I say faulty battery, but it could still be the dock connector as well. Out of curiosity, what is the firmware on your phone?
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  10. #9
    It is 3.1.3

    edit*

    Accidentally ripped a ribbon, I'm bundling it up and selling it for parts. Thanks a lot anyway dude!
    Last edited by Dloc2; 02-13-2010 at 01:36 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •