+ Reply
Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone works, but turns off after auto lock

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
I did a quick search and found a few things to try, but my symptoms don't exactly match and I had a few questions. I have a 2G 16Gb with
...
  1. #1
    Green Apple
    Join Date
    Feb 2008
    Location
    Wichita, KS
    Posts
    35
    Thanks
    0
    Thanked 6 Times in 5 Posts

    Default iphone works, but turns off after auto lock
    I did a quick search and found a few things to try, but my symptoms don't exactly match and I had a few questions. I have a 2G 16Gb with a brand new TMobile Sim Card. First off I know the main cause for it happening... DON'T DROP YOU iPHONE IN YOUR DOG'S WATER DISH and definitely don't leave the sim card in reach of your dog while the iPhone dries out (hence the new sim card). Luckily I grabbed it back out before it got "too wet," but it just hasn't been acting the same after I let it dry for a few days.

    I'm not sure if me trying to dry made this symptom appear or if it was from the water. I took off the Antennae cover and had to let the battery run completely out to turn it off.

    If I have the iphone in a disconnected iphone dock and let it auto lock, or if I don't start any apps after... it will run for at least a few hours. If I run an app, and then close it or leave it open the next time it auto locks and stays in sleep for a few minutes...it turns off.

    I am trying the suggestion from one of the other threads to set auto lock to "never" and the brightness to max, and then let the battery go completely dead.

    If that doesn't work does anyone know any other troubleshooting tips. I'm wondering if there is a way that I can have the iPhone save a log of all the processes and commands as it receives them, then if it "autolocks to turn off" I can use the log to narrow down things.

    Before the iphone was successfully turned off after it's bath the power button seemed to have a short causing a constant restart and the "Accessory Message" asking if I wanted to go into Airplane mode came up. Head phone jack works, dock connector works, all speakers work, all the buttons work, but I just can't figure out if which piece needs replaced.

    Any Help would be great.

    D.

  2. #2
    The King Melech518's Avatar
    Join Date
    Feb 2009
    Location
    NYC
    Posts
    4,704
    Thanks
    107
    Thanked 1,140 Times in 586 Posts

    Water damage is a tricky thing, especially on the first gens. There is most likely damage to the main board that is irreversible.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  3. The Following User Says Thank You to Melech518 For This Useful Post:

    scorpius67 (03-12-2010)

  4. #3
    Green Apple
    Join Date
    Feb 2008
    Location
    Wichita, KS
    Posts
    35
    Thanks
    0
    Thanked 6 Times in 5 Posts

    I let the battery run all the way down, charged it fully, and it seems to be working. Maybe it was just the extra time to let the moisture get out of there.

    I'm happy. Now at least I can use it without the risk of it turning itself off.

    I was worried there for a little bit. Glad I bought the sim card reader so I could transfer over all my contacts to the sim for the new phone.

    thanks for the response.

  5. #4
    What's Jailbreak?
    Join Date
    Oct 2009
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    not sure whats going on with mine?.got it wet and dried it out but had the NO SERVICE in top left of screen. got intouch with O2 who sent me a new sim card but trouble is even though itunes tries to upgrade through recovery mode, the NO SERVICE stays in top left of screen and after multiple tries at recovery it just tells me to either install sim card correctly or disconnect and unlock sim with code. PROBLEM..........i cant unlock sim as only screen i get is EMERGENCY CALLS ONLY with all the different languages to boot or,if you press the i in a circle icon, it shows a box saying............
    IMEI:
    UNKNOWN

    ICCID:
    UNKNOWN

    any help or advice would go toward my rehabilitation from subscribing to techno hell

    thanks in advance

    chris

  6. #5
    What's Jailbreak?
    Join Date
    Jan 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I have the same problem after auto-lock phone is death I bay new battery en flex cable en dont help.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts