Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Touch screen cuts out

  1. #1
    Default Touch screen cuts out
    Hey guys,

    Recently I replaced the cracked glass on my 3G, and it went fine.
    Everything worked fine too. But recently the touchscreen will become mostly unresponsive and unuseable. To fix it i just have to hit the lock button, then hit it again and unlock the phone. Then it'll work for a minute or two.

    Which cable number is the one for the touch screen? Cause maybe it's a little loose or something?
    2G iPhone:8Gb/unlocked/T-Mobile/T-Zones ($5.99)/FW2.2.1(5H11)
    LOST in the frozen backcountry of Copper Mountain, CO

    iPhone: 3G/8Gb/unlocked/T-Mobile/T-zones ($5.99)/FW3.1.2

    Mac: because two mouse buttons are scary.

  2. #2
    I have the exact same problem! I'd love to know if anyone has a fix. I've thought about whether it could be a hardware problem, but to me it almost seems like a software problem. How could pressing the lock button and home button cause a hardware problem to go away? I also find as the memory gets lower, the problem gets worse. If I respring my iPhone, the problem almost goes away for a while.

  3. #3
    let's see if we can narrow down the issue.

    what apps and hacks have you done to your phone?

    I've got a 3G with 3.1.2FW. I've deleted all language packs except for english and greek (i use it for my carrier name), I also deleted all the safe daemons listed here and also the com.apple.AOSNotification.plist daemon that controls MobileMe syncing (which i don't use)

    I dunno if any of those plists could affect the touch screen responsiveness though.

    But I also think my issue gets worse when the memory is low.

    so i uninstalled Haptic Pro and it seems to be doing much better
    Last edited by smuth; 01-11-2010 at 01:21 AM. Reason: Automerged Doublepost
    2G iPhone:8Gb/unlocked/T-Mobile/T-Zones ($5.99)/FW2.2.1(5H11)
    LOST in the frozen backcountry of Copper Mountain, CO

    iPhone: 3G/8Gb/unlocked/T-Mobile/T-zones ($5.99)/FW3.1.2

    Mac: because two mouse buttons are scary.

  4. #4
    Mine is a 3G, 3.1, mostly just modded with SBSettings. I didn't try any of the steps that you listed.

  5. #5
    Almost sound like a loose flex cable inside the phone. Weird now the re-spring affects it though.

  6. #6
    Let's solve this issue?

    1.) Did all of you replace the digitizers on your phones?
    2.) If so, are you using an aftermarket Digitizer or an OEM digitizer replacement?
    3.) If it is an aftermarket digitizer, or even if it is not, where did you purchase it?
    4.) Does a hard reset temporarily fix the issue?
    5.) Do you have any cracked app sources installed?

    In November there were a HUGE batch of faulty digitizers being exported from China. They were all recalled but only major distributers/importers/repair shops who place large batch orders were notified. Anyone who purchased a single digitizer from eBay, online, or Craigslist would not have know of this issue.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •