Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: IPhone Charging, but no sign or sync

  1. #1
    Default IPhone Charging, but no sign or sync
    When i try to charge my phone, it doesnt show its charging up right corner... When i wait and the battery is empty, i can see the "lightning" sign come when the phone is totaly off and the "red battery" is in the middle of the screen!

    When it powers up, the phone wont show it charges (BUT IT DOES) and also no connection to computer..

    This means im not able to restore the phone :S

    Any suggestions?
    When i put it in DFU it wont react with the computer :S

  2. #2
    I'm having the same issue. did you solve this?

  3. #3
    Do either of you have water damage to your phone?
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  4. #4
    I don't, I just managed to screwed it up while I was changing the back cover and now I have this battery issue.

  5. #5
    You may have damaged something on the main board while doing your housing swap or you may have damaged the dock connector assembly. What are the symptoms you are experiencing?
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  6. #6
    Basically, the same thing as tori1234 posted. I can charge the Phone even if the icon doesn't represent the actual charge of the battery. But then it won't be recognized by Itunes or by the computer. Now since, it won't show in I-tunes I can't restore it and etc. I've tried DFU, power off, restart reboot but nothing.

    The phone have been jailbreak. so I can SSH my way in if I need to change stuff or modify some corrupt file.
    Has you said, it might be the connector assembly. I guess I should order one since they are not very expensive.

    Any ideas

  7. #7
    Try a new dock connector. If that doesnt solve the problem we will take it from there.

    In the mean time, keep trying to get the phone into recovery or DFU mode and see if you are able to restore. I don't think it is a software problem but it doesnt hurt to keep trying while you wait for the part.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  8. #8
    Thanks for the advice. I will keep you posted whether it work or not.

  9. #9
    I have this exact same problem...and replaced the dock connector last night. No luck. When plugged in, the phone will charge but no indicator. Nothing happens when I plug it into a computer in any mode. I have tried different cables and computers...even put the mainboard in another phone. Same problem. I deleted all apps on the phone thinking it was a software problem. The only thing that I haven't tried is a full master reset on the phone...which I am afraid to do as there are 350 pictures I need to get off the phone (it is not mine, I would never leave that many images on a phone without back up!)

    Any Ideas?

  10. #10
    Email all of the pictures to yourself and then try to reset all settings. I doubt it is a software issue. Sounds like a logic board problem. I would also try different methods of getting the phone into DFU mode
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  11. #11
    I already emailed most of the photos to me...one by one...because the phone is running 2.2.1.

    I also noted that there is about 500 unread emails on the phone, I deleted the account...I wonder if that is causing some of the problems. I am hesitant to do the master reset as I don't think it will work...I should let the phone owner try it.

  12. #12
    This is a phone you are repairing for a customer? Give it back and admit you are stumped. It is not right to try to turn a profit if you cannot fix it. It is also not right to delete all of his information when you do not know what you are doing.

    Look up his phones serial and check to see the warranty status on it. If it is under warranty, let him deal with it. There is a good possibility that there is a hardware issue with the phone keeping it from being detected.
    If I helped you, hit the button or be Banned!

    Download Macbook 3.1 for Winterboard-Now LIVE on Cydia-Macbook Final, Macbook Final Widget,Macbook SBSettings
    Need Hardware Repair Support?: PM ME

  13. #13
    It's actually my brother's...it is out of warranty. He mailed it to me from across the country. He also said to decide which photos would be worth saving...but I do not want to take a chance. No profit being made here.
    Last edited by Poomobile; 01-31-2010 at 08:41 AM.

  14. #14
    Quote Originally Posted by Melech518 View Post
    You may have damaged something on the main board while doing your housing swap or you may have damaged the dock connector assembly. What are the symptoms you are experiencing?
    It's not the dock connector. You damaged one of the resistors on the logic board when you swapped out the housing. I unknowingly did the exact same thing to one of my 3G boards...and ending up with the same symptoms that you have described; the phone will charge even though it doesn't look like it is, but it no longer is recognized by my laptop or able to sync with iTunes. There's nothing you can do, unless you can find someone who can possibly solder a new resistor on the board for you...and I'm not even sure that's possible. I sent mine off to CPJR (a member here who repairs iPhones) and he said the chances were pretty slim. Those resistors are super miniscule.

  15. #15
    What's Jailbreak?
    Join Date
    Dec 2009
    Location
    http://www.accessorypal.com
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Please check for missing components around flex connector 1.
    Other day I fixed same problem.

  16. #16
    Default Follow-up
    In my case it seems like a logic board problem. I've try another dock but no luck. Same thing with the touch screen, I've put a new one in and still no sound from the ear-speaker.

    GSmalers, I'm curious of how you fixed your phone.

    Franberry did the soldering solved your issue ?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •