Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone screen colors gone craz

  1. #1
    Default iPhone screen colors gone craz
    Is this hardware or software related?

    I soldered on a new batter for my 2G and this is how the screen looks after I put everything back together.

    The touch screen works fine and everything seems to be displayed in the correct location. But the colors are totally wrong.

    I need to know whether it is hardware or software related? Do I need a new ribbon or a new phone?


  2. #2
    Have you checked all the LCD related cables/ribbons are hooked up properly. Ive seen similar on laptops when theres a poor connection.

  3. #3
    Quote Originally Posted by Vini View Post
    Have you checked all the LCD related cables/ribbons are hooked up properly. Ive seen similar on laptops when theres a poor connection.
    I think I have. I checked all the caBling but
    I am not sure which are LCD related.

    Can you help?
    Oh, and thanks 4 the reply.

  4. #4
    Livin the iPhone Life mr.sparky's Avatar
    Join Date
    Jul 2008
    Location
    On the open sea
    Posts
    1,326
    Thanks
    597
    Thanked 221 Times in 155 Posts

    talk to one1 hes the 2g god
    http://i122.photobucket.com/albums/o260/cpjr1979/dc5274181cd827585d4bb6d16bedb210cop.png
    Steroids are yummy

  5. #5
    Quote Originally Posted by mr.sparky View Post
    talk to one1 hes the 2g god
    If one1 is the 2G god I'd give him a bell. I'm afraid I only have 3g Disassembly experience, and even then im no guru...

    Hope you get it sorted!

  6. #6
    plain jane vanilla (post count restored to FULL AWESOMENESS) cpjr's Avatar
    Join Date
    Jul 2007
    Location
    ATL
    Posts
    11,685
    Thanks
    181
    Thanked 1,461 Times in 1,264 Posts

    Looks like you damaged the LCD.

  7. #7
    Default Which part?
    Quote Originally Posted by cpjr View Post
    Looks like you damaged the LCD.
    You mean the actual LCD display surface, the graphics chip or the cabling?

  8. #8
    Retired Moderator one1's Avatar
    Join Date
    Sep 2007
    Location
    In my own little world
    Posts
    10,318
    Thanks
    349
    Thanked 1,180 Times in 730 Posts

    It's your decoder plug, not seated properly. The bigger cable going to the lcd that runs with the other cable side by side. (the side with 2 cables). The other side is the lonely digitizer cable, not what we are talking about here.

    On the side with 2 cables, lift those plugs up going from the mobo to the lcd and reseat them tightly.
    Screw #Winning, I'm #Juanning
    iMac 27" i5 quad 2.8Ghz (1TB), MacBook Pro 17" 2.6, iPhone 4s

  9. The Following User Says Thank You to one1 For This Useful Post:

    EyeRTFM (06-24-2009)

  10. #9
    Thanks for everyone. At least now I know what the problem is.

    I will reseat the cable and post results.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •