+ Reply
Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3g says NO SIM even when one is inserted

is a discussion within the

Hardware

forums, a part of the

iPhone Modding

section;
Any help or advice on this issue would be greatfully appreciated, I have picked up an 3g iphone 8gb off ebay listed as faulty - very hard to get the
...
  1. #1
    iPhoneaholic Robcoffee's Avatar
    Join Date
    May 2008
    Location
    UK
    Posts
    308
    Thanks
    25
    Thanked 50 Times in 46 Posts

    Default iPhone 3g says NO SIM even when one is inserted
    Any help or advice on this issue would be greatfully appreciated, I have picked up an 3g iphone 8gb off ebay listed as faulty - very hard to get the sim detected - and they weren't kidding. I am using an o2 sim in the UK, and this sim works fine in all my 2g iphones, it also activated no problem a 3g 16gb through iTunes a few days ago.

    I have googled the issue to death and tried all the suggestions, reset network settings, reset all settings, restore to stock 2.2.1 - which I can't activate because it doesn't recognise the sim - Used Pwnage to create a custom activated firmware 2.2.1 which means I can access all the features - but it still says NO SIM. I have taken the sim in and out many times, tried a different 3g Sim tray, tried taping the sim into place on the tray - all to no avail. As soon as I pop the sim back into my 2g iphone it connects to the network straight away - so it isn't a sim issue.

    Next I'm going to take it apart and see if I can clean the contacts or find anything astray with mechanism. From having the 16gb 3g open I can see there is two mechanical operations when the tray is inserted - looking face on there is a little notch on the left side 3/4 way down that seems to push in when the tray passes, also at the bottom there are two thin copper strips that are joined when the tray is absent, and are pushed apart when the tray is in place - could either of these be the culprit?
    iPhone 5s 64gb iOS 7
    rMBP 15" 16gb 500gb
    @c0ff33a and @PhoneMainiac

  2. #2
    My iPhone is a Part of Me thevmax's Avatar
    Join Date
    Mar 2009
    Location
    West Milwaukee
    Posts
    589
    Thanks
    9
    Thanked 36 Times in 28 Posts

    My ATT sim says 3G on it. Maybe you should get a new sim from your carrier.

  3. #3
    iPhoneaholic Robcoffee's Avatar
    Join Date
    May 2008
    Location
    UK
    Posts
    308
    Thanks
    25
    Thanked 50 Times in 46 Posts

    My sim is fine, it works perfect in the 16gb 3g it activated - despite the fact it is on a sim only contract with data bolt on.

    This issue was resolved as soon as I "popped the hood", whoever had it previously must have had a bad experience with a sim adaptor - only 1 of the 3 sim connectors is present and that is misplaced! So this is forever going to be a 3g touch - still my lad will be pleased he's been wanting to get a new ipod touch because his 1g doesn't have a speaker - now he's getting a speaker and camera as well. I paid less then the price of a new 8gb 2g touch so no big issues.
    iPhone 5s 64gb iOS 7
    rMBP 15" 16gb 500gb
    @c0ff33a and @PhoneMainiac

  4. #4
    What's Jailbreak?
    Join Date
    Dec 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Popped the hood?
    Hey Rob,

    How did you pop the hood? Does that mean you opened up the whole phone? Dang, I'm trying to get my sim tray to go back in--it won't all the way--so I'm starting to think popping it might be my next option.
    But that looks like it'll take a lot of work.

    SH

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts