Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Strange problem after replacing digitizer/glass on a 3G. No Mic?!

  1. #1
    Default Strange problem after replacing digitizer/glass on a 3G. No Mic w/o speakerphone?!
    My brother called me to give me some bad news: He had dropped his 16GB white iPhone 3G from chair height (literally slipped out of his pocket) and it shattered the glass, despite having easily survived far worse drops many times previous. We both have identical phones (on the same plan even!), and he called for repair advice.

    He ended up ordering a new glass/digitizer and installing it ASAP. Other than some nosy friends, the install went without a hitch.,, that is, until he booted it back up and tried to use it.

    His microphone does not appear to work! It was working the whole time the screen was shattered, so we assume that it was not damaged in the fall and must be related to opening 'er up. Even more strangely, the mic DOES work when he enables speakerphone. He said that when the mic is not working ("handset mode") that the volume is lower than it should be, as if it is in "headset mode." He says that it does not indicate that he is using headphones when he changes the volume, so it does not appear to be sensing a "ghost" pair plugged into his headphone socket.

    What could this be? I live across the country, so I can't just swap assemblies with him to troubleshoot.
    Last edited by CZroe; 06-18-2009 at 06:01 AM.

  2. #2
    plain jane vanilla (post count restored to FULL AWESOMENESS) cpjr's Avatar
    Join Date
    Jul 2007
    Location
    ATL
    Posts
    11,685
    Thanks
    181
    Thanked 1,461 Times in 1,264 Posts

    Not real sure without seeing it.

    Cause the screen issue/fix has (or should have) had nothing to do with those issues what so ever. Those parts arent touched at all.

  3. #3
    plain jane vanilla (post count restored to FULL AWESOMENESS) cpjr's Avatar
    Join Date
    Jul 2007
    Location
    ATL
    Posts
    11,685
    Thanks
    181
    Thanked 1,461 Times in 1,264 Posts

    Not real sure without seeing it.

    Cause the screen issue/fix has (or should have) had nothing to do with those issues what so ever. Those parts arent touched at all.

  4. #4
    Well, he said that one of the nosy friends manhandled the screen assembly and flattened the copper leaf prongs that the Home button uses. Despite his insistence that this guy did not touch the rest of the phone and the flex cable, I'm not so sure.

    I'm *strongly* leaning toward flex cable. Perhaps it just needs to be reseated or something.

  5. #5
    Wow! Despite restoring the FW repeatedly and taking apart the phone multiple times, upgrading to iPhone OS 3.0 fixed everything (well, the leaf prongs on his Home button fell off )!

    How could this be a software problem when he restored the FW many times and it didn't do anything? Could it be because it wasn't really restoring if he couldn't enter DFU (due to his Home button problem)?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •