So i was working on a new 1.1.1 i down graded and i was going to run the 1.1.1 jailbreak commands and upgrade to 1.1.1 again so i would have a 1.1.1 jailbroken. but when i go to upgrade it says i have the latest version (1.0.2)

What could be the problem?