+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 29

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: J/B iphone 4 on 5.1.1; Do I upgrade or stay where I am?

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
Been on 5.1.1 for awhile now because I prefer to be jailbroken. Saw a thread a couple days ago about upgrading to iOS 6.1.2 and doing the ev4sion J/B for
...
  1. #1
    Green Apple
    Join Date
    May 2010
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    Default J/B iphone 4 on 5.1.1; Do I upgrade or stay where I am? (have 6.1.2 SHSH)
    Been on 5.1.1 for awhile now because I prefer to be jailbroken. Saw a thread a couple days ago about upgrading to iOS 6.1.2 and doing the ev4sion J/B for that, but as I got into reading more, it seems that you can't do it because Apple stopped signing that? I'm looking to stay untethered.

    So should I upgrade to 6.1.2, 7.0.2, or keep the jailbreak on 5.1.1? Opinions would be great! Thanks!
    Last edited by TurboGoKart; 10-13-2013 at 11:00 PM.

  2. #2
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,698
    Thanks
    40
    Thanked 576 Times in 526 Posts

    Quote Originally Posted by TurboGoKart View Post
    Been on 5.1.1 for awhile now because I prefer to be jailbroken. Saw a thread a couple days ago about upgrading to iOS 6.1.2 and doing the ev4sion J/B for that, but as I got into reading more, it seems that you can't do it because Apple stopped signing that? I'm looking to stay untethered.

    So should I upgrade to 6.1.2, 7.0.2, or keep the jailbreak on 5.1.1? Opinions would be great! Thanks!
    If you've got the SHSH blobs for 6.1.2 (check in the "TSS Center" on the front page of Cydia), that's a good option for an untethered jailbreak if you want to wrangle with restoring and such. 7.0.2 is probably not a good option, as no jailbreak exists for it (plus iOS 7 runs terribly on the iPhone 4 right now IMO). Otherwise, I'd stay at 5.1.1.

  3. #3
    Green Apple
    Join Date
    May 2010
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    Awesome, thank you! That's a long read but looks well explained. I will def read that.

    If I don't have the blobs, would it benefit me to do a DFU restore to my current version (5.1.1)? My phone has gotten slower and slooower over the years. I've never done a DFU restore, just a regular restore.

  4. #4
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,698
    Thanks
    40
    Thanked 576 Times in 526 Posts

    Quote Originally Posted by TurboGoKart View Post
    Awesome, thank you! That's a long read but looks well explained. I will def read that.

    If I don't have the blobs, would it benefit me to do a DFU restore to my current version (5.1.1)? My phone has gotten slower and slooower over the years. I've never done a DFU restore, just a regular restore.
    If you'd like. A good spring cleaning may help speed some things along. Just don't update to iTunes 11.1 if you haven't already (it plays havoc with custom/stitched IPSW restores).

  5. #5
    Green Apple
    Join Date
    May 2010
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    Ok I just read saurik's article. Am I correct in understanding that with an older iPhone 4 I may be able to run 6.1.2, provided that either the latest version of redsnow (what version is the latest?) or iFaith can capture the needed TSS data to be used for a restore to 6.1.2? Or am I not quite getting it?

    So from a practical standpoint, I need to download the latest version of redsnow or iFaith and it will walk me thru how to get that info?

    Also, if none of that works and I want to re-restore on 5.1.1, I should uninstall iTunes 11.1 and install 10.5.xx?

  6. #6
    Green Apple
    Join Date
    May 2010
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    Ok, I downloaded TU and saved my SHSH's twice (once with "Request from Cydia" checked and once unchecked).

    These are the SHSH's I have in TU:
    5.1.1 (9B206)
    5.1.1b (9B208)
    6.0.1 (10A523)
    6.1.2 (10B146)

    Does this mean I can follow this ([How-To] Using tiny umbrella to update/downgrade/restore) to restore to 6.1.2, then use evasion to JB? If so, one other question is, how do I go about doing a DFU restore to 6.1.2 then? Or download redsn0w and do it thru there?
    Last edited by TurboGoKart; 10-13-2013 at 11:05 PM.

  7. #7
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,698
    Thanks
    40
    Thanked 576 Times in 526 Posts

    Quote Originally Posted by TurboGoKart View Post
    Ok, I downloaded TU and saved my SHSH's twice (once with "Request from Cydia" checked and once unchecked).

    These are the SHSH's I have in TU:
    5.1.1 (9B206)
    5.1.1b (9B208)
    6.0.1 (10A523)
    6.1.2 (10B146)

    Does this mean I can follow this ([How-To] Using tiny umbrella to update/downgrade/restore) to restore to 6.1.2, then use evasion to JB? If so, one other question is, how do I go about doing a DFU restore to 6.1.2 then? Or download redsn0w and do it thru there?
    I'd go with redsn0w's Restore (Extras -> Even More -> Restore), however, I'm still not totally confident your 6.1.2 blobs are valid... I'd use redsn0w's Fetch (Extra -> SHSH blobs -> Fetch) to grab what's on your device currently for safe keeping. If all else fails, those 5.1.1 blobs should still be totally usable and our go-to if 6.1.2/6.0.1 don't work like we want.

  8. #8
    Green Apple
    Join Date
    May 2010
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    Using redsn0w v.0.9.9b9d, Extra-> SHSH blobs -> Fetch, I get an Unrecognized build, Error with SHSH blobs! It says to check to make sure I'm using the latest version of redsn0w and whether my iOS version is supported yet. Not sure if I have the latest version of redsn0w because there's no "Even more" option under "Extras."

  9. #9
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,698
    Thanks
    40
    Thanked 576 Times in 526 Posts

    Latest version is 0.9.15b3, grab it here.

  10. #10
    Green Apple
    Join Date
    May 2010
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    Thanks!

    Did a Fetch SHSH and it said I have nothing to do; Cydia already has a FULL set of blobs for this configuration. Build: iPhone3, 1_5.1.1_9B206.

    I'm not 100% sure what a FULL set of blobs means. I went ahead and stitched the iPhone3, 1_6.1.2_10B146_Restore build with the 6.1.2 blob I had to create a DFU IPSW. Then did Extras -> Even More -> Restore and used that custom IPSW. Everything worked up until the point where I needed to be in DFU mode. I put it in Pwned DFU mode like it says, and redsn0w tells me that it's not in the right mode; that I misunderstood the instructions. Lol. Did I do something wrong? Or is this route just not working?

  11. #11
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,698
    Thanks
    40
    Thanked 576 Times in 526 Posts

    Quote Originally Posted by TurboGoKart View Post
    Thanks!

    Did a Fetch SHSH and it said I have nothing to do; Cydia already has a FULL set of blobs for this configuration. Build: iPhone3, 1_5.1.1_9B206.

    I'm not 100% sure what a FULL set of blobs means. I went ahead and stitched the iPhone3, 1_6.1.2_10B146_Restore build with the 6.1.2 blob I had to create a DFU IPSW. Then did Extras -> Even More -> Restore and used that custom IPSW. Everything worked up until the point where I needed to be in DFU mode. I put it in Pwned DFU mode like it says, and redsn0w tells me that it's not in the right mode; that I misunderstood the instructions. Lol. Did I do something wrong? Or is this route just not working?
    The full set means that your blobs are complete and valid. It's a good thing.

    You entered DFU mode (with the screen totally off) not Recovery mode (the iPhone has a "Connect to iTunes" logo on screen), right? To be honest, I've never seen anyone have an issue with redsn0w not recognizing a truly DFU mode device correctly... if it continues, try entering DFU mode before opening redsn0w, since redsn0w will skip the instruction sequence if it detects a device already attached in DFU mode. Make sure you connect your iPhone to your computer while it's turned on, then hold down the power button and "Slide to Power Off" before starting the DFU access sequence.

  12. #12
    Green Apple
    Join Date
    May 2010
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    When I put it in DFU mode before opening redsn0w, then did Extras -> Even More -> Restore I got the error message "Found none of the expected files to stitch in IPSW" then the location of the IPSW I *thought* I stitched.

    Extras -> SHSH Blobs -> Query -> returned only the 5.1.1 remote blob. Is that an issue (if I'm trying to get to 6.1.2)?

    Do my 6.1.2 blobs need to be in a certain folder in order for the restore to find them?
    Last edited by TurboGoKart; 10-15-2013 at 08:45 AM.

  13. #13
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,698
    Thanks
    40
    Thanked 576 Times in 526 Posts

    Quote Originally Posted by TurboGoKart View Post
    When I put it in DFU mode before opening redsn0w, then did Extras -> Even More -> Restore I got the error message "Found none of the expected files to stitch in IPSW" then the location of the IPSW I *thought* I stitched.

    Extras -> SHSH Blobs -> Query -> returned only the 5.1.1 remote blob. Is that an issue (if I'm trying to get to 6.1.2)?

    Do my 6.1.2 blobs need to be in a certain folder in order for the restore to find them?
    Your IPSW may be corrupt or may have incorrect filenames for its internal components. Try downloading a fresh copy from Apple, and don't stitch it prior to beginning the redsn0w restore process.

    Redsn0w will only pull blobs from the remote server when doing a restore... and if redsn0w is only seeing the 5.1.1 blobs on the server, your 6.x blobs are likely corrupt and thus unusable. You can try submitting your local SHSH blobs (Extras -> SHSH Blobs -> Submit) from TinyUmbrella (they're in ~/.shsh on OS X, I'll have to look it up on Windows), but they're probably not valid if TinyUmbrella saved them, so submitting them may be of limited use to you.

  14. #14
    What's Jailbreak?
    Join Date
    Oct 2013
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    sorry for the bump, i am on the same boat, only i am on 5.0.1. any updates to this?

    i tried using ifaith to build signed ipsw with blobs but it gives me an error. it says "the provided apticket does not look valid! ifaith will refuse to build an ipsw with this apticket as it may put your device in an unusable state"

    i got the blobs from tinyumbrella with the request shsh from cydia option checked.

    iPhone4 5.0.1 (9A405)
    iPhone4 5.1 (9B176)
    iPhone4 5.1.1 (9B206)
    iPhone4 5.1.1b (9B208)
    iPhone4 6.0.1 (10A523)
    iPhone4 6.1.2 (10B146)
    iPhone4 7.0.2 (11A501)

    i saved it all onto my harddrive.

    any input?

  15. #15
    2k1
    2k1 is offline
    Sug Luv Super Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,057
    Thanks
    1,815
    Thanked 7,064 Times in 4,206 Posts

    What firmware are you trying to go to?

  16. #16
    What's Jailbreak?
    Join Date
    Oct 2013
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    ios6 6.1.2

    when i did the redsnow shsh blob fetch, it did say exploit failed and theres error with shsh blobs
    when i query, this came up
    iPhone3,1 403156571637 remote blobs:
    5.1.1, 5.1, 5.0.1

    i was able to stitch iPhone3,1_6.1.2_10B146_Restore.ipsw firmware with xxxxxxxxxxxx-iphone3,1-6.1.2.shsh to create a new custom firmware (i just replaced that number string with a whole bunch of x's for me being a bit paranoid) :P . i just want to make sure everything is fine before i go ahead to try and do a restore (if thats even still possible).

    i also tried submitting the blob i retrieved through tinyumbrella through cydia back into cydia via redsnow, it got rejected.
    Last edited by sonarwave; 10-23-2013 at 04:09 AM.

  17. #17
    2k1
    2k1 is offline
    Sug Luv Super Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,057
    Thanks
    1,815
    Thanked 7,064 Times in 4,206 Posts

    You pointing it to 6.0 ipsw? Ya need to point it to 6.0 ipsw or it won't work

  18. #18
    What's Jailbreak?
    Join Date
    Oct 2013
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I'm not sure what you mean pointing at 6.0 ipsw. Which step of the process or steps I did are you referring to? I dont think anything I did required me to point to an ipsw other than stitching. Stitching went fine.

    I'm just not sure if I can upgrade to ios6 given the problems I had

  19. #19
    What's Jailbreak?
    Join Date
    Oct 2013
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    bump

  20. #20
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,937
    Thanks
    76
    Thanked 2,752 Times in 2,642 Posts

    Quote Originally Posted by sonarwave View Post
    bump
    If you have successfully build a stitched 6.1.2 ipsw, then you should be able to restore to this firmware. Bear in mind , once restored, your iphone isn't jailbroken yet. You can run Redsn0w to jailbreak, you will have to browse to a firmware first which is 6.0 as a reference so redsn0w can proceed to jailbreak.

LinkBacks (?)


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts