+ Reply
Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 GSM 5.0.1 should upgrade to??????

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
Hi all, I had been reading many of your great posts and advise and understand it is not longer that easy to upgrade my iPhone to any firmware i wanted.
...
  1. #1
    What's Jailbreak?
    Join Date
    Jul 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iPhone 4 GSM 5.0.1 should upgrade to??????
    Hi all,

    I had been reading many of your great posts and advise and understand it is not longer that easy to upgrade my iPhone to any firmware i wanted.

    My JB 5.0.1 is running perfectly but lately, i found more and more apps required a newer firmware to run. At least 5.1.1.

    I install Tinyumbrella and manage to save some SHSH. (5.0.1, 5.1.1, 5.1.1b, 6.0.1 and 6.1)

    Could you guys advise me which is a safest firmware upgrade i should go for?
    I saw many trying to restore back to Ver 5.xx from 6.xx.
    Could i guess this is due to many had upgrade to the newest 6.1.3 and trying to roll back?
    Or maybe the Ver 6.xx is having many issues like not stable for JB?

    If i would to go for 5.1.1, should i be using the 5.1.1 or 5.1.1b shsh with the redsnow?

    Any advise and comments is great appreciated.

  2. #2
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    904
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, I went from iOS5.1 to 6.1 on my iPhone 4. I find 6.1 more stable than 5. The best feature I think is the way 6.1 handles the "open in" option. Things which don't work on 6 are wraparound, deck, Timer Plus, Play Awake, Noticall, AppFront and Apptivator (use App Activate instead). I couldn't get Redsnow to upgrade the iOS, so I used iFaith, created a custom ipsw with 6.1 blobs and shift restore with iTunes (tinyumbrella not needed)

  3. #3
    What's Jailbreak?
    Join Date
    Jul 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by DC_Dave View Post
    Hi, I went from iOS5.1 to 6.1 on my iPhone 4. I find 6.1 more stable than 5. The best feature I think is the way 6.1 handles the "open in" option. Things which don't work on 6 are wraparound, deck, Timer Plus, Play Awake, Noticall, AppFront and Apptivator (use App Activate instead). I couldn't get Redsnow to upgrade the iOS, so I used iFaith, created a custom ipsw with 6.1 blobs and shift restore with iTunes (tinyumbrella not needed)
    Hi, thank you for sharing.

    Luckily i do have the 6.1 SHSH hence i could take the same path as you.
    Could you share the problem for Redsnow when you upgrade the iOS?

    I will need to go read up on iFaith.
    Yet to read on the function of it.

  4. #4
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    904
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, I have always used Redsnow, but on this occasion, (I don't know why), After stitching my blobs to the ipsw, I got iTunes restore errors, didn't reach even half way. While the same process with iFaith worked first time.

  5. #5
    Evil Genius bbrks's Avatar
    Join Date
    May 2012
    Posts
    989
    Thanks
    171
    Thanked 198 Times in 149 Posts

    SHSH blobs for IOS 6.xx saved with Tiny Umbrella are corrupt. You cant use them. Only if you have saved them locally on your computer, at the time when those IOSs were signed by Apple.
    Install iFaith and check with it, if the blobs are OK or not.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts