My iOS version is 5.0.1, my baseband is 1.0.13. I don't really care about the specific version of iOS 6, I just want to get the panorama feature and stop getting errors about apps needing iOS 5.1 or 6.x.

What's the highest iOS version I can upgrade to with being able to jailbreak it untethered, and what tool should I use then?