Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 5 Jailbreak - Problem Video and Sound

  1. #1
    Default iPhone 5 Jailbreak - Problem Video and Sound
    I'm on iPhone 5 iOS 6.1- evasi0n jailbreak.

    My iPhone is having issues. I was in an app emulator PPSSPP attempting to download the Atrac3+ plugin. Phone rebooted- or respringed. After that, most Cydia apps didn't work. The phone outputted no sound, whether from speaker, in calls, out. People could not even hear me on the other ends of calls. No ringer sound, although vibration worked and works. Video did not play, even in the photos app. I did see a video play in the Cydia ads when looking for a package with no sound to it. All the tweaks disappeared in settings app. I saw in iFile that many files in ~/mobile/Documents that I had where missing. My iPhone was close to full. Some games crashed on opening. Wifi works fine. Cydia is there and works fine. When I re-installed the tweaks & dependencies via Cydia, they worked fine. For certain tweaks to work correctly, and not malfunction, I had to make sure the dependencies where installed, such as PreferenceLoader.

    The problem that is still here now is that there is no sound, no videoplayback from any app- I think which uses iPhone video player. No sound in call from ear piece or speakerphone. A person does not hear on other end of my call.

    An intriguing thing:
    Airplay icon is there (I am not connected to anything, nor wifi), and it has no options for it. See Attached photos. This is where I think the problem could be and could be close to resolved, though I am not sure.

    Ruled out hardware issues, considering when this happened.
    I can access root from iFile just fine. I am not able to access root from iFunBox. I can only reach /var/mobile/Media/, though it says it jailbroken or "(Jailed)"- where it shows the name of the phone.
    I am able to open Cydia, install apps from Cydia.
    I can respring and reboot.

    I have made this detailed, so we can save time and make it easier for you all to help.

    Things I have tried:

    Using the evasi0n tool. Gives error "error hmm... restore failed (-1)."
    Tried on different computers.
    Restore from an iTunes backup I previously had no problems with- before errors. This is to see if it may repair a messed up setting. iTunes returns error: "Could not restore the iPhone because an error occurred."
    Also tried on different computers.
    iLEX RAT- I successfully cleared all cydia apps with option 12, still no video, sound, etc.
    Deleting "com.apple.iapd.plist" and reboot. Also tried deleting the other files similar to iapd, associated with accessories.
    Tried plugging headphones in and out a couple of times- no change or recognition, as if I didn't plug it in at all. No "headphones" in volume display when plugged in.
    Safe Mode- still no video, sound etc.
    Deleting all Cydia Tweaks & Apps -via iLEX RAT
    Alot of things from iphonenosound.com
    Reboot and Hold Up to turn off all mobile substrate apps. - still no video, sound, etc.
    In these attempts, the issues remained.

    Even if I said forget the jailbreak, It's possible a restore will not even work, considering, I've seen people restore and still have sound problems. I'd like to isolate the problem, rather than me get to iOS 6.1.4 or iOS 7 beta and find I have the same issue. I would have wasted time and a jailbreak. That I think it may not work, and of course do not want to lose my jailbreak. The phone is fine generally, I just like to find a way to at least restore all sound and video until next jailbreak.

    Many Tweaks I had installed:

    %hooks%law
    Auxo
    Velox
    DeepEnd
    Accentify
    Activator
    Barrel
    CallBar
    SbRotator 6- springboard portion disabled- since I saw issues with it.
    Color Keyboard
    Folder Enhancer
    Iconoclasm
    Springtomize 2
    Zephyr
    FullScroll
    iLEX RAT
    Mobile Terminal
    Scrollingboard
    Winterboard
    MyTunes
    BytaFont
    Giffy
    Crashreporter

    A few more small tweaks.
    The phone still ran fluently- no lag though safe mode would appear, now and again.

    Details in things that currently occur:
    Voice Memos says when trying record, "No Microphone Available Connect a microphone to record voice memos."
    No Music plays from music app, Videos do not play.
    No Sound in call.
    Speaker phone will not turn on. I press it, it shows its selected, then immediately unselects it.
    There is no output from the sound whatsoever. Even in the ringtones app.
    Of course, I checked the vibrate switch. Which is fine and set to off.
    All videos, whether in photos app, YouTube app, YouTube from browser gives an error. Error from photos app "This operation could not be completed." Error on some YouTube videos "Playback error."
    The phone recognizes no difference when headphones are plugged in.
    Bluetooth does not turn on at all. It just shows the spinning wheel when attempting to toggle on and is seen on the "Off" position later.
    Airplay icon is there. Shows as if I have something connected to it. I have never used it, accept and has no devices listed:
    I would appreciate help to get this resolved.

    Thank you.

    -img_0005.png-img_0006.png

  2. #2
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,705
    Thanks
    40
    Thanked 579 Times in 528 Posts

    Well, I've seen many iPhone 5 devices have issues with these audio components, stock or otherwise. In fact, it was apparently such an issue that Apple released iOS 6.1.4 exclusively to try and rectify these speaker issues (if the change logs are to be believed)...

    If the device has been wiped with iLEX and the problem is still rearing its ugly head, I'm thinking it's either an issue with the installed firmware image, or hardware. Both of which, at this point, would likely require a restore to fully diagnose/resolve (or to satisfy Apple and get a new phone with warranty swap). Personally, I'm leaning "hardware."

  3. #3
    If I am having an issue with restore from a backup, you think it would give me problems with a normal restore? If I go to the Apple store with software issues- and I cracked screen, will the regularly replace it? Besides that, trying more will crash reporter help or syslog? Is there anything else someone can think of, I really want to retain my jailbreak- a lot of the reason why I have the iPhone.

  4. #4
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,705
    Thanks
    40
    Thanked 579 Times in 528 Posts

    Quote Originally Posted by FixitNow View Post
    If I am having an issue with restore from a backup, you think it would give me problems with a normal restore? If I go to the Apple store with software issues- and I cracked screen, will the regularly replace it? Besides that, trying more will crash reporter help or syslog? Is there anything else someone can think of, I really want to retain my jailbreak- a lot of the reason why I have the iPhone.
    Oh, when you said you "restored with iLEX" I assumed that meant this issue persisted when the phone was still "brand new but just jailbroken" and had not been restored from backup. If it's persisting with no user data on it (e.g., fresh after an iLEX cleaning), then I'm afraid we're back to where we were.

    Apple will replace the display by itself if they can eliminate the sound issue and the device is on iOS 6.1.4, I do believe. If they can't get the sound fixed and it's on 6.1.4, they'll probably swap the whole phone. However, the cracked screen means the warranty is toast and you'll be out $150 (display only) to $230 (full swap). If nothing's appeared in the syslog or crash logs about this sound issue, I doubt it'll appear in a way visible to us now...

    You can try seeing if anyone else has any ideas, but instinct tells me we're running out of options here.

  5. #5
    Livin the iPhone Life
    Join Date
    Sep 2009
    Location
    Manchester, England
    Posts
    2,004
    Thanks
    361
    Thanked 516 Times in 380 Posts

    Sounds like a full restore is on the cards.

  6. #6
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, if you can find someone with a jailbroken iOS6.1 iPhone 5, you could compare the contents of the Applications folder and their file/folder permissions. Make sure the PPSSPP folder has gone. Check the folder permissions of the folder you downloaded the plugin into. Make sure the plugin is deleted. Install afc2add if you want root access from iFunbox.
    As you say, the airplay icon issue must be related. You could try installing the Cydia AirPlayServer to see if that has any effect. Also try "Fix User DIR permissions" in SBSettings, more, system options.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •