+ Reply
Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: upgrade iPad 2 from 4.3.3 to ios 6.1.2 with saved 4.x SHSH blobs

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
My iPad 2 (GSM model) has been with 4.3.3 (jailbroken) for a long time, until recently there is a need for upgrade. And since I need it to be jailbroken
...
  1. #1
    What's Jailbreak?
    Join Date
    Jun 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question [Resolved] upgrade iPad 2 from 4.3.3 to ios 5.x-6.x with saved 4.x SHSH blobs
    My iPad 2 (GSM model) has been with 4.3.3 (jailbroken) for a long time, until recently there is a need for upgrade. And since I need it to be jailbroken after the upgrading, 6.1.2 seems to be my best choice. (Please correct me if 6.1.3 can be jailbroken.)

    I started upgrading process today. After half a day's effort, of which most of the time was spent in internet research, I found myself not far away from the position before I started the upgrading process - nothing has been done and I don't know what to do.

    My first question is about my understanding. All the web pages I have come across suggest that I can upgrade to 6.1.2 or earlier versions only if I have a saved 4.x SHSH blob. Is my understanding correct?

    I *do* have saved 4.x SHSH blobs. Actually, I have saved them multiple times, for multiple versions, with multiple tools - Before today, I've saved them at least twice, each time multiple versions were saved; I've saved 4.3.3, 4.3.4 & 4.3.5; They were saved with TinyUmbrella and iSHSH*t. I also save them again today with TinyUmbrella and iFaith. So I've got 4 collections of 4.x SHSH blobs, each with multiple versions. However, there is one problem. None of the aforementioned 4.x SHSH blobs was verified valid with redsn0w (reporting "APTicket missing") and iFaith (reporting "not supported"). So I supposed that none of my blobs is valid. However, I found some web page saying "As of iOS 5, SHSH blobs require an APTicket to be valid.". So now I'm guessing that the SHSH blobs might still be valid even though neither of the two tools reports them valid. Is my understanding correct? In other words, can I use these SHSH blobs to upgrade my iPad 2 to 6.1.2?

    My last question is about how to upgrade my device to 6.1.2 with blobs, assuming at least one of my 4.x blobs is valid. What tool(s) can be used and how? I tried Restore functionality of redsn0w. It was stuck at the stage that it asked me to manually get my device into DFU mode because I failed to get it into DFU mode after many times' trying. Then I gave up. Please let me know if I were on right track and I should keep trying getting the device into DFU mode.

    Any comment will be greatly appreciated.

    P.S.: The sticky thread titled [How-To] Using tiny umbrella to update/downgrade/restore seems to be about how to upgrade but I'm quite sure it fits my situation after half a day's massive reading, when English is not my primary language.

    CONCLUSION:
    The device is upgraded to 5.1.1 successfully.
    Last edited by alewela; 06-17-2013 at 09:49 PM. Reason: adding/updating information

  2. #2
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    903
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, you can only upgrade the iPad 2 to the current release version iOS6.1.3. This version can not be jailbroken.

  3. #3
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,665
    Thanks
    40
    Thanked 567 Times in 519 Posts

    Quote Originally Posted by DC_Dave View Post
    Hi, you can only upgrade the iPad 2 to the current release version iOS6.1.3. This version can not be jailbroken.
    Actually Dave... you're absolutely right for 6.x versions. Derp on my part.
    Last edited by Orby; 06-16-2013 at 10:29 PM.

  4. #4
    King Kong ain't got nothing on me! King_O_Hill's Avatar
    Join Date
    Apr 2011
    Location
    USA
    Posts
    8,798
    Thanks
    38,941
    Thanked 16,295 Times in 5,961 Posts

    If you are trying to go to 6.1.2, then you need those blobs also I believe. And seeing that Cydia was not saving the blobs and the apt ticket correctly until 6.1.3 I'm not sure that you can go there.

    You are trying to upgrade, correct?
    Widget-Weather App Now Available! Also with MyLocation Support!
    Check out the thread here - Widget-Weather
    To install the Widget-Weather app, just go to Cydia and install. This will also remove MyLocation, as it is built in!
    Want to protect your JailBreak! Add this repo http://cydia.myrepospace.com/iLEXiNFO/ & Install "iLEX R.A.T."
    It will allow you to bring your phone back to a fresh jailbroken state!

  5. #5
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    903
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, (correct me if I am wrong), but if you have both iOS4 and iOS5 blobs, then you should be able to upgrade your iPad2 from iOS4 to iOS5 and then Jailbreak.

    This downgrade method should still work even though you want to upgrade.

    http://www.iclarified.com/25274/how-...ios-5x-windows

    http://www.iclarified.com/25273/how-...-to-ios-5x-mac
    Last edited by DC_Dave; 06-17-2013 at 02:31 AM.

  6. #6
    What's Jailbreak?
    Join Date
    Jun 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thank you all. My iPad2 has been upgraded to 5.1.1 successfully.

    DC_Dave: Yes, the link you provided (the Windows one) was what I followed to upgrade my iPad2.

  7. #7


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts