Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgrading 3GS from 5.3.1 to 6.1.2... Is it possible?

  1. #1
    Default Upgrading 3GS from 5.3.1 to 6.1.2... Is it possible?
    Hi,

    I have an old 3GS that has recently been undergoing some major issues, random reboots, and now a recovery screen I can't get rid of.

    I've been wanting to upgrade it for a while and this might be the time. But obviously the most recent iOS 6.1.3 can't be jailbroken.

    Can I update this phone to 6.1.2 so that I can JB with Evasion? I am unlocked with ultrasn0w; do I have to be wary of a baseband update when updating to 6.1.2? If I can't update to 6.1.2 are there other newer iOS versions I can update to that might get me out of the issues that I'm having?

    3GS
    old bootrom
    5.13.04 (downgraded with redsnow)
    JB with Absinthe
    Win 7

  2. #2
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,724
    Thanks
    40
    Thanked 599 Times in 540 Posts

    Sure, if you're positive you've got an old-bootrom device. You won't even need SHSH blobs for this bad boy, under these circumstances...

    Download sn0wbreeze and build a custom 6.1.2 IPSW (it should preserve your baseband by default, but if not, make sure to select "Preserve Baseband"). sn0wbreeze will then help you enter Pwned DFU once it's done with the build process, and then you'll just restore to this custom IPSW file via the Shift+Click method in iTunes.

    If you have a SIM card for the carrier the phone is locked to (live line or not), use it to activate legitimately with iTunes. Otherwise, start with a hacktivation from sn0wbreeze then grab SAM from the Bingner repository (http://repo.bingner.com) in Cydia to spoof iTunes into thinking you've got the correct SIM so it'll legitimately activate your device. Ultrasn0w after that should then unlock you for use with your real SIM.

    Good luck!

    EDIT: Just to make it clear, if you are not 100% sure you have an old-bootrom phone... these instructions will still work, but you'll need to have SHSH blobs saved for your device. If your blobs were just automatically saved via Cydia, then they probably won't work, and therefore you will be unable to restore to anything else than 6.1.3.

  3. #3
    Thanks for the info. Yes, I am positive it's the old bootrom as I had to check into that previously (though I can't confirm it now because the phone is inaccessible and can't connect to TinyUmbrella). I had thought that Cydia automatically saved the blobs for each version, but apparently it does not, so I was out of luck there.

    But, I did end up getting this all fixed.

    I followed your instructions on creating a custom IPSW for 6.1.2 with Sn0wbreeze. I was not prompted to preserve baseband, so I didn't set anything.

    However, I was unable to get into DFU mode because the sleep/power button on my phone has been broken for a long time. I took it apart to see if I could fix it (I was able to briefly fix the connection about a year ago when I changed the battery) but no luck this time.

    So the phone was just in standard recovery mode, with the picture of the cable.

    I decided to try it anyway. Hosts were set to Cydia so I decided to leave it for now. I restored to the custom IPSW and the whole process appeared to work fine. It hung up forever on "Verifying restore with Apple" but eventually it completed and I got the message that the phone had been restored.

    But the phone never rebooted, instead the screen went dark. I unplugged and plugged back in and once again got the recovery mode screen (this time with the Sn0wbreeze branding).

    I went back into the hosts file and took out the two references for Apple, then tried to restore again.

    Same thing, got hung up forever on "Verifying restore with Apple" but once again it completed.

    This time, the restore was successful. I'm now running jailbroken 6.1.2 on my old 3GS. I didn't think this would work without the DFU mode, but I'm not complaining!

    Thanks again for the help

  4. #4
    didn't mean to thread jack... but i've now read several posts saying going from 5.x.x to 6.1.2 is impossible... what is the differentiating factor here? a bootrom? (need i'm currently on 5.1.1 and do have shsh blobs saved in tiny umbrella for that... but not 6.1.2

  5. #5
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,724
    Thanks
    40
    Thanked 599 Times in 540 Posts

    Quote Originally Posted by starbai View Post
    didn't mean to thread jack... but i've now read several posts saying going from 5.x.x to 6.1.2 is impossible... what is the differentiating factor here? a bootrom? (need i'm currently on 5.1.1 and do have shsh blobs saved in tiny umbrella for that... but not 6.1.2
    No worries.

    That is correct, the bootrom version is the difference. Only "old bootrom" 3GS units (as a rule of thumb, only certain devices made before the forty-fifth week of 2009, fairly rare) can bypass the SHSH blob requirement entirely, because of their vulnerability to both the limera1n and 24kpwn exploits. "New bootrom" devices (everything else, essentially) follow the same pattern as A4 devices--restoring to any version of iOS and getting an untethered jailbreak is supported, so long as you have at least one valid set of SHSH blobs for that device and OS combination.

  6. #6
    Asked this on the ATV section but no one answered, ATV 2 on OS 5, is it possible to upgrade to OS 5.1.2? Instead of the latest OS. I want to unteater jailbreak. If so, how?
    Thanks in advance.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •