+ Reply
Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Can I upgrade my jailbroken and unlocked 3GS? I'm lost.

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I have an Iphone 3gs, Version 4.0.1, 05.13.04. I am using a T-Mobile. It's already jailbroken and unlocked. Can I upgrade it. I am truly confused here. So much information.
...
  1. #1
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    16
    Thanks
    16
    Thanked 0 Times in 0 Posts

    Default Can I upgrade my jailbroken and unlocked 3GS? I'm lost.
    I have an Iphone 3gs, Version 4.0.1, 05.13.04. I am using a T-Mobile. It's already jailbroken and unlocked. Can I upgrade it. I am truly confused here. So much information.

  2. #2
    EVO
    EVO is offline
    Super EVO Moderator EVO's Avatar
    Join Date
    Dec 2009
    Posts
    3,484
    Thanks
    105
    Thanked 798 Times in 485 Posts

    if you are unlocked, it would depend on how the phone was unlocked...

    if the phone was unlocked via ultrasn0w, then you CAN upgrade, but you need to create a "custom firmware" to "preserve" the 05.13.04 Baseband to allow it to work with ultrasn0w, and thus, is why your phone is unlocked...

    if it was unlocked via Apple, then you can just update via itunes and would not need to worry about baseband preservation

  3. The Following User Says Thank You to EVO For This Useful Post:

    modonee (03-19-2013)

  4. #3
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    16
    Thanks
    16
    Thanked 0 Times in 0 Posts

    I forget what I used to unlock, but I think it was ultrasn0w. How do I know if it was ultrasn0w that I used to jailbreak? I did this more than 2 yrs ago, so I forget.

    How do I create a custom firmware to preserve my baseband?

    Thanks EVO

  5. #4
    2k1
    2k1 is offline
    Sug Luv Super Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,050
    Thanks
    1,814
    Thanked 7,061 Times in 4,203 Posts


  6. The Following User Says Thank You to 2k1 For This Useful Post:

    modonee (03-19-2013)

  7. #5
    iPhone? More like MyPhone BrainSmashR's Avatar
    Join Date
    Oct 2012
    Location
    Natchitoches, LA.
    Posts
    222
    Thanks
    36
    Thanked 51 Times in 38 Posts

    I was able to run iOS 6.0 on my old 3Gs with the old tethered jailbreak. So my guess is you should be able to run the untethered jailbreak as well.

    Keep in mind that I used it for a toy....I didn't have a sim card, never tried to make a call, never even sent a text. You will probably suffer some performance issues if this is your everyday phone.

  8. The Following User Says Thank You to BrainSmashR For This Useful Post:

    modonee (03-19-2013)

  9. #6
    2k1
    2k1 is offline
    Sug Luv Super Moderator 2k1's Avatar
    Join Date
    Jan 2011
    Location
    Hammond Louisiana
    Posts
    34,050
    Thanks
    1,814
    Thanked 7,061 Times in 4,203 Posts

    Yes he will if he requires an unlock and updates so will his basband and his phone will be an iPod unless he unlocks it threw IMEI or factory.

  10. The Following User Says Thank You to 2k1 For This Useful Post:

    modonee (03-19-2013)

  11. #7
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    16
    Thanks
    16
    Thanked 0 Times in 0 Posts

    So I tried upgrading my phone to ios 5.1.1 while preserving my baseband. did this using redsnow and upgraded my itunes. but alas when i clicked restore to upgrade the software in itunes it did not work. i have the feeling that i'll have to use this phone until i get a new one.

    i'll try upgrading to ios 6.1.2. can i do that? cydia notes it as of of the shsh that are compatible with my phone. ironically i didn't notice until now that ios 5.1.1 wasn't listed.

  12. #8
    EVO
    EVO is offline
    Super EVO Moderator EVO's Avatar
    Join Date
    Dec 2009
    Posts
    3,484
    Thanks
    105
    Thanked 798 Times in 485 Posts

    what is the error you are receiving?

    and does the 3gs have SHSH for 5.1.1?

  13. The Following User Says Thank You to EVO For This Useful Post:

    modonee (03-24-2013)

  14. #9
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    16
    Thanks
    16
    Thanked 0 Times in 0 Posts

    I forget exactly what it said to be honest. Yes, I think the root of the problem is that my 3gs did not have 5.1.1 listed. I have listed SHSH's for 6.0.1 and 6.1.2. I think I'll try upgrading to 6.1.2.


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts