OK,

so I've been thinking of doing this for a while, but now I'm jumping into it. I want to upgrade my iPhone iOS from 4.1 to 5.0.1 the reason I'm choosing that specific firmware is because it's the only one besides 6 that I have SHSH blobs for. Now, I need to preserve my unlock, as I'm running an unsupported carrier on the phone. I'm pretty sure I have an older bootrom (Model number starts MB).

Anyways, I've created a version of the 5.0.1 firmware that has the baseband preserved, I'm wondering, is this the firmware that I'm supposed to stitch the SHSH blobs to?