+ Reply
Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Problems with iphone 4 running 5.1.1

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
hi guys, I have spent a few weeks trawling google to try and sort out this problem i have been having with my iphone before posting a forum topic, but
...
  1. #1
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    18
    Thanks
    1
    Thanked 4 Times in 4 Posts

    Default Problems with iphone 4 running 5.1.1
    hi guys,

    I have spent a few weeks trawling google to try and sort out this problem i have been having with my iphone before posting a forum topic, but it seems i am going to have to as i am totally out of ideas now.

    let me explain.

    About 3 weeks ago, i made a mistake of deleting some files through ifile, i cant remember exactly what i did, anyway whatever i did was stupid, because i cant use cydia anymore.

    I cant download apps, error 100 i cant update current updates, which include 10 cydia updates Couldn't configure pre-depend dpkg for ncurses, probably a dependency cycle.

    I have used the apt-get remove cydia command using terminal via winscp - cydia not installed so no files removed

    I have tried the apt-get install cydia command using same method - it times out and host does not respond

    I have tried to re-jailbreak with redsnow, however this runs all the way through the process from start to finish, but does not actually change a thing.

    I have tried to restore through itunes - unknown error and cannot restore at this time

    I have tried to update via wifi elsewhere - an error occured downloading ios 6.0.1

    i have also tried to reinstall cydia via putty - E: Couldn't configure pre-depend dpkg for ncurses, probably a dependency cycle.

    Really appreciate anyones help please as i am pulling my hair out with this now.

    thanks

  2. #2
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,662
    Thanks
    40
    Thanked 564 Times in 518 Posts

    Okay, there are two routes we can feasibly attack here--trying to repair the dependency errors, or just nuke it and install a fresh copy of iOS. Personally, I don't think we need to restore yet.

    Let's try running apt-get with the following arguments:

    Code:
    # apt-get update
    # apt-get dist-upgrade -f
    That -f flag will attempt to fix the dependency issues that are likely plaguing your system. If that doesn't do it, try the -m (ignore missing) flag next, i.e.,

    Code:
    # apt-get dist-upgrade -m
    Another option may be reinstalling ncurses:

    Code:
    # apt-get reinstall ncurses
    and hoping that any missing dependencies get picked up during the reinstallation process.

  3. #3
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    18
    Thanks
    1
    Thanked 4 Times in 4 Posts

    Quote Originally Posted by Orby View Post
    Okay, there are two routes we can feasibly attack here--trying to repair the dependency errors, or just nuke it and install a fresh copy of iOS. Personally, I don't think we need to restore yet.

    Let's try running apt-get with the following arguments:

    Code:
    # apt-get update
    # apt-get dist-upgrade -f
    That -f flag will attempt to fix the dependency issues that are likely plaguing your system. If that doesn't do it, try the -m (ignore missing) flag next, i.e.,

    Code:
    # apt-get dist-upgrade -m
    Another option may be reinstalling ncurses:

    Code:
    # apt-get reinstall ncurses
    and hoping that any missing dependencies get picked up during the reinstallation process.
    Hiya,

    Thanks for your help, ok so i have followed your instructions, and it seems i am coming up against a brick wall again. coming up woth the usual E: Couldn't configure pre-depend dpkg for ncurses, probably a dependency cycle. so tried to reinstall ncurses and i get E: Invalid operation reinstall

    any other ideas?

    Thanks

  4. #4
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,662
    Thanks
    40
    Thanked 564 Times in 518 Posts

    Quote Originally Posted by Reeksy86 View Post
    Hiya,

    Thanks for your help, ok so i have followed your instructions, and it seems i am coming up against a brick wall again. coming up woth the usual E: Couldn't configure pre-depend dpkg for ncurses, probably a dependency cycle. so tried to reinstall ncurses and i get E: Invalid operation reinstall

    any other ideas?

    Thanks
    Both -f and -m are returning a dependency error still? Oh dear.

    As for the reinstall error: whoopsies! Try just
    Code:
    # apt-get install ncurses --reinstall
    If that doesn't do it, I've got two more thoughts at the moment:
    Code:
    # apt-get build-dep ncurses
    and
    Code:
    # apt-get check
    and see what it reports, if anything specific, as to what it's missing.

  5. #5
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    18
    Thanks
    1
    Thanked 4 Times in 4 Posts

    ok, tried them, the ncurses one seems to be ok, however the error has now changed to grep

    the check doesnt produce any report or anything specific

  6. #6
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,662
    Thanks
    40
    Thanked 564 Times in 518 Posts

    Which one worked for ncurses? Install <package> --reinstall or build-dep <package>?

    Either way, if it got you around ncurses but now you're hung up on grep, I'd try those two commands replacing "grep" for "ncurses."

  7. #7
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    18
    Thanks
    1
    Thanked 4 Times in 4 Posts

    right still getting error messages, i have retried as follows,

    the build dep ncurses Aarons-iPhone:~ root# E: You must put some 'source' URIs in your sources.list


    Aarons-iPhone:~ root# apt-get check
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done

    I have tried changing over the ncurses and the grep but cant get anywhere with that either, just the same message coming up all the time.

  8. #8
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,662
    Thanks
    40
    Thanked 564 Times in 518 Posts

    Quote Originally Posted by Reeksy86 View Post
    right still getting error messages, i have retried as follows,

    the build dep ncurses Aarons-iPhone:~ root# E: You must put some 'source' URIs in your sources.list


    Aarons-iPhone:~ root# apt-get check
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done

    I have tried changing over the ncurses and the grep but cant get anywhere with that either, just the same message coming up all the time.
    Okay, can you navigate to /etc/apt/sources.list (maybe /etc/apt/sources.list.d/Cydia.list) and see if there's anything there? If it's empty, try adding "apt.saurik.com" in there and see if that resolves the "need sources" issue.

  9. #9
    What's Jailbreak?
    Join Date
    Apr 2011
    Posts
    18
    Thanks
    1
    Thanked 4 Times in 4 Posts

    i have checked that, and added apt.saurik.com but all i get is E: Type 'http://apt.saurik.com/' is not known on line 1 in source list /etc/apt/sources.list.d/cydia.list now.

    Is there a way to work around itunes and do restore elsewhere or a complete restore from scratch, ideally i wouldnt want to lose any contacts etc but...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts