Hi,
I have a jailbroken iPhone 3g, iOS 4.2.1, modem firmware 05.14.04, factory unlocked phone (installed iPad baseband a few years back when I was still under contract with AT&T).

I would like to install fb messenger on my phone so that I can use it as a phone/text message device (without having to sign up with a carrier). However, the app will only work on firmware 4.3 and newer.

Can anyone suggest a way so I could upgrade to 4.3 without losing my jailbreak? Or, if push comes to shove - the ability to use fb messenger at the expense of doing away with jailbreak (the apps in Cydia today are mostly geared towards owners of newer devices anyway - and, who can blame the app designers as that's where the money is).

Thank you.