Page 1 of 2 12 LastLast
Results 1 to 20 of 35

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Respring Loop Problem; Happened 4 times already on 5.1.1

  1. #1
    Default Respring Loop Problem; Happened 4 times already on 5.1.1
    I've been having major problems with my iPhone 4 running 5.1.1 and that has been jailbroken with Absinthe 2.0.2.
    It seems that SBsettings has something to do with it. Everything will be fine for a few days and randomly when any app is accessed, I'm thrown out of it and back to the home screen. If I try to use SBsettings then the respring loop begins. Attempting to hard reset will only lead to a boot loop and ultimately have to be restored. Trying to boot without mobilesubstrate enabled leads to a gray screen of death. Is there something that I'm doing wrong?

    Any help is appreciated, thanks for your time and concern.
    Last edited by sirjuice; 07-01-2012 at 12:54 AM.

  2. #2
    Quote Originally Posted by sirjuice View Post
    I've been having major problems with my iPhone 4 running 5.1.1 and that has been jailbroken with Absinthe 2.0.2.
    It seems that SBsettings has something to do with it. Everything will be fine for a few days and randomly when any app is accessed, I'm thrown out of it and back to the home screen. If I try to use SBsettings then the respring loop begins. Attempting to hard reset will only lead to a boot loop and ultimately have to be restored. Trying to boot without mobilesubstrate enabled leads to a gray screen of death. Is there something that I'm doing wrong?

    Any help is appreciated, thanks for your time and concern.
    Do you have a lot of tweaks installed/and or running?

    Just because SBSettings "appears" to be the culprit for the respring loop does not mean that it actually is the issue.

    I can tell you, from my experience of having SBSettings installed and ran, that is not the issue.

    When you run SBSettings, something in that apps code may cause a conflict with one or more cydia tweaks..

    Uninstall SBSettings and see if the apps are still crashing..

    Then reboot, reinstall SBSettings and check if that causes the respring loop.

    If you restore, I would suggest going on a NO_BB firmware from redsn0w, this will not contain the jailbreak and you can test the issues further, UNLESS of course the apps that are crashing are the ones from cydia...

  3. #3
    Thanks for the reply,

    I'm not using any major tweaks, they've all been used on my phone when I was running 4.3.x and it was completely stable for a year.
    I just suspected SBSettings because I've never used it until I updated to 5.1.1, and that's when I started experiencing the respring loop.
    The only other thing that I can think of is that an app from Cydia was installing, but it crashed and I never corrected it. Not entirely sure if it happened each of the 4 times though or it has anything to do with it.

  4. #4
    Quote Originally Posted by sirjuice View Post
    Thanks for the reply,

    I'm not using any major tweaks, they've all been used on my phone when I was running 4.3.x and it was completely stable for a year.
    I just suspected SBSettings because I've never used it until I updated to 5.1.1, and that's when I started experiencing the respring loop.
    The only other thing that I can think of is that an app from Cydia was installing, but it crashed and I never corrected it. Not entirely sure if it happened each of the 4 times though or it has anything to do with it.
    here's what I would suggest you do to eliminate SBSettings as the cause, because it is indeed an extremely useful tweak to have.

    If you have some time, backup via itunes, then restore to a CUSTOM NO_BB 5.1.1 using redsn0w. This should delete any data you have and return it to stock with no jailbreak. Then use redsn0w again to jailbreak.

    Then the first thing you should install is SBSettings, and open it up and navigate around the settings to see if the loop occurs. If it doesn't, then you know it was something else that conflicted with SBSettings when it was opened

  5. #5
    Quote Originally Posted by EVO View Post
    here's what I would suggest you do to eliminate SBSettings as the cause, because it is indeed an extremely useful tweak to have.

    If you have some time, backup via itunes, then restore to a CUSTOM NO_BB 5.1.1 using redsn0w. This should delete any data you have and return it to stock with no jailbreak. Then use redsn0w again to jailbreak.

    Then the first thing you should install is SBSettings, and open it up and navigate around the settings to see if the loop occurs. If it doesn't, then you know it was something else that conflicted with SBSettings when it was opened
    I understand what you're saying and I'll give it a go. What gets me though is that I haven't installed any new tweaks or apps lately, so I'm completely unsure of any conflicting tweaks.

  6. #6
    Quote Originally Posted by sirjuice View Post
    I understand what you're saying and I'll give it a go. What gets me though is that I haven't installed any new tweaks or apps lately, so I'm completely unsure of any conflicting tweaks.
    it may not even be tweaks conflicting with each other.

    As you use your phone, for example tapping a button or enabling a setting, code gets written and overwritten to certain places in memory and the storage location (ie the storage size), so something could have overwritten a place while something else was reading from it

    So as you can see, the software on your phone is constantly performing work..

    Its important to make sure that you use a NO_BB custom firmware that doesnt contain the jailbreak.

    By the way, were the apps that crashes the ones from appstore or cydia?

  7. #7
    Quote Originally Posted by EVO View Post
    it may not even be tweaks conflicting with each other.

    As you use your phone, for example tapping a button or enabling a setting, code gets written and overwritten to certain places in memory and the storage location (ie the storage size), so something could have overwritten a place while something else was reading from it

    So as you can see, the software on your phone is constantly performing work..

    Its important to make sure that you use a NO_BB custom firmware that doesnt contain the jailbreak.

    By the way, were the apps that crashes the ones from appstore or cydia?
    You know.. that makes complete sense and it seems like that may be the problem.
    I had this respring loop problem earlier in the day and I had to restore because I had to hurry to work. As of now it's just 5.1.1 unjailbroken, so is the NO_BB firmware still needed? And should I implement it before I rejailbreak it?
    And it seems to crash the phone at random intervals, one time I tried to check my messages and another I was on Skyfire. Which is from the Appstore.

  8. #8
    Quote Originally Posted by sirjuice View Post
    You know.. that makes complete sense and it seems like that may be the problem.
    I had this respring loop problem earlier in the day and I had to restore because I had to hurry to work. As of now it's just 5.1.1 unjailbroken, so is the NO_BB firmware still needed? And should I implement it before I rejailbreak it?
    And it seems to crash the phone at random intervals, one time I tried to check my messages and another I was on Skyfire. Which is from the Appstore.
    Implement the instructions I stated since it is now unjailbroken.

    Download just ONE of the apps from the App store that caused the crash and see if there is still the issue.

    By the way, since you restored it today, you kept it stock?.....meaning you didnt mess with it yet did you?

  9. #9
    Livin the iPhone Life eddietah's Avatar
    Join Date
    Apr 2010
    Location
    ````
    Posts
    1,298
    Thanks
    615
    Thanked 319 Times in 222 Posts

    Download iWipe in cydia and use it to wash your iPhone clean clean

  10. #10
    Quote Originally Posted by eddietah View Post
    Download iWipe in cydia and use it to wash your iPhone clean clean
    he is on 5.1.1, which is not a supported iOS for iWipe, and besides that, it doesnt fix corrupted file system which is a possibility here

    plus, its a paid tweak, which I'm pretty sure the guy wants something free and works

  11. #11
    Than he should use iCleaner, but something he sad before, bothers me.
    He used to have all the tweaks on 4.3.x, could it be that, after update to 5.1.1, some of those tweaks can't work anymore, because they were not made for 5.1.1????

  12. #12
    Same problem happened again.. one week after a restore and rejailbreak. I used redsn0w to jailbreak, but alas.. to no change.
    Does the filesystem really stay intact after a restore?

  13. #13
    Quote Originally Posted by sirjuice View Post
    Same problem happened again.. one week after a restore and rejailbreak. I used redsn0w to jailbreak, but alas.. to no change.
    Does the filesystem really stay intact after a restore?
    what do you mean by "no change"?

    you mean the apps are still crashing?.....did you install SBSettings after you jailbreak?

  14. #14
    Quote Originally Posted by EVO View Post
    what do you mean by "no change"?

    you mean the apps are still crashing?.....did you install SBSettings after you jailbreak?
    It gets to a point where most apps quit themselves to the home screen upon trying to access them and that's how I know that it's happened again. I tried to reboot but it lead to a reboot loop. I did install SBSettings on this run, I wish I knew what the cause of this was.. I jailbroke a friend's 4S recently and his is still running strong with alot of the same tweaks and SBSettings.

  15. #15
    and just to confirm, you DID restore using a 5.1.1 NO_BB firmware from redsn0w?

    and you jailbreak using Absinthe?

  16. #16
    Quote Originally Posted by EVO View Post
    and just to confirm, you DID restore using a 5.1.1 NO_BB firmware from redsn0w?

    and you jailbreak using Absinthe?
    I used to use Absinthe, but I used redsn0w this time. I wasn't 100% sure how to get ahold of that NO_BB, it's an action in redsn0w, correct?
    Is it really a game changer here?

  17. #17
    Quote Originally Posted by sirjuice View Post
    I used to use Absinthe, but I used redsn0w this time. I wasn't 100% sure how to get ahold of that NO_BB, it's an action in redsn0w, correct?
    Is it really a game changer here?
    with stubborn issues like this, you have to be patient

    no one method is "set and stone" to fix these types of issues

    the problem is with jailbreaking also comes issues and one issue can be caused by the next, like a domino effect

    use redsn0w and go to Extras -> Custom ISPW, and point it to the stock 5.1.1 ISPW, this will create a NO_BB firmware, then use the PWNED DFU mode option, also in redsn0w to put the phone in a state that allows it to be restored using a custom firmware

  18. #18
    Quote Originally Posted by EVO View Post
    with stubborn issues like this, you have to be patient

    no one method is "set and stone" to fix these types of issues

    the problem is with jailbreaking also comes issues and one issue can be caused by the next, like a domino effect

    use redsn0w and go to Extras -> Custom ISPW, and point it to the stock 5.1.1 ISPW, this will create a NO_BB firmware, then use the PWNED DFU mode option, also in redsn0w to put the phone in a state that allows it to be restored using a custom firmware
    I'm doing this as this is being posted. Are there any precautions that I should take?

  19. #19
    Quote Originally Posted by sirjuice View Post
    I'm doing this as this is being posted. Are there any precautions that I should take?
    once you restore back to a NO_BB firmware, make sure not to restore from backup.......at least not yet

    install your "crashed" apps again, this will allow you to perform a diagnosis and at least eliminate any "residual" issues from the backup, and will let you focus more on the issues in other placs

  20. #20
    Quote Originally Posted by EVO View Post
    once you restore back to a NO_BB firmware, make sure not to restore from backup.......at least not yet

    install your "crashed" apps again, this will allow you to perform a diagnosis and at least eliminate any "residual" issues from the backup, and will let you focus more on the issues in other placs
    The only thing is that my backup is saved to iCloud and you can only restore from it from a fresh restore..

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •