+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 will not restore.

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
...
  1. #1
    What's Jailbreak? BurnToasT333's Avatar
    Join Date
    May 2010
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default iPhone 4 will not restore.
    Hello,

    Ok so i decided I was going to upgrade my iPhone 4 from iOS 4.1 to 4.2.1, now one of the main reasons I decided to do this was when i would turn my phone off it would get stuck on the loader wheel and i would need to do a hard reset. So now i do the usual backup, a backup of the main things through iFunbox & just to be safe an iBye backup. All ready to go i plug it into iTunes press restore, agree to the T&C's and wait while to new firmware downloads, then the restore starts and before it has even had a chance to begin (ok it verified the restore with apple, and was in the middle of "preparing iPhone for restore") it stopped and returned the error " The iPhone "iPhone" could not be restored. An unknown error occurred (2009)"". Apparently the error according to Apples incredibly useful website means

    "Error 2000-2009: (2001, 2002, 2005, 2006, 2009, and so on) If you experience this issue on a Mac, disconnect third-party devices, hubs, spare cables, displays, reset the SMC, and then try to restore. Learn how to reset the SMC. If you are using a Windows computer, remove all USB devices and spare cables other than your keyboard, mouse, and the device, restart the computer, and try to restore. If that does not resolve, try the USB issue-resolution steps and articles listed for Error 1604 above. If the issue continues, it may be related to conflicting security software."

    Now i have tried every possible thing i could think of i have uninstalled/reinstalled iTunes several times restarted the AMDs, tried the restore of 3 different PC's, i have encountered the White Screen Of Death, restore the phone from DFU mode, from Recovery Mode, Tried Downgrading using TU, removed TU, edited the Host Files, turned off all security i have on the PC to prevent blocked of any outgoing & incoming requests, nothing, i have had 1 or 2 other errors, but think they were just down to constant retries but were 3194, 20000 have changed cables and then back to the same error of 2009.

    I have attempted to re-Jailbreak which seems to give me more response than the restore, for instance with the new Greenpois0n it goes past the animated boot logo but then goes back to the normal apple logo and then does not do anything, and with Redsn0w it gets stuck on uploading RAM Disk.

    If i need to send it back to Apple, I’m fine with that however i need to know if there is possibly anything left on my phone as i think Apple wouldn’t be too happy to find some of the stuff i have on there, it is still under warranty.

    Any assistance or advice would be greatly appreciated.

    Kind Regards,
    G

  2. #2
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    So are you getting those errors when restoring to 4.2.1 or 4.1?

    Have you attempted to put the device in recovery mode first before restoring?

    If your phone doesn't have obvious traces of jailbreak (like the greenpois0n boot logo or Cydia on the homescreen if you can even see the springboard) then I'm sure they won't notice.

  3. #3
    Super Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,921
    Thanks
    76
    Thanked 2,751 Times in 2,641 Posts

    make sure u have iTunes 10
    Download 4.2.1 fw from iclarified
    run TU> adv>uncheck box: set hosts file
    Close TU
    Put iPhone into recovery mode
    run iTunes: shift + restore to 4.2.1 Ipsw

  4. #4
    Green Apple mikelegend's Avatar
    Join Date
    Jan 2011
    Posts
    51
    Thanks
    6
    Thanked 11 Times in 7 Posts

    maybe you can try doing all this on your freind computer having windows
    No links allowed per forum rules.

    ------------------------------------------------------------------------------------------------------
    ------------------------------------------------------------------------------------------------------


  5. #5
    What's Jailbreak? BurnToasT333's Avatar
    Join Date
    May 2010
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hi will try the FW from iclarified wa using the one from felixbruns. As for the TU tried all that I can with changing the hosts also. I'm not sure if there is any evidence of jailbreak as was jailbroken before update. Also it was an update from 4.1 to 4.2.1.

    Thanks

  6. #6
    My iPhone is a Part of Me
    Join Date
    Sep 2009
    Location
    CA
    Posts
    755
    Thanks
    12
    Thanked 112 Times in 79 Posts

    Hey your just like me!! iPhone 4 4.1 unhashed try to go to 4.2.1.

    Using firmumb to preserver baseband, but after each restore\dfu restore i either get error 1xxx or error 37. When i run GP for 4.2.1 after error 1xxx1 it just goes back to the stupid connect to itunes screen and doesn't kick it out of recovery.

    When I run the jailbreak on error 37 it just go back to a white screen, thats all.

    I have the iphone firmware 4.2.1 downloaded.

    I have the latest version of itunes.

    I have SHSH for everything above\at 4.2.1.

    I dont NEED my baseband saved, but it would be nice (resell value in 2 years).

    I am running W7 64 bit.

    Any ideas?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts