+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: I can't jailbreak my iPhone 4. HELP!

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
I've been trying to jailbreak my iPhone 4 with the 4.1 firmware, but I've had no success. First I tried downloading the custom firmware 4.1 and Shift+Restoring it from iTunes,
...
  1. #1
    Green Apple
    Join Date
    Apr 2010
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default I can't jailbreak my iPhone 4. HELP!
    I've been trying to jailbreak my iPhone 4 with the 4.1 firmware, but I've had no success. First I tried downloading the custom firmware 4.1 and Shift+Restoring it from iTunes, and I got an error. Then I tried limera1n and when I got to the step where you have to hold home and power, then release one, it doesn't do anything. The same problem occurs with sn0wbreeze. And sometimes these 3 methods get me stuck in recovery mode, and I have to use iRecovery to get it out.

    What's going on? Are there any other methods I can use? Is there something wrong with my phone?

  2. #2
    iColor Themes DevouredDreams's Avatar
    Join Date
    Aug 2010
    Posts
    2,546
    Thanks
    1,035
    Thanked 1,663 Times in 808 Posts

    did you run ireb from ih8sn0w.com with sn0wbreeze to give you the greenlight to restore to custom firmware?

  3. #3
    Green Apple
    Join Date
    Apr 2010
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I figured out my main issue. I can't get into DFU mode because my home button is too unresponsive. I have to mash the button to get it to work, but it doesn't work very well when you have to hold it. Is there anyway to get into DFU mode without holding the home button?

  4. #4
    iColor Themes DevouredDreams's Avatar
    Join Date
    Aug 2010
    Posts
    2,546
    Thanks
    1,035
    Thanked 1,663 Times in 808 Posts

    redsn0w 0.9.6b4 can put you in dfu mode

  5. #5
    Green Apple
    Join Date
    Apr 2010
    Posts
    34
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by DevouredDreams View Post
    redsn0w 0.9.6b4 can put you in dfu mode
    Yeah but don't you have to do that hold "Home + Power" process on redsn0w? That's my problem. I can't do that process because of my unresponsive home button.
    Last edited by MrKrabz; 11-28-2010 at 11:25 PM. Reason: Automerged Doublepost

  6. #6
    Super Galactic Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,680
    Thanks
    40
    Thanked 570 Times in 521 Posts

    Unfortunately the only way to reliably enter "true" (a.k.a., required for the jailbreak to work correctly) DFU mode is to use the hardware button-pushing method.

    If your Home button is physically unresponsive, you can try opening the phone and replacing it (don't do it if you're not comfortable operating on the innards of your phone and irreversibly voiding your warranty) or taking it to Apple and attempting to get a replacement (if you're inside warranty). Please don't take the phone into Apple jailbroken; they'll laugh you out of the store (and you won't get a replacement). Odds are they'll also make you update the firmware to 4.2.1 before they'll consider replacing it.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts