+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgraded iPhone 3G to 4.0 - cannot change APN settings

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
Hello all. I am in need of some help (and I just found this forum) Here's my problem: I would like to know how I can change the APN settings
...
  1. #1
    Green Apple
    Join Date
    Jun 2010
    Posts
    35
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Default Upgraded iPhone 3G to 4.0 - cannot change APN settings
    Hello all. I am in need of some help (and I just found this forum)

    Here's my problem: I would like to know how I can change the APN settings on my iPhone 3G which I have just upgraded to 4.0. My phone is jailbroken and unlocked (redsn0w and ultrasn0w)

    With 3.0, I could change the APN settings, so that I can use the internet/3G. But ever since I upgraded, I can't change it anymore. That settings that is supposed to be below that cellular data toggle is not there. Hence, I can't access the internet via 3G/EDGE

    Aside from this problem (and a lack of MMS, but that doesn't really bother me much), it's ok.

    Can anyone help me?

    If not, should I downgrade back to say 3.1.3?

    Thanks!

  2. #2
    Livin the iPhone Life
    Join Date
    May 2009
    Posts
    1,269
    Thanks
    43
    Thanked 277 Times in 239 Posts

    You need to do a clean restore to 4.0 and setup as a new phone.

    this happened to someone else, and it was because they hit update, instead of restore.
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!

  3. #3
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    29,682
    Thanks
    3,450
    Thanked 9,177 Times in 5,681 Posts

    You can check this thread out if your on T-Mo, I think spooky has a fix for.
    http://modmyi.com/forums/t-mobile/65...3g-3gs-47.html

  4. #4
    Green Apple
    Join Date
    Jun 2010
    Posts
    35
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Hey guys. Thanks for the quick responses.

    babyblue_pimp: I'm pretty sure I clicked restore. I guess I'll try to do a clean restore later on.

    blkcadi: I'm not on T-Mo. I'm in the Philippines (on Globe Telecom) at the moment, and that's why I need the unlock

    In any case, I think I will try the clean restore later.

    Will I actually lose anything in the process (notes, etc.?) I synchronized my iPhone 3G before I updated to 4.0, thus I have a backup of my files.
    However, if I synchronize it later on using this backup, won't the APN settings that I had on my iPhone OS 3.0 remain in my iPhone?

    Thanks for the help! Much appreciated

  5. #5
    iPhone? More like MyPhone
    Join Date
    Jul 2008
    Posts
    127
    Thanks
    3
    Thanked 10 Times in 10 Posts

    I have the SAME problems. Twice, with two different phones. Both times I used restore, then Redsn0w 0.9.5b5-4. Funny is that the first phone still worked on EDGE w/o editing APN, while the second one doesn't. And they're both on T-Mobile US. The only difference is that the first one uses Web2Go plan and the second uses a BB data plan.

    Weird.

  6. #6
    Green Apple
    Join Date
    Apr 2009
    Location
    Rome, Italy
    Posts
    32
    Thanks
    2
    Thanked 3 Times in 2 Posts

    Sorry guys, with iOS4 carrier data are now fully signed, then for now no party......
    let's see

LinkBacks (?)


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts