+ Reply
Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone won't answer calls

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
iphone 3G, FW 2.2, jailbroken, windows OS Long time reader, first time poster. Googled my heart out on this one and couldn't find much specific so thought I would ask
...
  1. #1
    What's Jailbreak?
    Join Date
    Dec 2008
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default iphone won't answer calls
    iphone 3G, FW 2.2, jailbroken, windows OS

    Long time reader, first time poster. Googled my heart out on this one and couldn't find much specific so thought I would ask here.

    While being in heaven with my jailbroken iphone all setup, everything was working great for weeks. Now it seems that when people call I cannot hit "answer" or the red button either (forgot what it says). Sometimes hitting the home button will answer the call and that has been a workaround, but that doesn't always work. Everything else on the phone works fine.

    I've read mixed things about what the best steps are to go about fixing this.

    I currently have my iphone backed up through itunes on my pc, a jailbroken restore, which I am not sure is useful at all. Could I try restoring this to see if it fixes it? Or is that useless?

    I am sure I can go back to 2.2 with a fresh install, and jailbreak again and resync everything or restore (? possibly)

    Is there any chance I can try to fix the problem on the iphone, through ssh or otherwise without going through all of that?

    Thanks for any and all help. It is greatly appreciated.

  2. #2
    iPhoneaholic jakecigar's Avatar
    Join Date
    Aug 2007
    Location
    San Francisco, CA
    Posts
    476
    Thanks
    24
    Thanked 112 Times in 94 Posts

    Did you modify some files on the iPhone? via ssh or other?

    Are you using winterboard or other?

    WHAT did you do, that others haven't done?

    You're not out of range from the tower, are you?

    Before you restore, try to figure out what actually happened!
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  3. #3
    What's Jailbreak?
    Join Date
    Dec 2008
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Last thing I did was install supreme preferences from cydia, as far as I know it was immediately after that but I can't be certain as I didn't get a call until the next day. It has been uninstalled to no avail. Winterboard, yes. Turned all themes off and that didn't help. Has been doing it for days now all over, so unlikely it is tower related. It will answer with home button just can't answer normally.

    Thx for the help.

  4. #4
    iPhoneaholic jakecigar's Avatar
    Join Date
    Aug 2007
    Location
    San Francisco, CA
    Posts
    476
    Thanks
    24
    Thanked 112 Times in 94 Posts

    I think you answered it; it may be supreme preferences! Perhaps it is conflicting with something else you had installed.

    Contact the author, poetic_folly... on here.
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  5. #5
    What's Jailbreak?
    Join Date
    Dec 2008
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I will do that, thanks.

    As for fixing the issue, since I have Supreme Preferences uninstalled now and it did not fix the issue. What are my options to get the phone back working normally?

  6. #6
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Restore to 2.2.. then rejailbreak. In iTunes set up the phone as a NEW profile. No not install anything from Cydia... test the phone. If you're still having issues then you'll know it's hardware related and there's nothing you can do. If the issue cleared up you'll know it was software related and unless you can reproduce the problem on a consistent basis you'll never know why.
    [SIGPIC][/SIGPIC]

  7. #7
    What's Jailbreak?
    Join Date
    Dec 2008
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Okay, thank you everyone.

    One last question, I can just use chronus and aptbackup to get everything stored off and then after I resync put everything back, correct?

    Since I assume it would not be safe to restore, then I will all of my texts, is that all? I thought contacts and stuff are sync'd back if I remember.

    Also, read something about through ssh copying off the whole library folder, would that work or would it just reintroduce the problem?

    Thank you everyone, greatly appreciated.

  8. #8
    Livin the iPhone Life Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,265
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    How To Upgrade In iTunes | iPhone News, Help and Guides

    This applies to staying at the same firmware but just wanting to back everything up. To save text messages I think there are two apps in cydia that can do this for you. Treasuremytext i think.. or something.
    [SIGPIC][/SIGPIC]

  9. #9
    What's Jailbreak?
    Join Date
    Dec 2008
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    So I thought I would report back. Thanks again to everyone that helped.

    So I have tried about 100 different times to get my phone working again with mixed results.

    After reading through the guide poseidon posted I attempted that way, the "answer" problem was fixed all the way until I did a restore from my old backup. Which told me that something from the backup was causing the problem. Now as far as apple states the backup is only supposed to copy back contacts, texts, bookmarks, history, calendar, etc... It doesn't touch the firmware. This told me that the problem was a file being copied to the phone.

    I tried various other combos to get things working and ended up flashing my phone more times then I could count.

    So I decided to take a more systematic approach and go at it step by step checking to see when exactly the problem occurs.

    After restore to original 2.2 apple firmware - OK
    After setup as new phone - OK
    After jailbreak with cydia and installer - OK
    After install of OpenSSH - OK
    After install of Cydia updates (4 of them) - OK
    After install of bossprefs - OK
    After install of appbackup - OK
    After install of Chronus - OK
    After SSH back into the phone and copying back timecapsule folder for Chronus restore - OK
    After chronus restore of contacts - OK
    After Chronus restore of SMS and Safari - FAILED

    So the answer problem doesn't present itself until the sms and safari data is restored (either from a backup or through chronus). I am not sure which one of the two it is, I don't know why, but I got all the way to this point and got lazy and restored them both at once instead of testing inbetween as I had been doing the entire way up until that point.

    So at least I know what the problem is, I have no idea why though or what possibly from one of those two things could be causing it. I am going to go through the process one more time and see if I can eliminate one or the other. Though the safest bet would probably be just to not do either, as I could care less about that data getting back on the phone.

  10. #10
    What's Jailbreak?
    Join Date
    May 2008
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    Default Stranger symptoms of not being able to answer
    I have an iPhone2G (2.0 Jailbroken) exhibiting the same problem. I call it with my iPhone 3G (2.2 Jailbroken) and cannot hit the answer button. Everything else worked. Then I tried calling it with a land line and it WORKED!!! Restore it to 2.2.1 firmware via iTunes and did not jailbreak it and the same symptom. So it has NOTHING TO DO WITH THE PHONE GETTING THE CALL. Called the firmware restored iPhone2G again with my Jailbroken iPhone3G and again it cannot answer. Call from my wife's UN-Jailbroken iPhone3G and it works!!!!

    SO IT HAS TO DO WITH THE CALLING PHONE. If the originating iPhone is Jailbroken, the receiving iPhone (jailbroken or not) cannot answer.

    Go figure!!! I cannot believe how Apple's firmware can tell whether an originating caller is using an iPhone, much less a Jailbroken iPhone.

    Need some experts help here. Will restore my iPhone to un-jailbreak it for now.

  11. #11
    Moderator Admin Broomhead's Avatar
    Join Date
    Sep 2007
    Location
    Outside Chicago IL
    Posts
    17,141
    Thanks
    502
    Thanked 1,716 Times in 1,169 Posts

    I have a similar problem. I have 1 contact that I'm unable to answer his call when he rings me.
    Here's what I've found that does work: When this person calls me, I slide to answer (it doesn't answer) then I hit the home button and bam, it answers the call. go figure

  12. #12
    What's Jailbreak?
    Join Date
    Nov 2008
    Posts
    5
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Lightbulb SOLUTION: Change your contact's custom ringtones
    I had the same problem: found a solution over in a mactalk forum, thanks to wilsonray1.

    Basically this problem can occur when you assign a ringtone to a contact and then delete the ringtone via ssh or cydia. The phone just vibrates when that contact calls, and searches for the ringtone, but does not allow the lockscreen to release and answer the call.

    To FIX it, just reinstall the ringtones, or re-assign the contacts with new ringtones that are currently stored on the phone. No updating or re-jailbreaking necessary!

  13. The Following User Says Thank You to krackerjack22 For This Useful Post:

    mr f (11-04-2009)

  14. #13
    Livin the iPhone Life CaptainChaos's Avatar
    Join Date
    Sep 2008
    Location
    In a van down by the river
    Posts
    4,825
    Thanks
    551
    Thanked 515 Times in 427 Posts

    Krackerjack hit the nail on the head with that one Thanks!

  15. #14
    What's Jailbreak?
    Join Date
    May 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Had the same problem last summer after restoring my jailbroken Iphone. Since I had custom ringtones for most of my contacts and the ringtones were now gone, I could not answer a phone call unless I clicked the Home button. It took me awhile to figure out that it was the missing ringtones that were causing the issue. The fix for me was to either change the ringtone for a contact to an existing one or just upload the missing ringtones again.

  16. #15
    What's Jailbreak?
    Join Date
    Apr 2009
    Posts
    23
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Thanks all I had the same trouble but found the solution from krackerjack22

    keep up the great work all

LinkBacks (?)


Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts