i'm having issues when downgrading and then upgrading back to 1.1.2 with the oktoprep. Is there some way to activate my iphone with att when i get it to that state? I'm perfectly fine with 1.1.1, i don't need the better version