+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 30

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 1.1.2 Jailbreak.jar not launching in Mac OSX (PPC 10.4.11)

is a discussion within the

General

forums, a part of the

Jailbreak / Downgrading / Upgrading

section;
Dear All, I have a problem with upgrading to 1.1.2 from unlocked jailbroken 1.1.1 (originally 1.0.2 / anysim) due to the new 1.1.2 jailbreak.jar file. I've downloaded the new version
...
  1. #1
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Default 1.1.2 Jailbreak.jar not launching in Mac OSX (PPC 10.4.11)
    Dear All,

    I have a problem with upgrading to 1.1.2 from unlocked jailbroken 1.1.1 (originally 1.0.2 / anysim) due to the new 1.1.2 jailbreak.jar file. I've downloaded the new version which is supposed to work for PPC Macs and it still won't launch. I also downloaded the dylib file that I've seen mentioned after tons of surfing through other threads and it still won't launch when clicking on the jar file. Any ideas? I've tried updating Java etc, still no change. However, I haven't tried it with the iphone connected yet. Does it have to be connected in order to launch the program? (Wouldn't have thought it makes a difference though - it should launch anyway). ?

    Any suggestions gratefully received.

    Alex

  2. #2
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Yes, the iPhone needs to be connected to your computer when you run jailbreak.jar
    Get "iPod & iTunes for Dummies", it'll change your life.

  3. #3
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Great, I'll give that a a try. Is the dylib file I placed in the library likely to affect the new version of the jailbreak file?

    Also, another quick question - as this didn;t work last time, I downgraded baseband etc and upgraded back to 1.1.1. I used the *#307# method. I now have a _MacOSX directory on the phone created by AppTapp. However, phone is crashing more than usual now and wi-fi / phone signals seem to drop in and out far more than they used to when I was on 1.1.1 which was jailbroken with Independence and Anysim. Is this likely to be due to 3rd party apps or the downgrade / upgrade procedure? In light of this, am I better off virginising to 1.0.2 and from a clean phone upgrade straight to 1.1.2 or just upgrade now?

    Many thanks. Everyone giving advice on this site is very cool - fantastic iPhone / MacHead resource.

    Alex

  4. #4
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    The only program I know of that causes constant crashing of the iPhone is Summerboard when the Dim Background option is turned on.

    You should be fine as far as running jailbreak.jar
    Get "iPod & iTunes for Dummies", it'll change your life.

  5. #5
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Fantastic - I'll give it a go. Many thanks- this site is a great resource. Just turned off the Dim Wallpaper feature and immediately phone was quicker on keypad and no crashes yet. Can't believe I didn;t see that tip before! I hope all you guys work for Apple. If not, you should be.

    A

    Quote Originally Posted by Eurisko View Post
    The only program I know of that causes constant crashing of the iPhone is Summerboard when the Dim Background option is turned on.

    You should be fine as far as running jailbreak.jar
    Ok, tried it again. Installed Oktoprep, updated and now....nothing. Jailbreak.jar still won't launch with or without dylib file in library. This is driving me nuts. Please help - this is my setup:

    Mac: 10.4.11
    iTunes 7.5

    iphone: Americain version on 1.0.2 upgraded and jailbroken / unlocked to 1.1.1. Community sources, bsd subsystem, open ssh installed. Oktoprep and upgraded to 1.1.2. Now ready to be jailbroken and unlocked....

    Still nothing but found a workaround to launch jailbreak from root - seems to be a permission problem:

    http://weblog.techdad.net/2007/11/12...t-work-for-me/

    See point 7. However Jailbreak then quit saying Oktoprep wasn't installed but obviously it was. Trying a workaround from another thread here involving sshing in to the phone, but Cyberduck won't connect. Reports an error. SSH was definately installed and activated prior to upgrade. What next? Jeesh....
    Last edited by spuggied; 11-30-2007 at 11:28 AM. Reason: Automerged Doublepost

  6. #6
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Ok, you said you upgraded to 1.1.2, very important: did you Restore or Update? If you restored, the OKtoPrep changes would have been wiped.
    Get "iPod & iTunes for Dummies", it'll change your life.

  7. #7
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Hi,

    Definately updated. I'm getting used to following these threads to the letter! I'm trying to ssh in via terminal now. Can't remember command - is it "ssh -/ipaddress" ?

    Just thought - could all this be because I didn't virginise my phone at 1.1.1 first before the update? From the threads I'd read I'd assumed going from a jailbroken and AnySim unlocked 1.1.1 was ok...
    Last edited by spuggied; 11-30-2007 at 11:40 AM. Reason: Automerged Doublepost

  8. #8
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by spuggied View Post
    Hi,

    Definately updated. I'm getting used to following these threads to the letter! I'm trying to ssh in via terminal now. Can't remember command - is it "ssh -/ipaddress" ?

    Just thought - could all this be because I didn't virginise my phone at 1.1.1 first before the update? From the threads I'd read I'd assumed going from a jailbroken and AnySim unlocked 1.1.1 was ok...
    You shouldn't have had to virginize. To SSH in, it's: #shh -l root IP

    If you haven't changed the password, it should still be alpine. I would ask the conceited guys about the OKtoprep error, they would know best what's going on with that.
    Get "iPod & iTunes for Dummies", it'll change your life.

  9. #9
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    It seems to be a language issue I think. Launched command: sudo java -jar jailbreak.jar to get the jailbreak.jar to launch. Terminal is coming back with:

    Mac detected...
    iPhuc at: /private/tmp/tmp39809
    Connecting to iPod/iPhone...
    This utility can only be used if you have already run OktoPrep before updating to 1.1.2.
    Size calculation: 945183002
    Uploading Installer.app files...
    java.lang.NullPointerException
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:341 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:330 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:318 )
    at com.planetbeing.iPhuc.IPhuc.mkdir(IPhuc.java:124)
    at com.planetbeing.iPhuc.IPhuc.recursiveUpload(IPhuc. java:59)

    Is it saying the language is a problem? I've seen on other posts that if the language on the Mac and pjone are set to English, it solves the issue. The language on my Mac is English. The phone....well I can't get into it now to change it, but it was also on English I think.

  10. #10
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by spuggied View Post
    It seems to be a language issue I think. Launched command: sudo java -jar jailbreak.jar to get the jailbreak.jar to launch. Terminal is coming back with:

    Mac detected...
    iPhuc at: /private/tmp/tmp39809
    Connecting to iPod/iPhone...
    This utility can only be used if you have already run OktoPrep before updating to 1.1.2.
    Size calculation: 945183002
    Uploading Installer.app files...
    java.lang.NullPointerException
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:341 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:330 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:318 )
    at com.planetbeing.iPhuc.IPhuc.mkdir(IPhuc.java:124)
    at com.planetbeing.iPhuc.IPhuc.recursiveUpload(IPhuc. java:59)

    Is it saying the language is a problem? I've seen on other posts that if the language on the Mac and pjone are set to English, it solves the issue. The language on my Mac is English. The phone....well I can't get into it now to change it, but it was also on English I think.
    Java.lang is refering to the Java programming language, not a spoken language. NullPointerException means it can't find the destination to write to.

    You're running jailbreak.jar through terminal? What happens if you run it just by double clicking on it?
    Get "iPod & iTunes for Dummies", it'll change your life.

  11. #11
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Nothing happens on double clicking. For some reason it won't launch. No idea why. Updated java etc. No change.

    Tried sshing in but Terminal is saying "connection refused". I'm stuck. Really need help.

    Ok. Tried again after taking dylib file out of library. Terminal comes back with:

    Mac detected...
    iPhuc at: /private/tmp/tmp16188
    Connecting to iPod/iPhone...
    This utility can only be used if you have already run OktoPrep before updating to 1.1.2.
    Size calculation: 945183002
    Uploading Installer.app files...
    java.lang.NullPointerException
    at com.planetbeing.iPhuc.IPhuc.waitForPrompt(IPhuc.ja va:264)
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:337 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:330 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:318 )
    at com.planetbeing.iPhuc.IPhuc.fileExists(IPhuc.java: 148)
    at com.planetbeing.iPhuc.IPhuc.mkdir(IPhuc.java:123)
    at com.planetbeing.iPhuc.IPhuc.recursiveUpload(IPhuc. java:59)
    at com.planetbeing.touchFree.TouchFreeEngine.jailbrea k(TouchFreeEngine.java:98)
    at Jailbreak$Task.run(Jailbreak.java:255)
    at java.lang.Thread.run(Thread.java:613)
    java.lang.NullPointerException
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:341 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:330 )
    at com.planetbeing.iPhuc.IPhuc.execute(IPhuc.java:318 )
    at com.planetbeing.iPhuc.IPhuc.fileExists(IPhuc.java: 148)
    at com.planetbeing.iPhuc.IPhuc.mkdir(IPhuc.java:123)
    at com.planetbeing.iPhuc.IPhuc.recursiveUpload(IPhuc. java:59)
    at com.planetbeing.touchFree.TouchFreeEngine.jailbrea k(TouchFreeEngine.java:98)
    at Jailbreak$Task.run(Jailbreak.java:255)
    at java.lang.Thread.run(Thread.java:613)


    Anyone else in this situation???
    Last edited by spuggied; 11-30-2007 at 12:21 PM. Reason: Automerged Doublepost

  12. #12
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,308
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Connection refused means the SSH daemon isn't running. Check with UIctl to make sure its there and running. Go into your Utilities folder, and run the Java Control app. I'm at work right now so I can't give step by steps, but your Java is probably still set to run 1.3 or 1.4 applets instead of 1.5, you'll need to correct that.
    Get "iPod & iTunes for Dummies", it'll change your life.

  13. #13
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Ok, this shows what i don't know - what's UIctl? Also, can't find Java Control App in utilities folder. Under the Java folder I have Java 1.3.1 and 1.4.2 plugin settings files, java web start, input method hotkey file and a J2SE 5.0 folder with Java Preferences and cache viewer inside.

    Is it anything to do with iPHUC? Not that I know what it is of course... ahem...
    Last edited by spuggied; 11-30-2007 at 12:42 PM. Reason: Automerged Doublepost

  14. #14
    Green Apple
    Join Date
    Sep 2007
    Posts
    50
    Thanks
    3
    Thanked 16 Times in 11 Posts

    Jailbreak not launcing on a mac indicates to me OktoPrep was not installed properly. So the jailbreak process will not start.

  15. #15
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by w9cae View Post
    Jailbreak not launcing on a mac indicates to me OktoPrep was not installed properly. So the jailbreak process will not start.
    Hi,

    I thought that as well, but I def ran Oktoprep properly and it the install confirmation came up as standard in installer. Looking at other threads, it seems a lot of other people have had a similar problem. I can't find any solutions though. Any ideas? Am I better off downgrading (1.1.1 or 1.02?) and starting over?

    All the best.

  16. #16
    Green Apple
    Join Date
    Sep 2007
    Posts
    50
    Thanks
    3
    Thanked 16 Times in 11 Posts

    You will have to downgrade to FW 1.1.1 and re-run OktoPrep. Sometime for some strange reason something installs but doesnt install correctly.

    Also one big mistake made by many is they have hit the reflash button which wipes out the OktoPrep where as upgrade keeps OktoPrep.

    To downgrade then re-run OktoPrep & then back to FW 1.1.2 shouldnt take very long.

  17. #17
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by w9cae View Post
    You will have to downgrade to FW 1.1.1 and re-run OktoPrep. Sometime for some strange reason something installs but doesnt install correctly.

    Also one big mistake made by many is they have hit the reflash button which wipes out the OktoPrep where as upgrade keeps OktoPrep.

    To downgrade then re-run OktoPrep & then back to FW 1.1.2 shouldnt take very long.
    Cheers - I'll try that and let you know what happens.

  18. #18
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by w9cae View Post
    You will have to downgrade to FW 1.1.1 and re-run OktoPrep. Sometime for some strange reason something installs but doesnt install correctly.

    Also one big mistake made by many is they have hit the reflash button which wipes out the OktoPrep where as upgrade keeps OktoPrep.

    To downgrade then re-run OktoPrep & then back to FW 1.1.2 shouldnt take very long.
    Ok, I've downgraded, jailbroken using jailbreakme.com, used AnySim 1.2.1, installed Oktoprep, upgraded (not restored), double clicked on jailbreak.jar and again nothing happened. Again, ran it from Terminal and it's coming up with the same as before.

    Any suggestions. Shall I just stay on 1.1.1?

    All the best.

  19. #19
    Green Apple
    Join Date
    Sep 2007
    Posts
    50
    Thanks
    3
    Thanked 16 Times in 11 Posts

    I was reading someplace a similar problem this bloke updated his java version and the jailbreak software worked.

  20. #20
    Green Apple
    Join Date
    Oct 2007
    Posts
    37
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by w9cae View Post
    I was reading someplace a similar problem this bloke updated his java version and the jailbreak software worked.
    Hi,

    Tried it - Java is on J2SE 5.0 which I think is the latest according to Apple. Still locked at Emergency screen and jailbreak still won't run.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts