+ Reply
Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Iphone 4S wont charge sometimes....

is a discussion within the

General Verizon / Sprint / CDMA iPhone Chat

forums, a part of the

iPhone on Verizon / Sprint / CDMA

section;
Im having an issue where my iphone will only charge using the white adaper via outlet only... If I use USB cable via computer or another adapter it wont charge...
...
  1. #1
    Green Apple Zekeman's Avatar
    Join Date
    Jun 2010
    Posts
    56
    Thanks
    3
    Thanked 1 Time in 1 Post
    Default Iphone 4S wont charge sometimes....
    Im having an issue where my iphone will only charge using the white adaper via outlet only... If I use USB cable via computer or another adapter it wont charge... It doesnt always do this just sometimes... I ends up fixing itself and I dont know how... is anyone else having this issue?? Like I said its a random issue but this time seems longer to fix, and I need to sync to itunes.....

  2. #2
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,825
    Thanks
    63
    Thanked 264 Times in 253 Posts

    Is the USB you're using an after market USB (Not certified by Apple)? If not your computer probably has a bad USB port making it so you can't charge it. Try a different computer and see what happens.
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

  3. #3
    The One and the Only (retired secret moderator) iPod's Avatar
    Join Date
    Aug 2010
    Location
    Planet Earth
    Posts
    2,127
    Thanks
    55
    Thanked 94 Times in 88 Posts

    Yah just check you charger

    secret moderator... Please hit that THANKS button over there if I helped you in any single way

  4. #4
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Try another cable if possible. That'll tell you if it's the cable or your phone. It sounds like your cable though. It's best to use higher quality cables, if you are currently not using the original or a better quality one right now.

  5. #5
    Green Apple Zekeman's Avatar
    Join Date
    Jun 2010
    Posts
    56
    Thanks
    3
    Thanked 1 Time in 1 Post
    Tried 3 cables and it will still only charge via wall... I tried 4 computers with those 3 cables still doesn't work... So it's a phone issue I assume...

  6. #6
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    If those are all Apple cables then...yeah I would say it's a phone issue. At least it does charge though...it would suck if it didn't charge at all. When you plug the cables into the computer, does iTunes at least recognize it and sync?

    Edit: do you have a chance to try those cables on another iDevice?

  7. #7
    Green Apple Zekeman's Avatar
    Join Date
    Jun 2010
    Posts
    56
    Thanks
    3
    Thanked 1 Time in 1 Post
    Nope iTunes doesn't recognize... And yes all cables find my other iPhone....

  8. #8
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Oh, then it's confirmed, it's your phone. Have you cleaned the charging port?

    Is it still under warranty?

    That's a dumb question lol, sorry. Since the 4S is still pretty new it probably is.

  9. #9
    What's Jailbreak?
    Join Date
    Mar 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I had this issue Thursday, I was suppose to go to a apple store and exchanged it but I fixed it restoring it but I lost my jailbreak and stuck on 5.1 :/. I have 4s 64gs oh well but, that will fix your problem, might wanna shsh if ur restoring so you won't go through this.. g/l

  10. #10
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,825
    Thanks
    63
    Thanked 264 Times in 253 Posts

    Always save your SHSH before restoring to an un-jailbroken firmware...
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

  11. #11
    Peanut Brain confucious's Avatar
    Join Date
    Oct 2008
    Location
    Woking
    Posts
    10,241
    Thanks
    137
    Thanked 900 Times in 817 Posts

    Have you used Photoalbum+ and uninstalled it?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  12. #12
    Green Apple Zekeman's Avatar
    Join Date
    Jun 2010
    Posts
    56
    Thanks
    3
    Thanked 1 Time in 1 Post
    Ok I uninstalled photoalbum+, I cleaned the charging port, and actually had the " problem charger" work for a few seconds until I took it off then put it back on... (this charger works fine with other iPhone)

    Im going to chalk this up to a bad charging port...

    Though if I save my shsh I still though I couldn't restore back to 5.01 losing my JB?

    Weird though how it worked for a few seconds...

  13. #13
    Green Apple Zekeman's Avatar
    Join Date
    Jun 2010
    Posts
    56
    Thanks
    3
    Thanked 1 Time in 1 Post
    Confucius.... You are the man... I probed more with photoalbum+ and this was indeed the issue!!!! I upgraded to a new beta and it resolved the issue!!!!! Thank you much... I figured disabling all substrate would bypass any addons but I was wrong!!!

    Thanks all for your input!!!!
    Last edited by Zekeman; 04-15-2012 at 11:55 PM.

  14. #14
    Peanut Brain confucious's Avatar
    Join Date
    Oct 2008
    Location
    Woking
    Posts
    10,241
    Thanks
    137
    Thanked 900 Times in 817 Posts

    Does the new beta solve the other problem with PhotoAlbum+ with pictures not displaying in MMS?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  15. #15
    Green Apple Zekeman's Avatar
    Join Date
    Jun 2010
    Posts
    56
    Thanks
    3
    Thanked 1 Time in 1 Post
    Yes it does... Everything seems to be fine all around... With PA+ ...

  16. The Following User Says Thank You to Zekeman For This Useful Post:

    confucious (04-16-2012)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts