Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Photos disappear then restore themselves

  1. #1
    iPhoneaholic xwinger's Avatar
    Join Date
    Jul 2008
    Location
    Calgary, Canada
    Posts
    470
    Thanks
    39
    Thanked 26 Times in 24 Posts

    Default Photos disappear then restore themselves
    Since i jailbroke iOS 7 this has happened twice. I have over 8000 photos on my iphone 5. A few minutes ago the photos app kept crashing when I opened it so I rebooted. I then had 0 photos. A few minutes later it said "Restoring..." and they are slowly coming back.

    Does anyone know what could cause this? I updated evasi0n yesterday as well as everything else that had an available update.

    Let me know if you have any ideas.

    Thanks.
    I am not a jailbreak n00b
    I like to drink iPhoneahol...
    Circa 2008

  2. #2
    Did you ever find a resolution to this problem, or what caused it? I have a friend that this happened to.

  3. #3
    Are your photos in your camera roll ? Or are they on iCloud ?
    The theme in my posts is 3 4 All, by Sk37cH.

    The numerous versions released, and infinite versatility, beats IconOmatic mods. By quality.

  4. #4
    Photos were in iCloud but turned iCloud off prior to jailbreaking about 2 months ago.

  5. #5
    Quote Originally Posted by BinkyRollTide View Post
    Photos were in iCloud but turned iCloud off prior to jailbreaking about 2 months ago.
    Ok. Weird one.
    So you haven't resorted to restore since updating Evasi0n7 ? Or have you ?
    If you haven't, I'd recommend you to !

    You can always try running iCleanerPro a few times to clean some stuff out before restoring to 7.0.6, but 7.0.6 is a more viable fix (to the security flaw Apple had left out) than using the tweak versions that keep you on 7.0.4 and patch the breach. That tweak causes side effects.
    You better get yourself a stable device back on a jailbrakable firmware before 7.1 is out !
    Last edited by Alfroggy; 03-09-2014 at 11:05 PM.
    The theme in my posts is 3 4 All, by Sk37cH.

    The numerous versions released, and infinite versatility, beats IconOmatic mods. By quality.

  6. #6
    I have this happen at least once a month. I had the problem back when I was on iOS 6 with the JB as well. I have over 10k photos, 150+ videos...so it takes a while to restore. And you have no access to new photos until the restore is done.

    I'll come back here if I find the solution, but I think it has to do with the volume of pictures and how other camera apps access the pics folder. Not sure. Don't think it's JB related since it's happened to me for over a year now at least, if not longer.

  7. The Following User Says Thank You to edwilk55 For This Useful Post:

    Alfroggy (03-11-2014)

  8. #7
    Hey guys,

    any solution there?

    I got this problem since I jailbroken my iPhone 4s..
    it is so annoying, sometimes when this happen I lose some new photos I've taken before-.-

  9. #8
    Quote Originally Posted by saymon View Post
    Hey guys,

    any solution there?

    I got this problem since I jailbroken my iPhone 4s..
    it is so annoying, sometimes when this happen I lose some new photos I've taken before-.-
    You sure the issue you experience is the same ?

    Or does it happen after you use pictures from your camera roll through iFile, in the process of themeing your iPhone ?
    The theme in my posts is 3 4 All, by Sk37cH.

    The numerous versions released, and infinite versatility, beats IconOmatic mods. By quality.

  10. #9
    Quote Originally Posted by Alfroggy View Post
    You sure the issue you experience is the same ?

    Or does it happen after you use pictures from your camera roll through iFile, in the process of themeing your iPhone ?
    i did try to use pictures from the camera roll for an iwidget and it messed up my phone. camera stopped saving pics and all of my pics inside the photo app becomes white once i open them. i tried to find a fix but none was found, i had to restore to iOS 7.1 as i can't use a phone that doesn't save or open pics...

    can you please explain what happened? you seem to know about such an issue, since you suggested it.

  11. The Following User Says Thank You to Arabology For This Useful Post:

    Alfroggy (03-25-2014)

  12. #10
    Quote Originally Posted by Arabology View Post
    i did try to use pictures from the camera roll for an iwidget and it messed up my phone. camera stopped saving pics and all of my pics inside the photo app becomes white once i open them. i tried to find a fix but none was found, i had to restore to iOS 7.1 as i can't use a phone that doesn't save or open pics...

    can you please explain what happened? you seem to know about such an issue, since you suggested it.
    Yep, from my understanding it's due to deleting pictures through system rather than within Photos application from home screen.

    iOS still is made to think pictures are still there when they are not, because of cached information.

    One fix is to give the /var/stash/mobile/Media/DCIM/ folder read, write and access permissions to all three 'User', 'Group' and 'Everyone' items.
    I also set owner permissions to mobile for both 'Owner' and 'Group'
    Before exiting that menu accessible from the blue arrow next to the 'DCIM' folder name, I toggle 'Apply Hierarchically' on.

    Here's how it is, seen from iFile :

    ImageUploadedByModMyi1395756822.883720.jpg

    Upon saving the changes you've made iFile will briefly show a loading wheel, confirming the changes were applied.
    The theme in my posts is 3 4 All, by Sk37cH.

    The numerous versions released, and infinite versatility, beats IconOmatic mods. By quality.

  13. The Following 3 Users Say Thank You to Alfroggy For This Useful Post:

    Arabology (03-25-2014), IrobertI (03-26-2014), saymon (03-26-2014)

  14. #11
    Quote Originally Posted by Alfroggy View Post
    Yep, from my understanding it's due to deleting pictures through system rather than within Photos application from home screen.

    iOS still is made to think pictures are still there when they are not, because of cached information.

    One fix is to give the /var/stash/mobile/Media/DCIM/ folder read, write and access permissions to all three 'User', 'Group' and 'Everyone' items.
    I also set owner permissions to mobile for both 'Owner' and 'Group'
    Before exiting that menu accessible from the blue arrow next to the 'DCIM' folder name, I toggle 'Apply Hierarchically' on.

    Here's how it is, seen from iFile :

    ImageUploadedByModMyi1395756822.883720.jpg

    Upon saving the changes you've made iFile will briefly show a loading wheel, confirming the changes were applied.
    Thank you so much for these information, i just wish i had found this exact thread and quoted you before i restored my device.
    Now i'm stuck with a non-jailbreak-able device till god knows when.

    i actually didn't delete any picture, i only renamed one of them to photo.png and copied it to the iwidget directory. i bet the iOS thought it got deleted once renamed.

    Oh well, cheers
    Last edited by Arabology; 03-25-2014 at 09:30 AM.

  15. The Following User Says Thank You to Arabology For This Useful Post:

    Alfroggy (03-25-2014)

  16. #12
    No problem. Sorry the fix came too late.

    Quote Originally Posted by Arabology View Post

    i actually didn't delete any picture, i only renamed one of them to photo.png and copied it to the iwidget directory. i bet the iOS thought it got deleted once renamed.

    Oh well, cheers
    Moving out of the initial directory is the same as deleting from it.
    The theme in my posts is 3 4 All, by Sk37cH.

    The numerous versions released, and infinite versatility, beats IconOmatic mods. By quality.

  17. The Following User Says Thank You to Alfroggy For This Useful Post:

    Arabology (03-25-2014)

  18. #13
    Thanks Alfroggy,

    yeah I'm pretty sure It is the same issue.

    Now I changed the permissions like you said, I hope this gonna help.

    Have to wait now to see if the problem is away, I will give feedback in some days.

  19. The Following User Says Thank You to saymon For This Useful Post:

    Alfroggy (03-26-2014)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •