Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: help cydia error " Couldn’t configure pre-depend dpkg for ncurses"

  1. #1
    Default help cydia error " Couldn’t configure pre-depend dpkg for ncurses"
    Hello
    I have an iphone 4 on firmware 4.3.3 unlocked by a gevey sim, my problem is whenever i try to download anything from cydia including updates i get this errer "Couldn't configure pre-depend dpkg for ncurses, probably a dependancy cycle". Can anyone please help me fix this error, please provide a step by step instruction because i am not tech savy. Thank u in advance!!!!

  2. #2
    I guess, that IOS 4.3.3 can not support any more any updates or new tweaks showing up in Cydia. It's just to old. Time for you to upgrade your IOS.

  3. #3
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, if you have iFile installed you may be able to re-install the dpkg deb from Saurik.

  4. #4
    If i upgrade my iphone to the newest firmware will my gevey sim still work?

  5. #5
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Sorry, not had any experience of the Gevey sim. Have you got iFile installed?

  6. #6
    no i don't, ok can i update my iphone to 6.1.3, would i be able to software unlock and jailbreak it, or should i not take the risk?

  7. #7
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, software unlock ultrasnow depends on you having baseband 01.59.00. (Check iPhone settings, general, about) You may find if you check Cydia, Home page, TSS Center, that you have some iOS 4 or 5 blobs. If you do, you could restore to that iOS and have an untethered jailbreak. You should have at least your 4.3.3 blobs there so you could restore to the same iOS.
    Also check the Gavey Sim website for compatible iOS/modem baseband options.
    GEVEY™ Ultra for GSM iPhone 4
    If you do upgrade to say iOS5.1.1 (presuming you have the Cydia blobs) you must already have baseband 4.10.01 and MUST NOT upgrade your baseband during the restore process. Both Redsnow and iFaith have options for this.
    Last edited by DC_Dave; 08-20-2013 at 03:45 AM.

  8. #8
    unfortunately i won't be able to software unlock then because my baseband is higher for ultrasnow, and i don't have any blobs saved unfortunately, can i make one now for my 4.3.3 and if so can u please give a step by step intruction on how to do so?

  9. #9
    Gevey card works with all IOS updates, 6.1.3 included, provided your BB stays on max. 4.10. So you need to upgrade and preserve BB.
    For that you need Snowbreeze 2.9.14. At the same time, Snowbreeze will also jailbreak your phone, but remember, on 6.1.3, it's only tethered. If there are words you don't understand, use google, beleive me, the best friend we have

    Here is one useful link:
    Jailbreak iOS 6.1.3 With Sn0wbreeze 2.9.14 [How-To Tutorial] | Redmond Pie

    Just curious, why don't you try to permanently unlock your phone?

  10. #10
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, Seeing as you are already jail broken on iOS4.3.3, then Cydia should already have uploaded your 4.3.3 blobs and probably more?

  11. #11
    Quote Originally Posted by DC_Dave View Post
    Hi, Seeing as you are already jail broken on iOS4.3.3, then Cydia should already have uploaded your 4.3.3 blobs and probably more?
    Cydia only saves them if you open it at least once during a signing window.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •