Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: OpenNotifier (SafeMode)

  1. #1
    What's Jailbreak?
    Join Date
    Apr 2013
    Posts
    11
    Thanks
    0
    Thanked 2 Times in 1 Post
    Default OpenNotifier (SafeMode)
    Hello everyone, I'm really trying to get some help here as I've tried everything that I could and could not figure out the issue on my own. I'm having a issue with installing OpenNotifier on my iPhone, but there's some abnormal things that are happening. First, the tweak, when installed, puts MY iPhone in SafeMode. The weird thing about it is that my wife's iPhone has it installed and it seems to work just fine. We both have OpenNotifier 2.0 beta 2.

    I though that, because we have different tweaks installed, the issue was with my tweaks. So I tried going into SBSettings and turning off every mobile substrate add-on and none of them corrected the issue unless I turned OpenNotifer off. I was about to give up and just uninstall it, but then I tried turning off libstatusbar… That seem to have done it. Before I turned libstatusbar off, I had ALL mobile substrate add-ons off with the exception of OpenNotifier and libstatusbar. Once I turned either one of those two off, my iPhone finally came out of SafeMode.

    Thank you all for all your help. Any information will be helpful. Thanks, once again.

    I'm jailbroken with Evasi0n on 6.1.2. iPhone 5.

  2. #2
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, I think I would click on libstatusbar and then uninstall, but do not uninstall! Cydia will then list the tweaks you have that rely on libstatusbar. Then you can compare the reliant tweaks you have on both phones and try uninstalling any uncommon ones. For example, on my iOS6 iPhone 4, Mute Icon, Celeste Bluetooth File Sharing, BT Stack and SpringBoardAccess all use libstatusbar.

  3. #3
    What's Jailbreak?
    Join Date
    Apr 2013
    Posts
    11
    Thanks
    0
    Thanked 2 Times in 1 Post
    ImageUploadedByModMyi1375261220.501895.jpg

    This is what I had come up when I did that in Cydia. Unfortunately when I started to remove each one it still went to safe mode. I then decided to remove all of them at once, but nothing changed. My iPhone still went into safe mode. The only difference between my iPhone and the other was that the other iPhone had OpenNotifier and the OpenNotifier Premium Pack.

  4. #4
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, OpenNotifier was last updated May 2012, and it says for iOS5, while the OpenNotifier Premium pack was updated June 2013. My guess is that you will need both to work on iOS6. You can also share Cydia purchased tweaks between your iDevices.

  5. #5
    What's Jailbreak?
    Join Date
    Apr 2013
    Posts
    11
    Thanks
    0
    Thanked 2 Times in 1 Post
    Dang it… Just when I thought I figured it out, something else happens.

    Well, as it turns out, I had the beta installed from n00neimp0rtant's repo. It was OpenNotifier 2.0~beta 2. I then removed that repo and installed the OpenNotifier from Cydia, which was version 1.1.3. When I re-sprung my iPhone, it stayed normal. I thought, "heck yeah!" But then I got a little down because when I went to set the notification icon for an app, it crashed! It took me back to the home page on my iPhone. I don't really know what else to do.

    Can anyone see if installing the beta of OpenNotifier from n00neimp0rtant's repo will recreate my issue?
    http://n00neimp0rtant.dyndns.org/repo/

    Edit: It seems that's its only crashing when I try to set certain icons for individual apps. Most of them are social networking apps. This is the list: AppStore, Draw 2, KIK, PayPal, ScoreCenter, FaceBook, TweetBot, FaceBook Messenger, Instagram, and Twitter.
    Last edited by JinOnyxMusic; 08-01-2013 at 02:12 AM.

  6. #6
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    905
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, tried it on my iOS6.1 iPhone 4 and seems to work ok. As its a beta, you could send a crash report to the developer so that he can maybe fix your issue.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •