it's a shame that I can't get this work the way it's suppose to since when I have this on volume buttons doesn't mute incoming texts. I email the dev and he said to reset my preferences which I did and still the same thing. Even tried a reinstalled and same thing. Is there anyway to get this working like how it suppose to? Thanks.