+ Reply
Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: HTTP 403 Forbidden on Paid Packages

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Hello dear MMi fellows. I didn't know where to post this so, please, if I did it in the wrong place, relocate or delete this post. I've searched the forum
...
  1. #1
    What's Jailbreak?
    Join Date
    Feb 2013
    Location
    São Paulo, Brazil, Brazil
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation HTTP 403 Forbidden on Paid Packages
    Hello dear MMi fellows.

    I didn't know where to post this so, please, if I did it in the wrong place, relocate or delete this post.

    I've searched the forum and haven't found anyone having exactly the same problem I have been facing.

    Since evasi0n went out, Cydia has been the crazy thing it always is when a JB is released.

    So I've waited a day or so and proceed to buy a package from MMi's repo. Tempus, to be precise.

    Although I was able to purchase it, everytime that I try to download it I get a "HTTP/1.1 403 Forbidden" response.

    Now, I am a System Analyst and understand that it could have something to do with the crazyness that took place earlier, so the repo could be down, on maintenance or just overflown with people.

    Except by a few things: It has been like this since 8 hours ago and I only get this problem when I try to download a package that I've paid for... If I try to get any free package from MMi, it works as a charm and everything goes well.

    Thanks in advance!

    Luxiel

    HTTP 403 Forbidden on Paid Packages-img_0956.pngHTTP 403 Forbidden on Paid Packages-img_0957.pngHTTP 403 Forbidden on Paid Packages-img_0958.png

  2. #2
    Green Apple alex-xx's Avatar
    Join Date
    Apr 2011
    Location
    EU
    Posts
    92
    Thanks
    6
    Thanked 4 Times in 4 Posts

    The same here.
    Do not worry, Is just too busy now!!

  3. #3
    What's Jailbreak?
    Join Date
    Feb 2013
    Location
    São Paulo, Brazil, Brazil
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by alex-xx View Post
    The same here.
    Do not worry, Is just too busy now!!
    Thanks! It's not like 2 dollars would be quite money nor anything, but I don't want to fall back to piracy if I can't get a package I've actually paid for.

    Let's hope it gets better then... Or someone pops up with a solution

  4. #4
    What's Jailbreak?
    Join Date
    Jun 2012
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts

    im also getting this issue with the payed app Iconoclasm, hope it settles down soon.

  5. #5
    What's Jailbreak?
    Join Date
    Jan 2011
    Posts
    13
    Thanks
    0
    Thanked 9 Times in 6 Posts

    I'm also a little disconcerted that free packages work fine and paid packages don't. There has been no word from anyone at MMi, I know theres been a lot of stress on the repos since evasi0n, but it seems like everything is settling down.

  6. #6
    Green Apple LWalsh's Avatar
    Join Date
    Jun 2012
    Location
    New York, United States
    Posts
    34
    Thanks
    14
    Thanked 19 Times in 7 Posts

    I have also been getting this error all day, both with the new theme I purchased this morning and a previous theme I had on my 4s.

  7. #7
    What's Jailbreak?
    Join Date
    Feb 2013
    Location
    São Paulo, Brazil, Brazil
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by demitrix View Post
    I'm also a little disconcerted that free packages work fine and paid packages don't. There has been no word from anyone at MMi, I know theres been a lot of stress on the repos since evasi0n, but it seems like everything is settling down.
    Now, that's precisely why I am concerned about this. As much as I know about repos and how they work, if there was a problem with the repo itselft, the free packages wouldn't work.

    Since only the paid packages are getting this error (at least for us), it would seem that the problem could reside on the API that check with Saurik's System if the user has actually paid for the package.

    I am then assuming that the green check on the package page is valided by Saurik itselft and not by MMi's repo.

    And Saurik's System for validating paid packages is working since my paid packages from TheBigBoss were installed flawlessly.

    So, IMHO, I am guessing the problem is on the piece of software that bridges MMi's Repo and Saurik's System to check either a package was really paid for. For some strange reason, it isn't allowing anyone or it is just down and the repo assumes you haven't paid for it, in case someone try to take advantage of it being down.

    Just guesses, of course. I'm still waiting for some official MMi word on this.

  8. #8
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,331
    Thanks
    6,707
    Thanked 15,006 Times in 6,921 Posts

    This is a known issue. It has to do with the authorization that is needed between the MMi repo and Saurik's repo. Kyle (one of the owner's of MMI) is aware of it. Hopefully everything will be working soon once things die down a bit.

  9. The Following User Says Thank You to Simon For This Useful Post:

    lanceb1891 (02-05-2013)

  10. #9
    What's Jailbreak?
    Join Date
    Feb 2013
    Location
    São Paulo, Brazil, Brazil
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Thanks!
    Thank you very much, Simon!

    I think this answers our questions. I already sent an email to Kyle this morning (GMT -3), but it is good to know everyone is aware.

    This topic may be closed if you want to, to avoid unecessary spam.

  11. #10
    Green Apple alex-xx's Avatar
    Join Date
    Apr 2011
    Location
    EU
    Posts
    92
    Thanks
    6
    Thanked 4 Times in 4 Posts

    Im ok now.
    🙏👏👉😊

  12. #11
    iPhone? More like MyPhone
    Join Date
    Dec 2012
    Location
    San Diego, California, United States
    Posts
    158
    Thanks
    12
    Thanked 15 Times in 11 Posts

    Quote Originally Posted by Luxiel View Post
    Hello dear MMi fellows.

    I didn't know where to post this so, please, if I did it in the wrong place, relocate or delete this post.

    I've searched the forum and haven't found anyone having exactly the same problem I have been facing.

    Since evasi0n went out, Cydia has been the crazy thing it always is when a JB is released.

    So I've waited a day or so and proceed to buy a package from MMi's repo. Tempus, to be precise.

    Although I was able to purchase it, everytime that I try to download it I get a "HTTP/1.1 403 Forbidden" response.

    Now, I am a System Analyst and understand that it could have something to do with the crazyness that took place earlier, so the repo could be down, on maintenance or just overflown with people.

    Except by a few things: It has been like this since 8 hours ago and I only get this problem when I try to download a package that I've paid for... If I try to get any free package from MMi, it works as a charm and everything goes well.

    Thanks in advance!

    Luxiel

    Attachment 620481Attachment 620482Attachment 620483

    You get that today? Don't fret, everybody is in the same boat. Saurik is working on it as fast as he can. The error I got was different, it told me that the package was simply not there.

    In the case of your error, the package is there. but it is being hammered by downloaders, hence the error you got. Just keep trying, and eventually you'll get in the slot. I had to try about 20 times for certain packages yesterday. Decided to wait it out.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts