Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: [HELP] Need to restore iPhone 3GS. Please?

  1. #1
    Default [HELP] Need to restore iPhone 3GS. Please?
    Hello, people!

    Alright, long story short... I got this iPhone 3GS, iOS 5.1.1 (16GB) with new bootrom, and iPad baseband 6.15.00 but that works for me because I have the right version of 3GS for it ("36MY1E")
    I managed to restore my iPhone after some issue for about 3-4 months ago, since then I've been using it without no problems at all until 2days ago when I downloaded some game/app that restarted the phone and kept me at apple logo.

    I have a IPSW for 3GS 5.1.1 that I downloaded from iClarified - iPhone - Where To Download iPhone Firmware Files From and created a NO_BB IPSW from that file using redsn0w, I also changed my hosts file so GCS Default Web Server would redirect me to Cydia.

    Then I put my phone into PWNED DFU-mode with iReb 5, and go on iTunes and shift-click "Restore" and use my NO_BB IPSW that I created (which should work just fine! and it did last time...) but now I get stuck on Extracting software... > Verifying with apple... And then, a popup comes saying "The iPhone "iPhone" could not be restored. An unknown error occured (3194)."

    Trying for a few days to solve this problem alone, googling the error and read through iTunes Errors - The iPhone Wiki and also following this guide http://www.iphonestuffs4u.com/iphone-error-3194/
    where it says I should add the line "#74.208.10.249 gs.apple.com" in the hosts file which I also have done, but I still seem to get this error.

    I've tried alot of things and also gotten the error 1602, but I can't seem to get past these errors and fully restore my iPhone. I know it's possible since I managed to do it few months ago, but I seem to have forgotten how I did it.

    So now I'm desperate and really need someone to help me with this problem and find a solution for it.
    I'd be really thankful for any kind of help and response with this.

    Thank you,
    Eratoc

  2. #2
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    31,179
    Thanks
    3,916
    Thanked 10,180 Times in 6,199 Posts

    Since Apple is not signing 5.1.1 anymore, you have to stitch your SHSH blobs to the firmware.

  3. The Following User Says Thank You to blkcadi For This Useful Post:

    eratoc (09-22-2012)

  4. #3
    You think that might be the issue then?

    Do you think you maybe could explain to me how I can do this?
    Thanks for your reply,
    Eratoc

  5. #4
    Super Duper Moderator blkcadi's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    31,179
    Thanks
    3,916
    Thanked 10,180 Times in 6,199 Posts

    Yes, I believe that is your problem.
    This should help you.
    http://modmyi.com/forums/how-jailbre...ware-file.html

  6. The Following User Says Thank You to blkcadi For This Useful Post:

    eratoc (09-22-2012)

  7. #5
    Thanks again, this was such a great guide! I have created the new IPSW.

    Just a simple question before I start, do I actually NEED GCS Default Web Server to redirect me to Cydia or can it redirect me to the Apple "GCS Default Web Server" aswell?

  8. #6
    This could work! Not 100% sure yet, but we'll see.
    on iTunes it says "Preparing iPhone for restore..." and the apple logo is on my phone, I also have a bar under it but it doesn't move at all which I think it should have done by now. I'm not sure what's wrong?

    Edit: phone just restarted itself, now I got to this screen: http://thisisinfo.com/wp-content/upl...d-recovery.jpg

    Edit 2: And now it's black again... Still says "Preparing iPhone for restore" on iTunes. Been stuck like this for about 5minutes.

    And guess what, iPhone error 1603.

    I have a question though - since I have iPad Baseband (16.15.00), will my IPSW with SHSH blobs work? Because it's not an NO_BB IPSW now is it...

  9. #7
    iPhone? More like MyPhone Jabbacks's Avatar
    Join Date
    Apr 2011
    Location
    Tutu Island
    Posts
    200
    Thanks
    27
    Thanked 2 Times in 2 Posts

    You saved your shshs blobs? Try and see if you can downgrade baseband using redsn0w_win_0.9.14b2

    Check this link....
    Last edited by Jabbacks; 09-24-2012 at 04:10 PM.

  10. #8
    Quote Originally Posted by blkcadi View Post
    Yes, I believe that is your problem.
    This should help you.
    http://modmyi.com/forums/how-jailbre...ware-file.html
    This didnt work. Gives me error -1 (WTF is this), and im stuck on recovery mode after the error.

  11. #9
    zeneleven - Using redsn0w try to kick the phone out of recovery loop(extra --> recovery fix which is right under pwned DFU). That should fix the issue.

  12. #10
    Hello guys. I know how to stich SHSH blobs to an IPSW. But how do I "save" SHSH blobs? This is the same thing I assume, but I'm going to ask stupid questions so I don't spend many hours doing the wrong thing again because that's more of a stupid mistake then anything else.

    I got this guide from someone who wants to help me aswell, maybe this can be helpful to other readers on this thread who have the same problem as me. I am going to try sort this out with this:

    Now I had this problem this is what I did to fix it.


    If you have blobs avaliable for 5.1.1 download the latest redsn0w its (0.9.14b2).

    Plug your iPhone in and press "Extras Screen (in redsn0w)"

    Then select the 5.1.1 .ipsw that you downloaded (the 5.1.1 one) then press ok.

    Now go back to the 'main' screen and press jailbreak.

    Then DEselect everything except Downgrade from iPad baseband (you will update back to it after), go through the steps onscreen till you get to the scrolling text on your iPhone now wait for about 15 minutes. MAKE SURE THAT YOU WATCH IT AS IT GOES THROUGH THE 'FLASHING BASEBAND' STAGE (on iPhone')

    Now back in resdsn0w go back to the 'main' screen and press Extras, then press even more, then press DFU .ipsw (it says for users with broken buttons but this is the ONLY way that I got it to work) select the 5.1.1.ipsw and then let it complete that.

    Now open iTunes and restore (from whatever state ((DFU , Recovery Mode) you are in, you have to do this even if you are in DFU mode already) to the dfu.ipsw that you made.

    Now iTunes should say that you are in recovery mode, (once again) now just press restore and let your iPhone upgrade to iOS 6. (If you don't have a valid SIM, you will then need to download redsn0w_win_0.9.13dev3 and the iOS 6 beta 3 (I can provide if necessary PM me) so that you can hacktivate your phone)

    Now you should be on the springboard on your iDevice.

    Now back in redsn0w go back to the 'main' screen then press Extras. Then press SHSH Blobs, then press stitch now select, ISPW and then navigate to the 5.1.1 .ipsw.

    Then press Local and find the SHSH blobs for 5.1.1 that you saved, you may have to change the viewable file types down at the bottom.

    Now press next (or the process may start automatically)

    Now you will get a notification saying where the signed .ipsw is located.

    Now go back to the 'main' screen then press extras then press PWNED DFU, now follow the onscreen instructions.

    Now open iTunes and restore to the .ipsw that redsn0w created before (it gave you the file path)

    Wait

    Wait

    Wait

    Now you should be on iOS 5.1.1 but you can't use the custom iPad baseband. So open redsn0w then press Install iPad baseband.

    Now go through the onscreen instructions in redsn0w.

    Now once your iPhone has rebooted, open Cydia and install UltraSn0w '(unless you want the location services fix).


    OPTIONAL (LOCATION SERVICES FIX)

    Now that you have the iPad baseband installed you will not have location services.

    To fix that you will need to open redsn0w and then press 'extras' then press select .ipsw and then select the 5.1.1 .ipsw

    Now go back to the 'main' screen and press jailbreak.

    Then deselect everything except Downgrade from iPad baseband.

    Now follow the onscreen instructions

    Now once you are back to the homescreen, you will need to open Cydia and install Ultrasn0w.

    UPDATE:

    I almost instantly got into a problem. I started off with a fresh start and downloaded a 5.1.1 IPSW for 3GS, I used this guide: http://modmyi.com/forums/how-jailbre...ware-file.html to stitch the blobs to it. (this is how it should be done, right?) and then when I went on redsn0w 14b2, and try to select the IPSW I just made in the extras menu, it says this:

    "That IPSW is not supported by this version of redsn0w."

    If I try with the original 5.1.1 I downloaded, it works and says "The following build was identified..."

    But I need it with blobs I guess? What am I doing wrong?

    Please help me. Thanks
    Last edited by eratoc; 10-04-2012 at 01:52 PM.

  13. #11
    I'm on my phone, but it says "No service" for some reason. I had this issue a long time ago aswell and I think I downloaded something to fix it. Or if it was fixed along with iPad BB, because I have that installed on the phone so I'm not sure why it says no service. Anyone?

  14. #12
    Quote Originally Posted by eratoc View Post
    I'm on my phone, but it says "No service" for some reason. I had this issue a long time ago aswell and I think I downloaded something to fix it. Or if it was fixed along with iPad BB, because I have that installed on the phone so I'm not sure why it says no service. Anyone?
    you installed ultrasn0w right?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •