+ Reply
Results 1 to 18 of 18

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Charging Not Supported With This Accessory.

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Why does this message keep popping up when I plug in my iPhone? It pops up and then stops charging. Will a new battery fix this issue? Thanks.
...
  1. #1
    Green Apple
    Join Date
    Jun 2012
    Posts
    94
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Charging Not Supported With This Accessory.
    Why does this message keep popping up when I plug in my iPhone? It pops up and then stops charging. Will a new battery fix this issue? Thanks.

  2. #2
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,825
    Thanks
    63
    Thanked 264 Times in 253 Posts

    It's because it's not supported by the iPhone. It's basically not compatible is what it's saying. A new battery won't solve this, if anything, you'd have to get a new charging cable.

    Try getting a Griffen cable, they're very well made and they're compatible.
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

  3. #3
    Green Apple
    Join Date
    Jun 2012
    Posts
    94
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by H4CK3R View Post
    It's because it's not supported by the iPhone. It's basically not compatible is what it's saying. A new battery won't solve this, if anything, you'd have to get a new charging cable.

    Try getting a Griffen cable, they're very well made and they're compatible.
    But what I don't understand is, the USB lead I use is a official Apple cable.

  4. #4
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,825
    Thanks
    63
    Thanked 264 Times in 253 Posts

    Well then that's really weird, it should always work, especially with an Apple cable. I would try a new one, that one could be broken or something of that matter.
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

  5. #5
    Green Apple
    Join Date
    Jun 2012
    Posts
    94
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by H4CK3R View Post
    Well then that's really weird, it should always work, especially with an Apple cable. I would try a new one, that one could be broken or something of that matter.
    I tried another one and a another charger plug thingy and the same thing popped up.

  6. #6
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,825
    Thanks
    63
    Thanked 264 Times in 253 Posts

    -_- I'm guessing it's your dock connector then. Replacing it should completely solve the issue... But before you go blow a bunch of money, I'd reccomend you try cleaning it with compressed air first and see if you can get it to work.
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

  7. #7
    iPhoneaholic boozie's Avatar
    Join Date
    Jul 2008
    Location
    Wood River, IL
    Posts
    411
    Thanks
    13
    Thanked 49 Times in 35 Posts

    Prolly dirty dock connector like H4CK3R said. I've "fixed" several including my own by cleaning it using a small brush that came with an electric razor...

  8. #8
    Green Apple
    Join Date
    Jul 2012
    Location
    Olympia, WA. USA
    Posts
    84
    Thanks
    2
    Thanked 6 Times in 5 Posts

    I've had the same problem in the past with an IPT4G. Clean with a soft brush or compressed air and you should be good to go. Also need to add that there is a nifty little dock plug set called Proctetorzhttp://www.radtech.us/Products/Portectorz.aspx made by a company called RadTech, $6 and you get rubber plugs for the dock and earphone jack, earphone jack plug even has a sim card tool molded right in. Highly recommended.
    Last edited by HeliPilot; 08-03-2012 at 10:02 PM.

  9. #9
    Green Apple
    Join Date
    Jul 2012
    Location
    Olympia, WA. USA
    Posts
    84
    Thanks
    2
    Thanked 6 Times in 5 Posts

    Had the same issue with a IPT4G. Soft brush and air worked great. I now use Proctectorz dock plugs from Radtech, $6 and you have rubber plugs for the dock and earphone jack. Highly recommended.

  10. #10
    Green Apple
    Join Date
    Jun 2012
    Posts
    94
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Is there a way to clean it just as good with household items?

  11. #11
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,825
    Thanks
    63
    Thanked 264 Times in 253 Posts

    Quote Originally Posted by bladesboy2 View Post
    Is there a way to clean it just as good with household items?
    Canned air
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

  12. #12
    Green Apple
    Join Date
    Jun 2012
    Posts
    94
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by H4CK3R View Post
    Canned air
    I need to get some then. ;P

  13. #13
    Livin the iPhone Life xboxbml's Avatar
    Join Date
    Apr 2011
    Location
    US-MI
    Posts
    1,271
    Thanks
    0
    Thanked 64 Times in 61 Posts

    Does this occur on wall plug or on USB?...

  14. #14
    Green Apple
    Join Date
    Jul 2007
    Posts
    33
    Thanks
    0
    Thanked 1 Time in 1 Post
    Also make sure the base of the charger is an iPhone base. I've had issues in the past using the iPhone base on my iPad and vice versa. The iPhone base is the smaller of the two

  15. #15
    Green Apple
    Join Date
    Jun 2012
    Posts
    94
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I fixed it fines thanks

  16. #16
    Livin the iPhone Life xboxbml's Avatar
    Join Date
    Apr 2011
    Location
    US-MI
    Posts
    1,271
    Thanks
    0
    Thanked 64 Times in 61 Posts

    Well...what was the fix?...I'm curious...

  17. #17
    Green Apple
    Join Date
    Jan 2011
    Posts
    43
    Thanks
    0
    Thanked 0 Times in 0 Posts

    yea, i guess it's the problem with dock connector

  18. #18
    Green Apple
    Join Date
    Jun 2012
    Posts
    94
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by xboxbml View Post
    Well...what was the fix?...I'm curious...
    Dock connector

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts