+ Reply
Page 1 of 3 123 LastLast
Results 1 to 20 of 43

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Is anyone else having a problem with camera crashing?

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Hey I was wondering if it was just me or is anyone else having a problem with any app that takes picture (Camera/Instagram/PS Express/Etc) keeps crashing?
...
  1. #1
    Green Apple
    Join Date
    Feb 2009
    Location
    Ga
    Posts
    98
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Is anyone else having a problem with camera crashing?
    Hey I was wondering if it was just me or is anyone else having a problem with any app that takes picture (Camera/Instagram/PS Express/Etc) keeps crashing?

  2. #2
    What's Jailbreak?
    Join Date
    Mar 2011
    Posts
    15
    Thanks
    0
    Thanked 1 Time in 1 Post
    Probably low on memory

    Have you tried deleting your background apps?

  3. #3
    EVO
    EVO is online now
    Super EVO Moderator EVO's Avatar
    Join Date
    Dec 2009
    Posts
    3,483
    Thanks
    105
    Thanked 798 Times in 485 Posts

    Quote Originally Posted by Mike/D View Post
    Probably low on memory

    Have you tried deleting your background apps?
    i agree, double tap your home button and close any running apps hiding behind the background

  4. #4
    Green Apple
    Join Date
    Feb 2009
    Location
    Ga
    Posts
    98
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I tried it I closed all the background apps I even try respiring it but it just keeps crashing randomly when I try to take a picture

  5. #5
    Livin the iPhone Life celeron's Avatar
    Join Date
    Dec 2010
    Location
    Puerto Rico
    Posts
    5,831
    Thanks
    51
    Thanked 340 Times in 323 Posts

    Have you installed any tweaks recently?
    If my post was good, click the button in my post

    New to jailbreaking? Have a look at my Redsn0w Guide

  6. #6
    Green Apple
    Join Date
    Feb 2009
    Location
    Ga
    Posts
    98
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Well it been happening since I updated to 5.1.1. all my tweaks are my normal tweaks bitesms winterbroad theme sbsettings nothing different from then I was on 5.0.1.

  7. #7
    EVO
    EVO is online now
    Super EVO Moderator EVO's Avatar
    Join Date
    Dec 2009
    Posts
    3,483
    Thanks
    105
    Thanked 798 Times in 485 Posts

    what iphone do you have?

  8. #8
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,903
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Sounds like a bug with the JB. It can occur occasionally. If you can't find the culprit in Cydia, you'll probably want to restore and reJB. If you used Absinthe, I would suggest trying Redsn0w instead. If you did not use Absinthe, well then I'd probably just redo the jb with Redsn0w anyhow.

  9. #9
    Green Apple
    Join Date
    Feb 2009
    Location
    Ga
    Posts
    98
    Thanks
    1
    Thanked 0 Times in 0 Posts

    I got a 4s and I did use redsn0w the thing that sucks it don't always happen so whenever I try to fix it I just gotta wait it out to see if it worked or not

  10. #10
    Livin the iPhone Life celeron's Avatar
    Join Date
    Dec 2010
    Location
    Puerto Rico
    Posts
    5,831
    Thanks
    51
    Thanked 340 Times in 323 Posts

    I'd do as Annie said if I were you. A restore will surely get that fixed so you don't have to worry about that anymore
    If my post was good, click the button in my post

    New to jailbreaking? Have a look at my Redsn0w Guide

  11. #11
    Green Apple
    Join Date
    Feb 2009
    Location
    Ga
    Posts
    98
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Well thanks for the tips I guess I was the only one getting it I will try it thanks again

  12. #12
    Livin the iPhone Life celeron's Avatar
    Join Date
    Dec 2010
    Location
    Puerto Rico
    Posts
    5,831
    Thanks
    51
    Thanked 340 Times in 323 Posts

    No prob
    If my post was good, click the button in my post

    New to jailbreaking? Have a look at my Redsn0w Guide

  13. #13
    My iPhone is a Part of Me n0m0n's Avatar
    Join Date
    Nov 2007
    Location
    Here
    Posts
    835
    Thanks
    58
    Thanked 39 Times in 38 Posts

    Have you found the culprit as to why you were crashing?
    This same thing is happening to me and its not every time I try to use the camera app or for that matter Camera+ as well, but it happens more times then not.

    Thanks
    --
    JW

    It is the mark of an educated mind to be able to entertain a thought without accepting it. -- Aristotle

    Support P.E.T.A. [PEOPLE EATING TASTY ANIMALS]

  14. #14
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    903
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, yes I too have seen Camera crashing on low memory, but have also had problems with camera related tweaks CameraLocker, PhotoMe and SnapTap.

  15. #15
    My iPhone is a Part of Me n0m0n's Avatar
    Join Date
    Nov 2007
    Location
    Here
    Posts
    835
    Thanks
    58
    Thanked 39 Times in 38 Posts

    Quote Originally Posted by DC_Dave View Post
    Hi, yes I too have seen Camera crashing on low memory, but have also had problems with camera related tweaks CameraLocker, PhotoMe and SnapTap.
    I double pressed the home button and closed all the open apps (3) but it did not change and as for the listed tweaks I dont have them on my device.
    I have CaughtU, Camstamp, but thats all the related camera tweaks I have on my device.
    I went into SBSettings and Mobile Substrate Addons and switched them off but it did not help with my camera app, camera+ to take a picture.
    Sometimes the camera opens and takes the picture then crashes back to the springboard and no picture.
    I think that it is related to when I zoom in the camera, if that helps

    Thanks
    --
    JW

    It is the mark of an educated mind to be able to entertain a thought without accepting it. -- Aristotle

    Support P.E.T.A. [PEOPLE EATING TASTY ANIMALS]

  16. #16
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    903
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, this post has details of ram issues and IconSupport
    IconSupport causing crash - help

  17. #17
    My iPhone is a Part of Me n0m0n's Avatar
    Join Date
    Nov 2007
    Location
    Here
    Posts
    835
    Thanks
    58
    Thanked 39 Times in 38 Posts

    Quote Originally Posted by DC_Dave View Post
    Hi, this post has details of ram issues and IconSupport
    IconSupport causing crash - help
    Is that something automatically on the device because in Cydia I don't have a tweak called IconSupport.

    Thanks
    --
    JW

    It is the mark of an educated mind to be able to entertain a thought without accepting it. -- Aristotle

    Support P.E.T.A. [PEOPLE EATING TASTY ANIMALS]

  18. #18
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    903
    Thanks
    5
    Thanked 69 Times in 66 Posts

    Hi, IconSupport is installed with infinifolders and other such tweaks, so you may not have it, to see all your cydia installs, press the simple/expert button in packages. I think you will have to disable various tweaks a few at a time to see if your problem goes away.

  19. #19
    My iPhone is a Part of Me n0m0n's Avatar
    Join Date
    Nov 2007
    Location
    Here
    Posts
    835
    Thanks
    58
    Thanked 39 Times in 38 Posts

    Quote Originally Posted by DC_Dave View Post
    Hi, IconSupport is installed with infinifolders and other such tweaks, so you may not have it, to see all your cydia installs, press the simple/expert button in packages. I think you will have to disable various tweaks a few at a time to see if your problem goes away.
    OK yes it was there so I downgraded to 1.7.7-1, I'm not really seeing much of a difference, but in Cydia I'm being notified that there is a update to it.

    I would like to understand better what the ram breakdown means though.
    I have Omni Stat Widget and it offers a breakdown of the memory:
    Wired
    Active
    Inactive
    Free.

    I have noticed that the Inactive, and Free when added together equal the available ram.?.
    Am I correct and what does the wired mean?

    Thanks
    --
    JW

    It is the mark of an educated mind to be able to entertain a thought without accepting it. -- Aristotle

    Support P.E.T.A. [PEOPLE EATING TASTY ANIMALS]

  20. #20
    My iPhone is a Part of Me
    Join Date
    Oct 2010
    Location
    UK
    Posts
    903
    Thanks
    5
    Thanked 69 Times in 66 Posts

    From what I read in the link on post #16, there was a problem with his ram getting used up, which resulted in crashing of apps. This was fixed by downgraded to v1.7.4-1 of IconSupport. In my case it was mostly Safari crashing when touching the screen to copy/paste in the URL or google search windows.

    You could try uninstalling ICaughtU and CamStamp, rather than just disabling them. Maybe list your tweaks here too. Does your Camera app crash if you are in safe mode?
    Last edited by DC_Dave; 08-17-2012 at 07:33 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts