I'm having an awkward issue with Cydia, but every time I try to download something from the app it kicks me to a "Cannot Comply" screen. I've tried looking through google and posts on the website but they are all for outdated iOS versions. I'm running iPhone 4S on 5.0.1.