Relocating broken sleep/wake button with software

I am currently in the process of jailbreaking and unlocking an Iphone 3g 8 Gb phone I bought from a

farmers market a few weeks ago for $20.I had some free time and some extra cash so I thought about fixing it.

This would be first venture working on any kind of iphone. I have some knowlege on the ipod touch so I went at

it. For the past three days I have been working on this phone. The phone has a lot going against it.

Problems:

- Broken Sleep button
- No way of turning it OFF
- Disabled / Emergency Mode
- Locked
- No Passcode screen
- Doesnt respond to windows 7
- Itunes doesnt recognize it
- First ever attempt in repairing an iphone
- 100% Charged battery

I have been modding electronics since 1994 so my instinct is to uninstall and then reinstall any

software that could be a potential issue on the computer I'd would be working on. I started by uninstalling

all Apple software and processes on the computer. I went into windows device manager and uninstalled any

drivers that corresponded to what I'd be using (portable devices,internet adapters). Deleted any, even hidden,

folders about Apple software. Then I rebooted the computer. After restart I plugged the Ipod usb cable in and

then installed Itunes 10.1.6.7. Watched as drivers reinstalled themselves. Reboot.

Restarted and plugged in iPhone, brings up usb device in windows 7. I'm able to view DCIM folder but

it's empty and write protected. iTunes still does not recognize the phone. uninstall itunes. Look for older

version, forgot which version but it didnt matter. The older version of iTunes was for updating only.Install

and Reboot.

Fire up itunes and the phone is now seen as an iphone. I get an error that it is passcode protected

and I would need to do it on the phone to get access update iTunes.Same error. Windows 7 doesnt respond to the

phone anymore but updated itunes does. So I was at a dead end. Running a loop. Both should see whats

connected. Turned on Media monkey and it instantly dies. odd

More Problems:

- No way to enter DFU mode
- windows sometimes will respond
- itunes wants me to enter a passcode

So I broke out my screwdriver and started opening the phone to turn it off manually. I dissassembled

and the phone was now off. During the installation the phone turns on. The screen on and its at the disabled

screen. Not enough time to get back together and get into recovery. Next option was to let the battery die. 22

hours passed before it I was able to drain the battery. I worked a little on windows 7 drivers and did some

major reading on how to get this repaired. Trolled many forums from 2007 on up. I also downloaded a lot of

software that might help in my repair. I tried each program and followed directions on how to use each of the

following:

Software:
- tiny umbrella 5.10.14
- iReb-r5
- Disk Aid 5.14
- DFU.zip
- blackra1n(PC)
- sn0wbreeze-v2.9.3
- redsn0w_win_0.9.6rc16
- RecBoot
- limera1n-win
- ifunbox_en

Firmware
- iPhone1,2_3.0_7A341_Restore.ispw
- iPhone1,2_3.1_7C144_Restore.ipsw
- iPhone1,2_3.1.3_7E18_Restore.ipsw
- iPhone1,2_4.0.1_8A306_Restore.ipsw

With the battery dead I connected the iphone holding down the home button to boot into recovery.Opened

iTunes and finally was able to install the first firmware. I got some errors after installing the firmware but

I used recBoot to fix them.I also fixed my hosts file. I was also able to save the blobs with tiny umbrella.



So with the firmware flashed at 3.0 I wanted to jailbreak and unlock. But first I wanted to upgrade to

3.1.3 before the jailbreak because many seemed pleased with it. I did the same thing for each firmware

installation. With no way of turning the device off I went and reset the network settings for a restart.

3.1.3 is up and running but itunes want an activation?? I insert an at&t sim card into the phone and

restart itunes and lets me enter the phones new info. I went to jailbreakme.com jailbroke the phone.It works

and Cydia is installed. Programs like ifunbox actually work on the computer end. Time for customization.

Install spree:
- Winterboard
- **********
_ Quicklock
- SbSettings
- Activator
- BossPrefs
- AptBackup
- FuzzyBand
- Facebook

Cydia Sources:
- BigBoss
- Cydia.Telesphoreo
- Dev Team
- Hackulo.us
- ModMyi.com
- ZodTTD & MacCiti

Everything is going smooth but now I want to unlock it. I installed ultrasn0w and I have 3 unactivated sim

cards to play with. I have a verizon 4g lte, and at&t and a card that says "sim card". If I put the verizon

card in I get a setting called carriers in my settings and it shows up as carrier 5.5. The at&t there is no

carrier setting but it shows up as att 5.6 and the sim card version says 5.5. Each show 1bar and then go into

searching.

Specs for the unlock don't look good though from running fuzzyband 4.1

Bootloader 6.02 [G2M3S2]
Model Firmware ICE2-05.15.04
Version 3.1.3 (7E18)

Problems as of now:

- not sure if its unlocked
- cannot upgrade firmware to 4.0.1 for jailbreakme.com
- broken wake button
- cannot downgrade or upgrade bootloader or baseband
- NO DFU

If anyone took the time to read this please help me figure this out.