I have to confirm that whoever is relying unlock with R-SIM 2 on 5.0.1 now can UPDATE to 5.1 but I have to warn that no JB is available for 5.1 now. My iphone 4S with 5.1 bb2.0.10 works, I thought I had to buy Ultra S 3rd version but now I don't have to!