+ Reply
Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Restore Error "Device Isn't Eligible for the Requested Build" iOS 5.0.1

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Hi, I own a iPhone 4 (16GB) from AT&T, I'm having issues with the phone's functionality, it's not working correctly or as smooth as it used to be before. I'm
...
  1. #1
    Green Apple
    Join Date
    Mar 2008
    Location
    Puerto Rico
    Posts
    42
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Default Restore Error "Device Isn't Eligible for the Requested Build" iOS 5.0.1
    Hi,

    I own a iPhone 4 (16GB) from AT&T, I'm having issues with the phone's functionality, it's not working correctly or as smooth as it used to be before. I'm trying to restore my device but iTunes keeps displaying the error message "The iPhone could not be restored. This device isn't eligible for the requested build."

    I've read several posts and possible solutions to this issue by conducting Google searches, reading in the forums but I know there's something I'm not seeing that needs to be done or modified. I already have the Hosts file modified with the 74.208.10.249 gs.apple.com at the bottom of the file, I've added # in front of the code, left a space, erased a space, etc., (everybody says something different). I erased the iPhone 5.0.1 firmware file that I had saved on my Mac and redownloaded it thinking that maybe I downloaded the incorrect file but it didn't worked.

    I need suggestions, can someone help me??

  2. #2
    jl1
    jl1 is offline
    Green Apple jl1's Avatar
    Join Date
    Nov 2008
    Location
    Michigan
    Posts
    61
    Thanks
    8
    Thanked 10 Times in 7 Posts

    Apple isn't signing 5.0.1 anymore. If you were jail broken on 5.0.1 previously you can use iFaith to build a ipsw and restore in iTunes. If not I believe you are s.o.l!!

  3. #3
    iPhoneaholic
    Join Date
    May 2010
    Posts
    315
    Thanks
    9
    Thanked 4 Times in 3 Posts

    also check tinyumbrella for your shsh blobs. if they're there, you can pick and choose the ios you prefer. i don't know why apple doesn't let users do this in the first place!

  4. #4
    Livin the iPhone Life xboxbml's Avatar
    Join Date
    Apr 2011
    Location
    US-MI
    Posts
    1,271
    Thanks
    0
    Thanked 64 Times in 61 Posts

    1. Because they want to control your environment...I was gonna say their environment...but this is my device..
    2. Because they want to control your environment...oh...did I say that all ready?....

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts