Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 2G randomly lost WiFI?

  1. #1
    Default iPhone 2G randomly lost WiFI?
    I have an iPhone 2G running 3.1.3 JBed by redsn0w.

    The iPhone has no service, was using it as an iPod Touch basically.

    I was using the phone along with my Bluetooth GPS using BTStack GPS with WiFIFoFum and Motion-X GPS.

    All of the sudden the minute the GPS died on me with the iPhone still connected, the iPhone it self did not complain like normal that the GPS was disconnected.

    Instead it seems WiFI is totally disabled (greyed out in Settings) and I have tried going in to Settings -> BTStack and choosing "None" which did nothing.

    Before that I also tried resetting both networking and entire phone.

  2. #2
    Sounds like a hardware problem. Similar happened in my old 2g but probably not worth trying to fix.

  3. #3
    What's Jailbreak? J-Hackstar's Avatar
    Join Date
    Jan 2010
    Location
    Milton Keynes, England
    Posts
    13
    Thanks
    1
    Thanked 3 Times in 2 Posts

    Try restoring in iTunes. If that doesn't work, try using PwnageTool or sn0wbreeze to create a custom pwned IPSW and restore with that instead as it could be an issue that only a fresh dose of pwnage can help...

  4. #4
    Yea cause something strange is going on.

    As a last resort, I tried going to Settings - General - Bluetooth, turning WiFi on.

    On a reboot, it actually bought WiFI out of "No WiFi" mode but still wasn't detecting any networks.

    Seems it would not turn back on if WiFi card is dead.

    EDIT: WOW, I just rebooted it again, and because I have it show what it's booting vs just the Apple Logo, I saw the text explode and "failed firmware start after 3 failed attempts" or something similar.
    Last edited by redpenguin; 03-03-2012 at 12:47 PM.

  5. #5
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    46,787
    Thanks
    6,994
    Thanked 15,551 Times in 7,110 Posts

    Sounds hardware related to me too. Not an easy fix, better to just get a new phone.

  6. #6
    Default Yea
    It appears it probably is hardware related.

    A little while back while using WiFiFoFum I was having issues where the screen would randomly blink while trying to use the program but it eventually went away.

    Now in restore mode and DFU mode with two different USB cables and two different USB ports (one USB port on a card reader by itself) and it refuses to restore just telling me, "could not be restored. An unknown error occurred (1611)."

    The iPhone will just sit there in DFU mode like normal then when the bar showing it's receiving never fills and the phone reboots and tries again.

    Same thing in restore mode.

    Oh well, I got a fair amount of use out of it.

    I still have my iPhone 3G but who knows how long that will last now being it was made only a year later, LoL.

  7. #7
    I take some of that black.

    I was wrong with the screen blinking, that's my iPhone 3G doing that with WiFiFoFum sometimes.

    Anyway, I decided maybe try my laptop to restore the iPhone (figured what can I lose?) thinking maybe my iTunes is just bad or since I have so many USB devices plugged into my desktop.

    So I hooked the iPhone 2G to my Win 7 laptop and all the sudden it started to restore the iPhone 2G with no issues, no more constant 1611 errors.

    Now I just gotta wait and see what happens with the WiFi.

    EDIT: It appears that my iPhone 2G has turned into a more advanced iPod, meaning it has totally lost it's WiFI, but I will just use it for music or whatever.
    Last edited by redpenguin; 03-04-2012 at 02:55 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •