+ Reply
Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Brokern 3GS speaker replaced - still no sound

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Hey, the speaker on my 3GS broke the other night. Today I got my replacement dock module and put it in. Sadly that didn't help it, still no sound. The
...
  1. #1
    What's Jailbreak?
    Join Date
    May 2008
    Posts
    17
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default Brokern 3GS speaker replaced - still no sound
    Hey,

    the speaker on my 3GS broke the other night. Today I got my replacement dock module and put it in. Sadly that didn't help it, still no sound. The microphone and earpiece speaker work fine though, so do my headphones. And the iPhone isn't stuck in headphone-mode, i can clearly see it changing volumes when I unplug the headphones.

    What else could it be?


    Thanks,
    cube

  2. #2
    Livin the iPhone Life xboxbml's Avatar
    Join Date
    Apr 2011
    Location
    US-MI
    Posts
    1,273
    Thanks
    0
    Thanked 64 Times in 61 Posts

    Could be mute switch I think....anyone?....

  3. #3
    What's Jailbreak?
    Join Date
    May 2008
    Posts
    17
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Well my mute switch hasn't been working right for months, which is why I'm using the cydia addon "Silentmode Switcher" instead. It completely disables the hardware switch. You think it could still affect my speaker? If so, I could try detaching the stupid switch alltogether, right?


    Thanks

  4. #4
    Livin the iPhone Life xboxbml's Avatar
    Join Date
    Apr 2011
    Location
    US-MI
    Posts
    1,273
    Thanks
    0
    Thanked 64 Times in 61 Posts

    I would at least remove that Cydia tweak first...just to see if u can heat anything...was the switch working at all?...

  5. #5
    What's Jailbreak?
    Join Date
    May 2008
    Posts
    17
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by xboxbml View Post
    I would at least remove that Cydia tweak first...just to see if u can heat anything...was the switch working at all?...
    I did a full restore today because I wanted to rule out the jailbreak and anything related. Afraid that didnt help, so it must be a hardware problem. The mute switch works, it's just a bit flimsy and will switch modes at the slightest touch. But with the cydia addon it wasn't an issue anymore.

  6. #6
    Livin the iPhone Life xboxbml's Avatar
    Join Date
    Apr 2011
    Location
    US-MI
    Posts
    1,273
    Thanks
    0
    Thanked 64 Times in 61 Posts

    Hmm...yeah sounds like definite HW prob...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts