+ Reply
Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: REALLY NEED HELP WITH THIS ONE! SO FAR NOBODY HAS BEEN USEFUL ELSEWHERE! iPHONE 4

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Anyone ever had this problem? trying to restore phone to factory settings to re-jailbreak, put my phone into DFU mode, (black screen, definitely in! wont power on) connect to itunes,
...
  1. #1
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    22
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Angry REALLY NEED HELP WITH THIS ONE! SO FAR NOBODY HAS BEEN USEFUL ELSEWHERE! iPHONE 4
    Anyone ever had this problem? trying to restore phone to factory settings to re-jailbreak, put my phone into DFU mode, (black screen, definitely in! wont power on) connect to itunes, itunes recognises device in recovery mode, starts restore, gets to part where its about to install and says "Apple is preparing iphone for restore" - then my phone switches itself on to the apple logo, I get error code "21" EVERY time, on 2 different machines, and have the itunes logo on the screen of the phone now, I try the same thing every time and get the same result! ?????? STUCK!

  2. #2
    Banned
    Join Date
    May 2009
    Posts
    219
    Thanks
    0
    Thanked 38 Times in 24 Posts

    Try deleting everything after the 127.******* line in ur hosts file save it then try again with and without DFU

  3. #3
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    22
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Tried your method, on both occasions after a few beeps (phone connecting/disconnecting) and the itunes top bar saying "Verifying restore with apple" the phone seems to switch itself back on at a similar point early on in the restore back to the normal apple logo as if it were trying to boot up, then I'd get the error "21" code in itunes and the phones logo would go back to the itunes screen logo. I have tried to put it into a pwnd DFU mode, and the redsn0w recovery fix using the latest redsn0w but as above during the reboot process after the phone has been put into DFU mode it keeps switching itself back onto the apple logo and fails the DFU recovery process. If i reset and come out of DFU/recovery mode (holding both power and home for 10 secs) the phone just goes into an apple logo boot loop on - apple logo - off - on - apple logo - off continuously........

    The phone was originally tethered Jailbroken on 5.0.1 installed both the versions of Corona packages in cydia as they were released, which untethered the jailbreak. Always seemed to have some problems with packages and sources since the untether was released. My phone ran our of power last night and when I plugged it into the charger it just went into this apple logo boot loop? now Im stumped because it seems that even my DFU mode wont help me!

    "edit" - What I also forgot to mention is as I sit here with the USB cable plugged into my phone/pc and the itunes logo on the screen, I can pull the cable out of the PC and the power to the phone switches off ? as if its in DFU mode as it refuses to switch back on by pressing the power button. However - If i plug it back into the pc the itunes logo re-appears on the screen again? So once again I pull the cable out - the power dies, I can not switch it on at all by hand - but will power up with the charger or the pc via usb? Is there possibly a hardware issue here?
    Last edited by Greeny308; 12-30-2011 at 03:50 AM.

  4. #4
    What's Jailbreak?
    Join Date
    Aug 2010
    Posts
    22
    Thanks
    1
    Thanked 0 Times in 0 Posts

    PROBLEM SOLVED! my battery was dead when it went into recovery loop yesterday - and even though it was plugged into the wall with the itunes logo on the screen, it WOULD NOT charge as the software was in loop! Tried my mates battery this morning, and Voila! phone up and running fine. FRESH restore - so going to run redsn0w 0.9.10b3 (latest version) to re jailbreak - then I will re-sync all my stuff. Should be clean install and JB then.

  5. #5
    Green Apple
    Join Date
    Dec 2007
    Posts
    46
    Thanks
    6
    Thanked 2 Times in 2 Posts

    I had the same issue I needed to run tiny umbrella to change the settings so itunes was checking apple server instead of the TU's server. as soon as I did that everything was fine and I was able to update and jailbreak.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts