+ Reply
Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone will not charge unless it is turned off completely - HELP!!

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Hi All, I really have a strange problem. I have a jailbroken 3Gs on 4.3.3 and out of the blue yesterday I noticed that it was not charging. I tried
...
  1. #1
    iPhone? More like MyPhone
    Join Date
    Jun 2008
    Posts
    110
    Thanks
    17
    Thanked 1 Time in 1 Post
    Default iPhone will not charge unless it is turned off completely - HELP!!
    Hi All, I really have a strange problem. I have a jailbroken 3Gs on 4.3.3 and out of the blue yesterday I noticed that it was not charging. I tried different cables, different computers, and also wall socket (different locations) and still nothing. By chance I turned it off to perhaps try again and all of the sudden noticed that it actually charged while I had it turned off.

    iTunes will also not detect it no matter what I do. I tried another iphone on my iTunes and my iPod and both were detected with no problems.

    Anyone have any suggestions???? I am waiting for the iphone 5 which is supposed to be in a couple of months but in the meantime I have no idea how to function this way. Has anyone else had this issue? Any suggestions as to what I can try?

    Would really appreciate any help. Thanks.

  2. #2
    Green Apple
    Join Date
    Jan 2011
    Posts
    96
    Thanks
    4
    Thanked 2 Times in 2 Posts

    My cousin's phone had the same problem, where iTunes would not detect it, although it charged fine. I did multiple restores in DFU mode and eventually it was detected. Try it a few times and post the results.

  3. #3
    iPhone? More like MyPhone
    Join Date
    Jun 2008
    Posts
    110
    Thanks
    17
    Thanked 1 Time in 1 Post
    Hi AAred - I have tried to put the phone in DFU mode but nothing happens. If iTunes would at least recognize it I would try to restore but I can't do anything with it.

    Any other suggestions??? Thank you for responding.

  4. #4
    What's Jailbreak?
    Join Date
    Jun 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I think this may be caused by hardware,something wrong with the small moterboard charging of connection

  5. #5
    Mes
    Mes is offline
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,025
    Thanks
    102
    Thanked 788 Times in 731 Posts

    The dock connector could be dirty (or faulty). Power off, then gently and thoroughly clean the contacts using 90%+ alcohol and a Q-tip. Also, inspect the pins with a magnifying glass. Make sure any excess alcohol has evaporated prior to turning back on. If all else fails, replace the dock connector.

  6. #6
    iPhone? More like MyPhone
    Join Date
    Jun 2008
    Posts
    110
    Thanks
    17
    Thanked 1 Time in 1 Post
    acerow and Mes - thank you for your replies. It's definitely a strange problem. There is no doubt that something is damaged but no clue why it would charge when turned off but not when it is on. If it were the connectors it wouldn't charge when it was off also - right??

    I did clean it and the pins seem okay although hard to tell. I will keep trying. Any other ideas would be really appreciated - hard to believe that this never happened to anyone else.

    Thanks.

  7. #7
    Green Apple
    Join Date
    Jan 2011
    Posts
    96
    Thanks
    4
    Thanked 2 Times in 2 Posts

    Since it charges when turned off, it's probably not a problem with the hardware problem...
    Hmm, have you deleted any of the launchdaemons? There's one that deals with charging so if you modified or deleted it, that could prevent connecting to itunes and charging when turned on

  8. #8
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Instead of dfu have you tries recovery mode instead? iTunes 99% of the time will recognize an iDevice in recovery mode so you can restore.

  9. #9
    iPhone? More like MyPhone
    Join Date
    Jun 2008
    Posts
    110
    Thanks
    17
    Thanked 1 Time in 1 Post
    Thanks i.Annie - I tried that too and still iTunes did not recognize it.

  10. #10
    Super Penguin Mod i.Annie's Avatar
    Join Date
    Jun 2009
    Location
    SW Ohio
    Posts
    16,907
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    It had the iTunes+USB screen when you did recovery mode? If that doesn't work well it's hard to say what can be done, at least I can't tell.

  11. #11
    What's Jailbreak?
    Join Date
    Dec 2011
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Same Exact Problem. Help!
    Hi Kally & Everyone,
    I have the same exact problem you describe to a 'T'. Did you ever get any further with your problem than where this post ends so far? Did you come up with a solution or learn more about it at all? Any additional information would be greatly appreciated.

    My situation:
    iPhone 3GS 32GB 4.0.1
    Jailbroken (Jailbreakme.com), Unlocked; (both over a year ago)
    Windows 7
    Can only charge when powered off (both wall & computer chargers),
    Cleaned the iPhone's metal contacts
    Tried multiple cables
    Can't get iTunes or tiny umbrella to connect to phone despite DFU and recover attempts
    The computer does make the connect sound when I plug it into the computer (but doesn't show up in iTunes or in My Computer).
    (Also tried plugging into a MacBook and there was no recognition of the device there).
    Received "USB device not recognized" error showing "Unknown Device" (so can't uninstall or reinstall driver as some threads have suggested trying).
    Recovery attempt does show the "iTunes + USB" screen, but after continuing to hold Home button (after releasing the power button that was held simultaneously for 10 seconds to get it into recovery mode) for another few minutes and letting it go, the iPhone just sits at that "iTunes + USB" screen and never goes into further recovery progress.
    My phone is out of the warranty period, and the nearest Apple store 1.5 hours away, so making a Genius appointment to get a replacement, as some suggest, is not an option.

    Furthermore, it has been working fine and I did not install any new software or do anything different that I am aware of that would have caused this. I did restore the phone from back up one and two days prior to this problem, as I had syncing issues when I opened a Microsoft Exchange account in Outlook 2007 which I sync my iPhone with.

    So now I can't sync anything, backup my iPhone, update firmware, restore iPhone, update software through the computer, all of which really limits the phone's usefulness.
    Not to mention the impracticality of only being able to charge it when it is powered off.
    But it still does work as a phone and an organizer.

    It sure seems like a software problem, but I am stuck as to how to overcome it, so any input would be greatly appreciated. Thank you.
    Last edited by kwr8; 12-13-2011 at 08:33 AM.

  12. #12
    Green Apple
    Join Date
    Jan 2011
    Posts
    96
    Thanks
    4
    Thanked 2 Times in 2 Posts

    When you talked about the recovery thing, isn't the itunes+usb thing the recovery mode?

  13. #13
    What's Jailbreak?
    Join Date
    Dec 2011
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Recovery Clarification
    I can get to the "iTunes + USB" screen in my recovery attempt, but I can't get past this screen. My computer makes the "connection" sound, but then Windows gives an error "USB Device Not Recognized" and I never get the message from iTunes that states, "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes." So even in my recovery attempt, it appears that iTunes is not able to recognize the iPhone. The computer is recognizing the phone being connected (with the sounds and USB Device Not Recognized error), the iPhone knows it is being connected (eg it will wake up from powered off mode if I plug it into the wall charger or computer USB (even though it won't charge), and it will enter the "iTunes + USB" screen), but iTunes doesn't seem to be recognizing it.

    Another charging observation: I noticed yesterday that my phone won't even charge if it is powered off. It didn't charge until it reached the less than 3% battery critical stage and automatically powered off and went to the "low red battery with lighting bolt" screen signifying that it was charging. So my guess is that there is a problem with the charging regulation software (that is working even when phone is powered off?) and it is only when phone can bypass that software and somehow get a straight charge that it will charge.

    Maybe is there some way to restore the charging software, and perhaps the USB connection software on the phone itself (though Cydia or something) to restore charging and get iTunes to recognize my iPhone? Might somehow manually installing a Windows 7 driver help iTunes recognize my phone? I'm open to any suggestions and ideas. Thanks.

  14. #14
    What's Jailbreak?
    Join Date
    Dec 2011
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Replacing Docking Unit Hardware Didn't Solve Problem
    My problem still continues. I have now also replaced the docking unit hardware twice. The device is recognized the first time I plug in after replacing the docking unit, and then subsequent attempts, the old problem returns and persists- "USB device not recognized" and can't charge unless the phone is below 5% battery level AND powered off.

    In the several months I have had this problem, there have been two or three times when the charging synching has spontaneously worked for no apparent reason, but the chances are only about 1 in 50 for the times I've tried.

    Also, if I plug the iphone into the computer, the "USB device not recognized" error keeps coming up intermittantly minutes to hours apart, while continuously plugged in (as though something internally or in the computer resets/refreshes and it tries to connect anew).

    I would love it if anyone could offer any insight into this strange problem. Thanks.

  15. #15
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,833
    Thanks
    63
    Thanked 264 Times in 253 Posts

    I reccoend you all do a Hard Reboot. If that fails force restore. It will 99.99% recognize the device. If that fails since it's in a state of uselessness bring it to an Apple store to see what they can do. They won't be able to detect a jailbreak since it's in a useless state.
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

  16. #16
    What's Jailbreak?
    Join Date
    Dec 2011
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Update: iOS 4.3.3 Upgrade Improved,but Didn't Solve Prob + Unrecognized USB Work-Around
    I used sn0wbreeze to upgrade my iOS to 4.3.3 (incidentally I could not get past errors 1600 or 3194 with redsn0w and iOS 5.0.1 despite trying all the on-line solutions). Now my phone will only charge when powered off. This is so much better than before when I could only charge with iPhone powered off AND the battery was below 5%.

    The computer still prettty much never recognizes the iPhone. I have found that I can get the computer to recognize the iPhone ONLY if I unplug the internal docking/charge port cable (internal cable marked with orange #4 sticker), plug it into a different replacement docking/charge dock assembly part that I bought [which can be done without installing the replacement part by just removing the two screen screws and lifting up the screen (with an adequate suction cup), without removing any other parts or undoing any other cables], then plug it back into the original docking/charge port unit still in the phone, then unplugging the #4 cable again, then re-plugging it into the same installed unit again (and sometimes having to do repeated switches of units and unplugs and replugs, with attempts at plugging device into computer throughout steps).

    Still not sure if this is a hardware or software problem, but would suspect software based on the above (but suprised that upgrading to 4.3.3 didn't fix it; might 5.0.1 fix it?). Any further insight from anyone would be greatly appreciated.

    PS In response to the previous post, my 3GS iPhone otherwise functions fine except for the charging and the not being recognized. When you say "hard reset"- I assume you mean the "erase all content and settings" option in the iPhone "settings" program? I have not done that (as I am afraid I will loose all my settings and create a lot of manual restore work of jailbroken apps, and still not fix my problem- but I would do it if it would fix the problem; the word on the web seems to say that "erase all content and settings" on a jailbroken machine will likely brick the machine, so I am very hesitant to try). My machine is out of warranty and the nearest Apple Store is 1.5 hours away, and I use T-mobile, all of which sums up to great potential to jump from the frying pan into the fire.

  17. #17
    My iPhone is a Part of Me Frostbite's Avatar
    Join Date
    Jun 2009
    Location
    over the hill across the river and through the candy cane forest
    Posts
    693
    Thanks
    34
    Thanked 72 Times in 61 Posts

    @kwr8, I am late to the game so if I missed something I apologize, but when you put it in DFU, does it show up in system profiler under USB?
    If you wanna thank me hit "Thanks" in the lower left of my post. If you would like to follow me on twitter click here

  18. #18
    What's Jailbreak?
    Join Date
    Dec 2011
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    No, in DFU mode, it doesn't not show up in system profiler under USB except as "unrecognized USB device". It will only be recognized with the complex "work-around" that I described above, and not with DFU mode. Once I do the work-around it usually stays connected for a long time (though has on rare occasion dropped spontaneously).

    PPS I have thought about wiping the machine and letting iTunes restore to the latest iOS, then revert with Tiny Umbrella, but if I do so, it will also automatically permanently upgrade my baseband, and I will never be able to get that back (my baseband/Modem Firmaware is 05.13.04, which I would like to keep for unlocking purposes).

  19. #19
    What's Jailbreak?
    Join Date
    Feb 2011
    Posts
    4
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default Same problem
    Long story real short, buds phone was on 4.3.3 jb. His phone just randomly started not accepting charge. I tried everything. When off, I plug it in and it turns on so i knew it was at least seeing it plugged it. SO i tried prally 50 times to plug in and out, and it beeped but I unplugged it too fast... tried some more and finally left it in after a beep. Since then the issue has never resolved but i got it plugged into and recognize on computer after about 1000 tries it think(some reason it will randomly pick it up normally) and got it updated to ios 5. It still has the charge issue, however it charges when off(slowly) and when staring at slide to unlock... its will blink funny when plugged in but not charging so it is responding to it kinda...

  20. #20
    H4CK3R's Avatar
    Join Date
    Jan 2012
    Location
    java.lang.IllegalStateException: Location unknown.
    Posts
    5,833
    Thanks
    63
    Thanked 264 Times in 253 Posts

    I have a feeling it's hardware issues, that's not normal at all. I'd try taking it to an Apple Store and see what they say.
    Great minds discuss ideas.
    Average minds discuss events.
    Small minds discuss people.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts