Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: AppIconMask issue; unable to restore to the original correctly

  1. #1
    Default AppIconMask issue; unable to restore to the original correctly
    Hello everyone, I'm new to the forums, so I'm not too sure if this is the correct forum to be posting this question/problem. If it is not, please do guide me to the right section so I won't make the same mistake again . I am currently using iPhone 4, on 4.3.2 firmware, jailbroken with sn0wbreeze.

    Let's get to the problem.

    Recently, I had changed my theme with WinterBoard to Glasklart HD, and proceeded to change the [email protected]'s name to [email protected] to remove the black opaque icon issue. With this done, all the unthemed icons will be squares.

    However, now that I want to change back to the original theme, I changed the name of [email protected] back to [email protected], the square icons issue still remains.

    Also, whenever the icons are pressed, a semi-transparent black square appears on top of them instead of just icon itself. It is as though the alpha channels of the [email protected] is not being properly recognized.

    I have already tried deleting the cache, as well as trying out different [email protected] files, they look fine with image viewers, but they they all don't work at all.

    Here are screenshots to help identify the problem:

    The black square on the icon's pushed state.


    The square icons.


    Screenshot of winSCP to show that the [email protected] is there in the folder.

    May I get a solution to rectify this issue as well as what is causing the problem? Many thanks in advance!

  2. #2

  3. #3
    I have this issue myself if I copy the files on my iDevice to the desktop using iFunBox and then copy them back after a restore. Although, if I used the original that was saved from Photoshop (The PNG of course) and upload that to the phone, it's fine.

    I think it's a bug with the 'iPhone PNG to Computer PNG' conversion tools that are available. I believe it just needs to be resaved with an app like Photoshop or GIMP, but I haven't tried it myself.

  4. #4
    Quote Originally Posted by WaLLy3K View Post
    I have this issue myself if I copy the files on my iDevice to the desktop using iFunBox and then copy them back after a restore. Although, if I used the original that was saved from Photoshop (The PNG of course) and upload that to the phone, it's fine.

    I think it's a bug with the 'iPhone PNG to Computer PNG' conversion tools that are available. I believe it just needs to be resaved with an app like Photoshop or GIMP, but I haven't tried it myself.
    Aye, it's been fixed, thanks for the reply it was fixed by flattening the image in photoshop and saving it.

  5. #5
    Sorry to drag open an old thread - it's just i have the exact same issue today - right now, i have 4 files i dragged to my desktop (the ORIGINAL files from the phone) to see if the square icons would bother me, they did but when i placed the 4 files back....... it didn't work. Icons are still square.
    I'm not sure quite what you guys meant to i opened the AppIconMask@2x~iphone.png into photoshop, clicked "flatten image" and saved it (new filename to preserve the original files) and saved that back onto the iphone but naming it back to the original filename in the phone and still square icons.
    Can you do over this for one once more in more detail on how to fix this?
    More details are here - Reversing a change isn't working!

    Thanks.

  6. #6
    This was correct - i had to flatten all FOUR images, save using the save for web and devices, reimporting with ifunbox was fine ... what a hassle hey!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •