+ Reply
Results 1 to 20 of 20

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4, 4.3.2 Won't connect to computer?

is a discussion within the

General iPhone Chat

forums, a part of the

iPhone Modding

section;
Yo I've had no problems with my i4, running 4.3.2, it is Jailbroken redsn0w. However recently I haven't been able to connect it to my computer, i've used 3 different
...
  1. #1
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Default iPhone 4, 4.3.2 Won't connect to computer?
    Yo
    I've had no problems with my i4, running 4.3.2, it is Jailbroken redsn0w. However recently I haven't been able to connect it to my computer, i've used 3 different USB cables, and have tried different USB ports and restarting the computer... Anybody have any ideas that might work?

  2. #2
    What's Jailbreak?
    Join Date
    Jun 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    what error are u getting when u connect? i had same issue and needed to update the usb controlers in device manager because i had a htc desire rooting app that changed the usbhost controlers u may need to reinstall them using the orignal windows cd repair function tool

  3. #3
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by DrSt01NeR View Post
    what error are u getting when u connect? i had same issue and needed to update the usb controlers in device manager because i had a htc desire rooting app that changed the usbhost controlers u may need to reinstall them using the orignal windows cd repair function tool
    I'm nOt getting any errors it won't even realize that it's connected, no pop ups or anything :/

  4. #4
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Have you tried reinstalling iTunes?

  5. #5
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by Str4y View Post
    Have you tried reinstalling iTunes?
    I haven't tried reinstalling completely. I upgraded to the newest version. I'll try uninstalling then reinstalling it now

    I just removed all Apple programs from my computer, and then reinstalled iTunes.
    Plugged in my iPhone and nothing happened...
    Last edited by tinymech; 06-09-2011 at 05:47 PM.

  6. #6
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Do you have another computer to try it on?

  7. #7
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Quote Originally Posted by Str4y View Post
    Do you have another computer to try it on?
    I've tried it on 3 different computers

  8. #8
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Ok I would try this. Connect the phone into the computer. Then hold the power and home button for 10 seconds. After the 10 seconds continue to hold onto the home button but not the power. If the computer detects it, I am afraid you will need to restore. You are not unlocked correct?

  9. The Following User Says Thank You to Stray For This Useful Post:

    tinymech (06-09-2011)

  10. #9
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    So, just see if I can't have the phone be detected in DFU mode is that what you're asking?
    And no, my phone isn't unlocked. Just jailbroken.

    I'll try the DFU mode trick you said now

  11. #10
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    alright and yes i want to see if the phone will be detected in dfu mode

  12. The Following User Says Thank You to Stray For This Useful Post:

    tinymech (06-09-2011)

  13. #11
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    I just went into recovery mode and it detected it!
    Huzzah thats progress ;_;

  14. #12
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Yup! Was there any tweak that you had installed prior to the issue?

  15. The Following User Says Thank You to Stray For This Useful Post:

    tinymech (06-09-2011)

  16. #13
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    The most recent tweak I believe I installed was ToneFXS

    I used recboot to kick out so that I can make a list of everything I need to put back on the phone, what a surprise when I Exited Recovery the computer stopped recognizing...
    I'm gonna try uninstalling ToneFXS now

  17. #14
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Yeah try uninstalling it. It could be conflicting with the drivers or something

  18. #15
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    It didn't do anything, the phone still isn't showing up after re-spring. I guess I'll just make a list of everything that I'm gonna need to get back on here, and SSH off all my GBA roms.

    Thanks for the help man

  19. #16
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Ok. Best of luck! No problem.

  20. #17
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Taking... so long... to SSH everything

  21. #18
    Green Apple
    Join Date
    Nov 2010
    Posts
    34
    Thanks
    5
    Thanked 0 Times in 0 Posts

    So, I tried to restore, and it gave me error 1013. So I took off the cydia hosts. Since then its been giving me Error 3194. I'm a sad panda

  22. #19
    Livin the iPhone Life Stray's Avatar
    Join Date
    Oct 2010
    Location
    You Know...
    Posts
    14,067
    Thanks
    675
    Thanked 1,357 Times in 1,074 Posts

    Put the cydia hosts back on. Then click fix recovery. Try restoring again.

  23. #20
    What's Jailbreak?
    Join Date
    May 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I know this is old, but it is one of the first results on google when I searched for this problem, and I wanted to share the way I fixed it.

    If you are jailbroken, go into SBSettings options ('more' in the dropdown menu), then scroll down to system options and turn 'Apple Killswitch' OFF.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts